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Evaluation

PART - I

Choose the correct answer

1.	 ________ refers to any type of application that 
involves more than one type of media such as 
text, graphics video animation and sound
(a)	 an executable file
(b)	 desktop publishing
(c)	 multimedia		  (d)	 hypertext

� [Ans. (c) multimedia]

2.	 One of the disadvantages of the multimedia is 
its __________.
(a)	 cost			   (b)	 adaptability
(c)	 usability			  (d)	 relativity

� [Ans. (a) cost]

3.	 Expand JPEG 
(a)	 Joint Photo Experts Gross
(b)	 Joint Photographic Experts Group
(c)	 Joint Processor Experts Group
(d)	 Joint Photographic Expression Group

� [Ans. (b) Joint Photographic Experts Group]

4.	 You need hardware, software and ________ to 
make multimedia
(a)	 network
(b)	 compact disk drive
(c)	 good idea
(d)	 programming knowledge

� [Ans. (c) good idea]

5.	 Match the following by choosing the right one
1.	 Text 	 –	 TGA
2.	 Image 	 –	 MIDI
3.	 Sound 	 –	 MPEG
4.	 Video 	 –	 RTF
(a)	 1, 2, 3, 4 			  (b)	 2, 3, 4, 1
(c)	 4, 1, 2, 3			   (d)	 3, 4, 1, 2

� [Ans. (b) 2, 3, 4, 1]

6.	 Find the odd one on the following which is not 
an image format
(a)	 TIFF			   (b)	 BMP
(c)	 RTF 			   (d)	 JPEG

� [Ans. (c) RTF]

7.	 _______ is the process displaying still images 
they give continuous movement
(a)	 Text formats		  (b)	 Sound
(c)	 MP3			   (d)	 Animation

� [Ans. (d) Animation]

8.	 The live telecasting of real time program 
through Internet is known as ____
(a)	 web casting		  (b)	 web hosting
(c)	 data manipulation	 (d)	 none of the above

� [Ans. (a) web casting]

9.	 GIF use _______ color look up table
(a)	 8 bit			   (b)	 8 KB
(c)	 8 MB			   (d)	 8 GB

� * [Ans. 13 bit]

10.	 RTF file format was introduced by ______
(a)	 TCS			   (b)	 Microsoft
(c)	 Apple			   (d)	 IBM

� [Ans. (b) Microsoft]

PART - II

Short Answers

1.	 Define Multimedia and their features.
Ans. (i)	 The word multimedia consists of two 

words “multi” and “media” which means 
that multiple forms of media are combined 
to gather and provide services like storage, 
communication, presentation and Input/ 
output interactions of text, video, image, 
graphics and audio.

(ii)	 The term multimedia comprises of two 
words, “multi” and “medium”. Multi refers 
to many i.e. at least two.

(iii)	 Media is the plural of medium. Therefore 
multimedia is an integration of many types 
of media like text, graphics, images, audio, 
animation, video etc on a single medium in 
the same information unit.
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2.	 List out Multimedia Components.
Ans.	Multimedia has five major components like text, 

images, sound, video and animation. They are 
explained in detail below:

Components of Multimedia

3.	 Classify the TEXT component in multimedia
Ans. (i)	 Static Text

(ii)	 Hyper Text
4.	 Classify the IMAGE component in multimedia.
Ans. (i)	 Raster or Bitmap Images

(ii)	 Vector Images
5.	 Define Animation and their features.
Ans. (i)	 Animation is the process displaying still 

images so quickly so that they give the 
impression of continuous movement. In 
animation the screen object is a vector 
image in animation. 

(ii)	 Using numerical transformations the 
movement of that image along its paths is 
calculated for their defining coordinates.

(iii)	 The least frame rate of at least 16 frames per 
second gives the impression of smoothness 
and for natural looking it should be atleast 
25 frames per second.

(iv)	 Animations may be in two or three 
dimensional. The two dimensional 
animation, bring an image alive, that occur 
on the flat X and Y axis of the screen. 

(v)	 While in three dimensional animation 
it occurs along the three axis X, Y and Z. 
Animation tools are very powerful and 
effective.

6.	 List out image file formats.
Ans. (i)	 TIFF	– Tagged Image File Format

(ii)	 BMP	– Bitmap
(iii)	 DIB	 – Device Independent Bitmap
(iv)	 GIF	 – Graphic Interchange Format
(v)	 JPEG – Joint Photographic Experts Group
(vi)	 TGA	– Tagra
(vii)	 PNG	– Portable Network Graphics

7.	 List out audio file formats.
Ans. (i)	 WAV	– Wave form Audiofile   Format

(ii)	 MP3	– MPEG Layer - 3 Format
(iii)	 OGG
(iv)	 AIFF	– Audio Interchange File Format
(v)	 WMA – Windows Media Audio
(vi)	 RA	 – Real Audio Format

8.	 List out video file formats.
Ans. (i)	 AVI	 – Audio / Video Interleave

(ii)	 MPEG – Moving Picture Experts Group
9.	 Define Multimedia Production.
Ans.	Multimedia production assures that the 

multimedia project will be proceed smoothly 
and certainly ensures that the information 
reaches the target audience.

10.	 List out Multimedia Production team 
members.

Ans.	The team comprises of members playing various 
roles and responsibilities like Script writer, 
Production manager, Editor, Graphics Architect, 
Multimedia Architect and Web Master.

PART - III

Explain in Brief Answer

1.	 Briefly explain about Multimedia  
Components.

Ans.	Components of Multimedia:
Text :
(i)	 Text is the basic components of multimedia 

and most common ways of communicating 
information to other person.

(ii)	 Even though multimedia includes images, 
video, audio and graphics, Text is the basic 
components used in multimedia.

Image :
(i)	 Images acts as an vital component in 

multimedia.
(ii)	 These images are generated by the 

computer in two ways, as bitmap or raster 
images and as vector images.

Animation :
(i)	 Animation is the process displaying still 

images so quickly so that they give the 
impression of continuous movement.

(ii)	 In animation the screen object is a vector 
image in animation.
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Sound :
(i)	 Sound is a meaningful speech in any 

language and is the most serious element 
in multimedia, providing the pleasure of 
music, special effects and so on.

(ii)	 Decibels is the measurement of volume, 
the pressure level of sound.

Video :
(i)	 Video is defined as the display of recorded 

event, scene etc.
(ii)	 The powerful way to convey information 

in multimedia applications are embedding 
of video.

(iii)	 The video can be categorized in two types 
as Analog video and Digital video.

2.	 Describe the features and techniques of 
animation.

Ans. (i)	 Animation : Animation is the process of 
displaying still images so quickly so that 
they give the impression of continuous 
movement. In animation the screen object 
is a vector image in animation.

(ii)	 Path Animation : Path animation involves 
moving an object on a screen that has 
a constant background e.g. a cartoon 
character may move across the screen 
regardless of any change in the background 
or the character.

(iii)	 Frame Animation : In frame animations, 
multiple objects are allowed to travel 
simultaneously and the background or the 
objects also changes.

3.	 Write roles and responsibilities of Production 
team members.

Ans. (i)	 Production Manager: In a multimedia 
production, the role of production manager 
is to define, and coordinate, the production 
of the multimedia project in time and with 
full quality. 

(ii)	 Content Specialist: Content specialist is 
responsible for performing all research 
activities concerned with the proposed 
application’s content.

(iii)	 Script Writer: Video and film scripts 
represents a linear sequence of events. 
The script writer visualizes the concepts 
in three dimensional environments and if 
needed uses the virtual reality integration 
into the program.

4.	 Describe the various file formats in 
multimedia.

Ans.	File Formats for Multimedia: The following is 
an outline of current file formats used for the 
production and delivery of multimedia data.
Text Formats:

(i)	 RTF : Rich Text Format is the primary file 
format introduced in 1987 by Microsoft 
with the specification of their published 
products and for cross-platform documents 
interchange.

(ii)	 Plain text : Plain text files can be opened, 
read, and edited with most text editors.

Image Formats :
(i)	 TIFF (Tagged Image File Format): This 

format is common in desktop publishing 
world (high quality output), and is 
supported by almost all software packages.

(ii)	 BMP (Bitmap): Initially this format is in 
use with Windows 3.1.

(iii)	 DIB (Device Independent Bitmap) : This 
format which is similar to BMP, allows the 
files to be displayed on a variety of devices.

(iv)	 GIF (Graphics Interchange Format) : GIF 
is a compressed image format. Most of the 
computer color images and backgrounds 
are GIF files.

(v)	 JPEG (Joint Photographic Experts 
Group) : JPEG was designed to attain 
maximum image compression.

(vi)	 TGA (Tagra) : It is the first popular 
format for high-resolution images. TGA 
is supported by Most of the video-capture 
boards.

(vii)	 PNG (Portable Network Graphics): An 
extensible file format for the less loss, 
portable and well compressed storage of 
raster images.

5.	 Explain animation industry and their scopes.
Ans.	The Indian animation industry encompasses 

traditional 2D animation, 3D animation and 
visual effects for feature films. In 1956, Disney 
studios animator clair weeks who had worked 
on Bambi, was invited to Films Division of India 
in Mumbai to establish and train the country's 
first animation studio as part of the American 
technical co-operation mission. He trained a 
core group of Indian animators, whose first 
production was a film called “The Banyan Deer”.
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Scope: 
The animation industry is growing at a very past 
face. It is now a multi-billion dollar industry 
generating a great deal of employment for those 
who have the passion for it. Big international 
studios and companies like Sony pictures, 
Turner Entertainment and Walt Disney are off 
shoring the development of animation content 
to India and already. Indian animation studies 
and production houses are jam packed with 
work be it outsourced from abroad or in-house 
projects. Therefore, there is a talent crunch inthis 
industry and people are required to fill up these 
vacancies. 
Work opportunitites for quality animators and 
related professinals like graphic designers, 
multimedia, developers, game developers, 
character designers, key frame animators, 3D 
modelers, layout artists etc.

PART - IV

Explain in Detail:� (5 marks)
1.	 Explain in detail Process of Multimedia.
Ans.	(1)	 Conceptual Analysis and Planning :

(i)	 The process of multimedia making 
begins with a conceptual ignition 
point.

(ii)	 Conceptual analysis identifies a 
appropriate theme, budget and 
content availability on that selected 
theme.

(iii)	 Additional criteria like copyright 
issues also are considered in this 
phase.

(2)	 Project design :
(i)	 Once the theme is finalized objectives, 

goals, and activities are drawn for the 
multimedia project. 

(ii)	 General statements are termed as 
goals. The specific statements in the 
project is known as the objectives.

(iii)	 Activities are series of actions 
performed to implement an objective. 
These activities contribute to the 
Project design phase.

(3)	 Pre-production :
	� Based on the planning and design, it is 

necessary to develop the project.
(4)	 Budgeting : 
	 Budgeting for each phases like consultants, 

hardware, software, travel, communication 
and publishing is estimated for all the 
multimedia projects.

(5)	 Multimedia Production Team :
(i)	 The production team for a high end 

multimedia project requires a team 
efforts. 

(ii)	 The team comprises of members 
playing various roles and 
responsibilities like Script writer, 
Production manager, Editor, Graphics 
Architect, Multimedia Architect and 
Web Master.

(6)	 Hardware/Software Selection :
(i)	 All multimedia Application requires 

appropriate tools to develop and 
playback the application. 

(ii)	 Hardware includes the selection of 
fastest CPU, RAM and huge monitors, 
sufficient disc for storing the records.

(iii)	 Selection of the suitable software 
and file formats depends on the 
funds available for the project being 
developed.

2.	 Explain in detail Techniques of Animation.
Ans.	Animation :

(i)	 Animation is the process of displaying 
still images so quickly so that they give the 
impression of continuous movement.

(ii)	 In animation the screen object is a vector 
image in animation.

(iii)	 Using numerical transformations the 
movement of that image along its paths is 
calculated for their defining coordinates. 

(iv)	 The least frame rate of at least 16 frames per 
second gives the impression of smoothness 
and for natural looking it should be at least 
25 frames per second.

(v)	 Animations may be in two or three 
dimensional.
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(vi)	 The two dimensional animation, bring an 
image alive, that occur on the flat X and Y 
axis of the screen.

(vii)	 While in three dimensional animation 
it occurs along the three axis X, Y and Z. 
Animation tools are very powerful and 
effective.

(viii)	The two basic types of animations are Path 
animation and Frame animation. 

Path Animation :
(i)	 Path animation involves moving an object 

on a screen that has a constant background.
(ii)	 E.g. a cartoon character may move across 

the screen regardless of any change in the 
background or the character.

Frame Animation :
In frame animations, multiple objects are allowed 
to travel simultaneously and the background or 
the objects also changes.

3.	 Explore the opportunities Animation field 
movie industry.

Ans.	3D Modeler, Animator, Art Director, Film and 
Video Editor, Flash Animator, Graphic Designer, 
Stop Motion Animator, Video game Designer, 
Animation Director, Background Painter, 
Character Animator, Cartoonist, Character 
Rigger Color Key Artist, Compositing Artist, 
Concept Artist, Digital Painter, Director, Effects 
Animator, Forensic Animator, Independent 
film maker, Key Animator, Lighting Technician, 
Mathematical Modeler, Render Wrangler 
Storyboard Artist, Texture Artist, Visual 
Development Artist. 

4.	 Explain in detail about production team Roles 
and Responsibilities.

Ans.	Production Manager:
(i)	 In a multimedia production, the role 

of production manager is to define, 
and coordinate, the production of the 
multimedia project in time and with full 
quality. 

(ii)	 The production manager should be an 
expertise in the technology expert, good 
at proposal writing, good communication 
skills and budget management skills.

(iii)	 Also must have experience in human 
resource management and act as an 
efficient team leader.

Content Specialist :
(i)	 Content specialist is responsible for 

performing all research activities 
concerned with the proposed application’s 
content.

(ii)	 Program content refers to projects 
information, graphics, data or facts 
presented through the multimedia 
production.

Script Writer :
(i)	 Video and film scripts represents a linear 

sequence of events.
(ii)	 The script writer visualizes the concepts 

in three dimensional environments and if 
needed uses the virtual reality integration 
into the program.

Text Editor : 
(i)	 The content of a multimedia production 

always must flow logically and the text 
should always be structured and correct 
grammatically.

(ii)	 Text and narration is an integrated part of 
the application.

Multimedia Architect :
The multimedia architect integrates all the 
multimedia building blocks like graphics, text, 
audio, music, video, photos and animation by 
using an authoring software.
Computer Graphic Artist :
The role of Computer Graphic Artist is to deal 
with the graphic elements of the programs like 
backgrounds, bullets, buttons, pictures editing, 
3-D objects, animation, and logos etc.
Audio and Video Specialist :

(i)	 The roles of these specialists are needed for 
dealing with narration and digitized videos 
to be added in a multimedia presentation. 

(ii)	 They are responsible for recording, editing 
sound effects and digitizing.

5.	 Explain about different file formats in 
multimedia files.

Ans.	File Formats for Multimedia : The following 
is an outline of current file formats used for the 
production and delivery of multimedia data.
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(1)	 Text Formats:
RTF :
	Rich Text Format is the primary file format 
introduced in 1987 by Microsoft with the 
specification of their published products and for 
cross-platform documents interchange.
Plain text :

(i)	 Plain text files can be opened, read, and 
edited with most text editors.

(ii)	 Commonly used are Notepad (Windows), 
Gedit or nano (Unix, Linux), TextEdit 
(Mac OSX) and so on.

(2)	 Image Formats :
TIFF (Tagged Image File Format) :

(i)	 This format is common in desktop 
publishing world (high quality output), 
and is supported by almost all software 
packages.

(ii)	 Recent versions of TIFF allows image 
compression, and the format is comfortable 
for moving large files between computers.

DIB (Device Independent Bitmap) :
This format which is similar to BMP, allows the 
files to be displayed on a variety of devices.
GIF (Graphics Interchange Format) :

(i)	 GIF is a compressed image format. 
Most of the computer color images and 
backgrounds are GIF files.

(ii)	 This file format is best suitable for graphics 
that uses only limited colors, and it is the 
most popular format used for online color 
photos.

TGA (Tagra) :
It is the first popular format for high-resolution 
images. TGA is supported by Most of the video-
capture boards.

PNG (Portable Network Graphics) :
(i)	 An extensible file format for the less loss, 

portable and well compressed storage of 
raster images.

(ii)	 PNG acts as replacement for GIF and also 
replaces multiple common uses of TIFF. 

(iii)	 PNG works good with online viewing 
applications like worldwide web. So it is 
fully streameable with a best display option.

(3)	 Digital Audio File Formats :
WAV (Waveform Audio File Format)

(i)	 WAV is the most popular audio file format 
in windows for storing uncompressed 
sound files.

(ii)	 In order to attain the reduced file size it can 
also be converted to other file formats like 
MP3.

MP3 (MPEG Layer-3 Format) :
(i)	 MPEG Layer-3 format is the most popular 

format for storing and downloading music.
(ii)	 The MP3 files are roughly compressed to 

one-tenth the size of an equivalent WAV 
file.

(4)	 Digital Video File Formats :
AVI (Audio/Video Interleave) :
	 AVI is the video file format for Windows. 

Here sound and picture elements are stored 
in alternate interleaved chunks in the file.

MPEG (Moving Picture Experts Group) : 
(i)	 MPEG is a standard for generating digital 

video and audio compression under the 
International Standards Organization 
(ISO) by the group of people. 

(ii)	 Simply MPEG is the standards for digital 
video and audio compression.
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additional questions and answers

Choose the Correct Answer� 1 MARK 
1.	 Which of the following is not a multimedia 

source?
(a)	 Text			   (b)	 Pagemaker
(c)	 Graphics 		  (d)	 Video
� [Ans. (b) Pagemaker]

2.	 Which of the following is becoming more 
popular among the user in the terms of its uses  
and applications?
(a)	 Multimedia		  (b)	 Pagemaker
(c)	 Computer		  (d)	 Images
� [Ans. (a) Multimedia]

3.	 Multiple forms of media are combined 
together called
(a)	 Media
(b)	 Computerized applications
(c)	 Image media		
(d)	 Multimedia
� [Ans. (d) Multimedia]

4.	 How many major components are there in 
multimedia?
(a)	 4	 (b)	 3	 (c)	 5	 (d)	 2
� [Ans. (c) 5]

5.	 Which of the following is not a major 
component of multimedia?
(a)	 Text			   (b)	 Pagemaker
(c)	 Video			   (d)	 Animation
� [Ans. (b) Pagemaker]

6.	 Which of the following is not a dynamic 
element of multimedia?
(a)	 Video			   (b)	 Animation
(c)	 Audio			   (d)	 Text
� [Ans. (d) Text]

7.	 Which of the following is a static element?
(a)	 Graphics			  (b)	 Video
(c)	 Animation		  (d)	 Audio
� [Ans. (a) Graphics]

8.	 How many types of elements are there in 
multimedia?
(a)	 3	 (b)	 4	 (c)	 2	 (d)	 5
� [Ans. (c) 2]

9.	 Which of the following is a basic components 
of multimedia?
(a)	 Video			   (b)	 Text
(c)	 Graphics			  (d)	 Audio
� [Ans. (b) Text]

10.	 The most common ways of communicating 
information to other person is 
(a)	 Audio			   (b)	 Text
(c)	 Graphics			  (d)	 Images
� [Ans. (b) Text]

11.	 How many types of text used in multimedia?
(a)	 4	 (b)	 3	 (c)	 2	 (d)	 5
� [Ans. (c) 2]

12.	 Which of the following type of text not used in 
multimedia?
(i)	 Static Text	 (ii)	 Hyper Text
(iii)	Multi Text	 (iv)	 Interactive Text
(a)	 i, ii			   (b)	 ii
(c)	 iii			   (d)	 iii and iv
� [Ans. (d) iii and iv]

13.	 Which of the following text will give 
information or support an image or an video?
(a)	 Static			   (b)	 Hyper
(c)	 Multi			   (d)	 Information
� [Ans. (a) Static]

14.	 Which text defines the paths the user need to 
follow for the text access in non-sequential 
ways?
(a)	 Static			   (b)	 Multi
(c)	 Hyper			   (d)	 None of these
� [Ans. (c) Hyper]

15.	 Which of the following acts as an vital 
component in multimedia?
(a)	 Text			   (b)	 Image
(c)	 Video			   (d)	 Audio
� [Ans. (b) Image]

16.	 How many ways the images are generated by 
the computer?
(a)	 4	 (b)	 5	 (c)	 3	 (d)	 2
� [Ans. (d) 2]
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17.	 Which of the following is a type of image not 
generated by computer?
(a)	 Bitmap			   (b)	 Raster
(c)	 Hyper			   (d)	 Vector
� [Ans. (c) Hyper]

18.	 The common form of storing images in a 
computer is 
(a)	 Raster			   (b)	 Bitmap
(c)	 Vector			   (d)	 a or b
� [Ans. (d) a or b]

19.	 The image formed by pixel is
(a)	 Bitmap			   (b)	 Vector
(c)	 GIF			   (d)	 JPG
� [Ans. (a) Bitmap

20.	 How many colors are there in each pixel?
(a)	 1			   (b)	 2
(c)	 256			   (d)	 more
� [Ans. (d) more]

21.	 Which of the following is used to determine 
the number of colors in images?
(a)	 Bits			   (b)	 Bytes
(c)	 Megabytes		  (d)	 Gigabytes
� [Ans. (a) Bits]

22.	 Which types of image is used to create line, 
rectangle?
(a)	 Raster			   (b)	 Vector
(c)	 Bitmap			   (d)	 GIF
� [Ans. (b) Vector]

23.	 Which types of images is useful for storing large 
number of images and speeding transmission 
for network application?
(a)	 Raster			   (b)	 Bitmap
(c)	 Animated Gif	 (d)	 Vector
� [Ans. (d) Vector]

24.	 Which of the following is not a compression 
format image?
(a)	 GIF			   (b)	 MPEG
(c)	 TIFF			   (d)	 JPEG
� [Ans. (b) MPEG]

25.	 Which of the following is the process displaying 
still images in continuous movement?
(a)	 Images			   (b)	 Graphics
(c)	 Animation		  (d)	 Video
� [Ans. (c) Animation]

26.	 The least frame rate that gives the impression 
of animation smoothness is 
(a)	 16	 (b)	 25	 (c)	 9	 (d)	 20
� [Ans. (a) 16]

27.	 The least frame rate that gives the impression 
of animation in natural is 
(a)	 16	 (b)	 25	 (c)	 20	 (d)	 21
� [Ans. (b) 25]

28.	 How many types of animation are there?
(a)	 1	 (b)	 2	 (c)	 3	 (d)	 5
� [Ans. (b) 2]

29.	 Which of the following is not a types of 
animation?
(a)	 Vector			   (b)	 Path
(c)	 Frame			   (d)	 All of these
� [Ans. (a) Vector]

30.	 Which tools are very powerful and effective?
(a)	 Animation		  (b)	 Image
(c)	 Text			   (d)	 None of these
� [Ans. (a) Animation]

31.	 Which type of animation involves moving 
an object on a screen that has a constant 
background?
(a)	 Frame			   (b)	 Static
(c)	 Dynamic		  (d)	 Path
� [Ans. (d) Path]

32.	 In which type of animation there is not change 
in the background?
(a)	 Frame			   (b)	 Path
(c)	 Dynamic		  (d)	 Vector
� [Ans. (b) Path]

33.	 In which type of animations, multiple objects 
are allowed to travel simultaneously?
(a)	 Vector			   (b)	 Raster
(c)	 Frame			   (d)	 Path
� [Ans. (c) Frame]

34.	 In which type of animation, the background 
changes according to the object?
(a)	 Frame			   (b)	 Vector
(c)	 Raster			   (d)	 Path
� [Ans. (a) Frame]
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35.	 Which of the following is the most serious 
element in multimedia?
(a)	 Text			   (b)	 Image
(c)	 Animation		  (d)	 Sound
� [Ans. (d) Sound]

36.	 The pressure level of sound is
(a)	 Frequency 		  (b)	 Decibels
(c)	 Analog			   (d)	 Digital
� [Ans. (b) Decibels]

37.	 Which of the following is a meaning full 
speech in any language?
(a)	 Animation		  (b)	 Sound
(c)	 Image			   (d)	 Graphics
� [Ans. (b) Sound]

38.	 MIDI expansion is
(a)	 Musical Instrument Digital Information
(b)	 Musical Information Digital Instrument
(c)	 Musical Instrument Digital Interface
(d)	 Musical Information Digital Interface
� [Ans. (c) Musical Instrument Digital 

Interface]

39.	 Which of the following is a standard 
communication tool developed for computers 
and electronic instruments?
(a)	 MIDI			   (b)	 MPEG
(c)	 MPG			   (d)	 MP3
� [Ans. (a) MIDI]

40.	 Which tools is flexible and easy for composing 
the projects in multimedia?
(a)	 AIFF			   (b)	 TIFF
(c)	 AVI			   (d)	 MIDI
� [Ans. (d) MIDI]

41.	 Which of the following is taken and stored 
every nth fraction of a second as digital 
information?
(a)	 Sample of text	 (b)	 Sample of image
(c)	 Sample of sound	 (d)	 Animation
� [Ans. (c) Sample of sound]

42.	 Which of the following used to represent the 
value of each sound sample?
(a)	 bit depth			  (b)	 resolution
(c)	 Sample size		  (d)	 all of these
� [Ans. (d) all of these]

43.	 Which of the following is a powerful way to 
convey information in multimedia?
(a)	 Audio			   (b)	 Image
(c)	 Video			   (d)	 Animation
� [Ans. (c) Video]

44.	 How many types the video can be categorized?
(a)	 2	 (b)	 3	 (c)	 4	 (d)	 5
� [Ans. (a) 2]

45.	 Which of the following is not a type of video?
(i)	 Sampled video	 (ii)	 Digital video
(iii)	Embedded video	 (iv)	Analog video
(a)	 i, ii			   (b)	 ii, iii
(c)	 ii, iv			   (d)	 iii, i
� [Ans. (d) iii, i]

46.	 Video tape, laserdisc, film are the example of 
(a)	 Analog video		 (b)	 Digital video
(c)	 Embedded video	 (d)	 Sampled video
� [Ans. (a) Analog video]

47.	 How many types of analog video are there?
(a)	 3	 (b)	 4	 (c)	 2	 (d)	 5
� [Ans. (c) 2]

48.	 Which of the following is not a type of a 
Analog video?
(a)	 Composite		  (b)	 Synchronized
(c)	 Component		  (d)	 all of these
� [Ans. (b) Synchronized]

49.	 Which of the following video components  are 
combined to form an analog video?
(a)	 Brightness		  (b)	 Color
(c)	 Synchronization	 (d)	 All of these
� [Ans. (d) All of these

50.	 The quality of the composite video resulted in 
(a)	 Color blending	 (b)	 Low clarity
(c)	 High Generational Loss	
(d)	 All of these� [Ans. (d) All of these]

51.	 Betmax and VHS video formats are an example 
of
(a)	 Component video	
(b)	 Blended Video
(c)	 Composite Analog Video
(d)	 Digital Video
� [Ans. (c) Composite Analog Video]
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52.	 Expansion of RTF is
(a)	 Rich Text Format	
(b)	 Raster Text Format
(c)	 Rich Tele Format	
(d)	 Rich Text Form�[Ans. (a) Rich Text Format]

53.	 RTF introduced in the year
(a)	 1977			   (b)	 1987
(c)	 1997			   (d)	 1981
� [Ans. (b) 1987]

54.	 Which text files can be opend in most of the 
editors?
(a)	 Ms-word file		 (b)	 RTF
(c)	 Plain			   (d)	 TIFF
� [Ans. (c) Plain]

55.	 Which of the following is not a text editor?
(a)	 Credit			   (b)	 nano
(c)	 Text edit			  (d)	 Pagemaker
� [Ans. (d) Pagemaker]

56.	 The popular way of conveying an email using
(a)	 Rich text file		  (b)	 Plain text
(c)	 Composite text	 (d)	 Digital text
� [Ans. (b) Plain text]

57.	 Expansion of TIFF is
(a)	 Text Image File Format
(b)	 Text Information Format File
(c)	 Tagged Image File Format
(d)	 Tagged Image Format File
� [Ans. (c) Tagged Image File Format]

58.	 Which of the following image format is 
common is DTP world?
(a)	 BMP			   (b)	 TIFF
(c)	 GIF			   (d)	 DIB
� [Ans. (b) TIFF]

59.	 Which image format produces very high 
quality output?
(a)	 BMP			   (b)	 GIF
(c)	 DIB			   (d)	 TIFF
� [Ans. (d) TIFF]

60.	 Which of the following image format is 
comfortable for moving large files between 
computers?
(a)	 TIFF			   (b)	 DIB
(c)	 JPEG			   (d)	 TGA
� [Ans. (a) TIFF]

61.	 Which of the following image format used in 
windows 3.1?
(a)	 TIFF			   (b)	 TGA
(c)	 BMP			   (d)	 JPEG
� [Ans. (c) BMP]

62.	 Which image format used for the high-
resolution or large images?
(a)	 TIFF			   (b)	 BMP
(c)	 TGA			   (d)	 DIB
� [Ans. (b) BMP]

63.	 Which of the following image format is similar 
to BMP?
(a)	 DIB			   (b)	 TGA
(c)	 BMP			   (d)	 TIFF
� [Ans. (a) DIB]

64.	 DIB image format is similar to
(a)	 TGA			   (b)	 JPEG
(c)	 BMP			   (d)	 PNG
� [Ans. (c) BMP]

65.	 DIB expansion is
(a)	 Digital Independent Bitmap
(b)	 Device Information Bitmap
(c)	 Device Image Bitmap
(d)	 Device Independent Bitmap
� [Ans. (d) Device Independent Bitmap]

66.	 Which of the following is not a compressed 
image format?
(a)	 TIFF			   (b)	 GIF
(c)	 JPEG			   (d)	 PNG
� [Ans. (a) TIFF]

67.	 GIF expansion is
(a)	 Graphics Image Format
(b)	 Graphics Independent Format
(c)	 Graphics Interchange Format
(d)	 Graphics Information Format
� [Ans. (c) Graphics Interchange Format]

68.	 The widely supported image format is 
(a)	 GIF			   (b)	 TIFF
(c)	 PNG			   (d)	 BMP
� [Ans. (a) GIF]
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69.	 Which image format was designed to attain 
maximum image compression?
(a)	 GIF			   (b)	 PNG
(c)	 JPEG			   (d)	 TIFF
� [Ans. (c) JPEG]

70.	 Which of the following image uses lossy 
compression technique?
(a)	 JPEG			   (b)	 TIFF
(c)	 PNG			   (d)	 TGA
� [Ans. (a) JPEG]

71.	 Which image format works good with 
photographs, naturalistic artwork?
(a)	 GIF			   (b)	 TIFF
(c)	 JPEG			   (d)	 TGA
� [Ans. (c) JPEG]

72.	 Which image format is the first popular format 
for high resolution images?
(a)	 JPEG			   (b)	 TGA
(c)	 GIF			   (d)	 PNG
� [Ans. (b) TGA]

73.	 Which of the following first popular image 
format for high resolution images?
(a)	 TIFF			   (b)	 PNG
(c)	 JPEG			   (d)	 TGA
� [Ans. (d) TGA]

74.	 Expand TGA
(a)	 Tagged Graphics Animation
(b)	 Tagra
(c)	 Text Graphics Animation
(d)	 Tagra Graphics Animation
� [Ans. (b) Tagra]

75.	 Which image format is supported by most of 
the video capture boards?
(a)	 TGA			   (b)	 TIFF
(c)	 PNG			   (d)	 None of these
� [Ans. (a) TGA]

76.	 Expand PNG
(a)	 Portable Node Graphics
(b)	 Positioned Network Graphics
(c)	 Portable Network Graphics
(d)	 PlainText Network Graphics
� [Ans. (c) Portable Network Graphics]

77.	 A well compressed storage of raster image is
(a)	 TIFF			   (b)	 JPEG
(c)	 GIF			   (d)	 PNG
� [Ans. (d) PNG]

78.	 Which image format acts as replacement for 
GIF?
(a)	 TIFF			   (b)	 PNG
(c)	 TGA			   (d)	 JPEG
� [Ans. (b) PNG]

79.	 Which image format replaces multiple 
common uses of TIFF?
(a)	 TGA			   (b)	 GIF
(c)	 PNG			   (d)	 JPEG
� [Ans. (b) GIF]

80.	 Which image format works good with online 
viewing applications?
(a)	 TIFF			   (b)	 GIF
(c)	 JPEG			   (d)	 PNG
� [Ans. (d) PNG]

81.	 Expand WAV
(a)	 Waveform Audio File Format
(b)	 Wave
(c)	 Wave Audio Video
(d)	 Wave Audio Visual
� [Ans. (a) Waveform Audio File Format]

82.	 Which Audio format is most popular in 
windows for storing uncompressed sound 
files?
(a)	 MP3			   (b)	 OGG
(c)	 WAV			   (d)	 RA
� [Ans. (c) WAV]

83.	 Find the odd man out
(a)	 TIFF			   (b)	 WAV
(c)	 PNG			   (d)	 TGA
� [Ans. (b) WAV]

84.	 Expand MP3
(a)	 MPEG Layer – 3 format
(b)	 MP Audio layer – 3 format
(c)	 MP layer – 3 format
(d)	 Multiplayer Audio layer – 3 format
� [Ans. (a) MPEG Layer – 3 format]
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85.	 Which of the following file compressed to one-
tenth the size of an equivalent WAV file?
(a)	 RA			   (b)	 WMA
(c)	 AIFF			   (d)	 None of these
� [Ans. (d) None of these]

86.	 Find the odd man out.
(a)	 WMA			   (b)	 WAV
(c)	 OGG			   (d)	 PNG
� [Ans. (c) OGG]

87.	 Which Audio format used by Apple?
(a)	 WAV			   (b)	 AIFF
(c)	 MP3			   (d)	 OGG
� [Ans. (b) AIFF]

88.	 Expand AIFF
(a)	 Audio Information File Format
(b)	 Audio Interleave File Format
(c)	 Audible Interchange File Format
(d)	 Audio Interchange File Format
� [Ans. (d) Audio Interchange File Format]

89.	 Expand WMA
(a)	 Waveform Media Audio
(b)	 Windows Media Audio
(c)	 Windows Multimedia Audio
(d)	 Waveform Multi Audio
� [Ans. (b) Windows Media Audio

90.	 Expand RA
(a)	 Raster Audio
(b)	 Real Digital Audio
(c)	 Real Audio Format
(d)	 Resource Audio
� [Ans. (c) Real Audio Format]

91.	 Find the odd man out
(a)	 WAV			   (b)	 WMA
(c)	 RA			   (d)	 MPEG
� [Ans. (d) MPEG]

92.	 Expand AVI
(a)	 Audio Video Interchange
(b)	 Audio Video Information
(c)	 Audio Video Interleave
(d)	 Audio Video Instrument
� [Ans. (c) Audio Video Interleave]

93.	 Expand MPEG
(a)	 Moving Picture Experts Group
(b)	 Motion Picture Experts Group
(c)	 Multimedia Picture Expansion Group
(d)	 Moving Picture Expansion Group
� [Ans. (a) Moving Picture Experts Group]

94.	 ISO Group has developed
(a)	 AVI			   (b)	 MPEG–1
(c)	 WMA			   (d)	 WAV
� [Ans. (b) MPEG – 1]

95.	 The MPEG standard on which video CD and 
MP3 are based
(a)	 MPEG – 1		  (b)	 MPEG – 2
(c)	 MPEG – 7		  (d)	 MPEG – 4
� [Ans. (a) MPEG – 1]

96.	 Which of the following video standard 
supports digital setup boxes and DVD?
(a)	 MPEG – 1		  (b)	 MPEG – 7
(c)	 MPEG – 2		  (d)	 MPEG – 4
� [Ans. (c) MPEG – 2]

97.	 Which of the following video standard for 
multimedia and mobile web?
(a)	 MPEG – 1		  (b)	 MPEG – 4
(c)	 MPEG – 2		  (d)	 MPEG – 7
� [Ans. (b) MPEG – 4]

98.	 Which of the following identifies appropriate 
multimedia theme, budget and content 
availability?
(a)	 Project Design	 (b)	 Pre-production
(c)	 Budgeting		
(d)	 Conceptual Analysis
� [Ans. (d) Conceptual Analysis]

99.	 Which of the following phase the copy right 
issues are considered?
(a)	 Project Design	
(b)	 Conceptual Analysis	
(c)	 Budgeting	
(d)	 Multimedia Production Team
� [Ans. (b) Conceptual Analysis]

100.	The specific statements in the multimedia 
project design is known as
(a)	 Objectives		  (b)	 goals
(c)	 activities			  (d)	 design
� [Ans. (a) objectives]
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101.	The General Statements in the multimedia 
project design is called
(a)	 objectives		  (b)	 goals
(c)	 production		  (d)	 activites
� [Ans. (b) goals]

102.	Find the odd man out
(a)	 Script writer		  (b)	 Webmaster
(c)	 System analyst	 (d)	 Editor
� [Ans. (c) System analyst]

103.	Who prepares the narration, bullets, charts 
and tables for multimedia application content?
(a)	 Application developer
(b)	 Project designer
(c)	 Web Master
(d)	 Content Specialist
� [Ans. (d) Content Specialist]

104.	In multimedia application, text is 
incorporated using the software.
(a)	 BCR			   (b)	 OCR
(c)	 MICR			   (d)	 OMR
� [Ans. (b) OCR]

105.	The more effective way of delivering 
multimedia application is 
(a)	 CD			   (b)	 DVD
(c)	 Internet			   (d)	 All of these
� [Ans. (d) All of these]

106.	Who is responsible to get maximum outcome 
with high degree of efficiency in multimedia 
production?
(a)	 Application Developer
(b)	 System Engineer
(c)	 Multimedia production team
(d)	 Content director
� [Ans. (c) Multimedia Production team]

107.	Who act as an efficient Team leader?
(a)	 Content Specialist	
(b)	 Production Manager
(c)	 Text Editor
(d)	 Computer Programmer
� [Ans. (b) Production Manager]

108.	Multimedia program content refers to
(a)	 Projects information	 (b)	 graphics
(c)	 data			   (d)	 all of these
� [Ans. (d) all of these]

109.	Who visualizes the multimedia concepts in 
3D environments? 
(a)	 Script Writer		 (b)	 Graphic Artist
(c)	 Web Master
(d)	 Multimedia Architect
� [Ans. (a) Script Writer]

110.	The multimedia text correct grammatically 
and structured by
(a)	 Script Writer		 (b)	 Text Editor
(c)	 Text Writer		
(d)	 Computer Programmer
� [Ans. (b) Text Editor]

111.	Who integrates all the multimedia elements 
using an authoring software?
(a)	 Computer Programmer
(b)	 Web master
(c)	 Multimedia Architect
(d)	 Computer Graphic Artist
� [Ans. (c) Multimedia Architect]

112.	Who writes the scripts for developing the 
software to give the size and shape of video 
windows?
(a)	 Computer Programmer
(b)	 Text Writer
(c)	 Scriptwriter
(d)	 Audio and Video specialist
� [Ans. (a) Computer Programmer]

113.	Which of the following is the most widely 
used multimedia resource on internet? 
(a)	 Video			   (b)	 Audio
(c)	 Image			   (d)	 Animation
� [Ans. (c) Image]

114.	Which of the following is launched in India for 
serving the educational sector of the country?
(a)	 Modulo			   (b)	 GMU
(c)	 Edusat			   (d)	 all of these
� [Ans. (c) Edusat]

115.	Which of the following is a free standing 
furnished equipped multimedia computer 
that allows users to receive information via 
touch screen?
(a)	 ATM			   (b)	 Kiosk
(c)	 Library			   (d)	 all of these
� [Ans. (b) Kiosk]
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116.	The live telecast of real time programs through 
internet is known as 
(a)	 Web mastering	 (b)	 Web browsing
(c)	 Web Surfing		  (d)	  Webcasting
� [Ans. (d) Webcasting]

117.	Which of the following is a digital format 
information?
(a)	 Digital books	 (b)	 Scanned Images
(c)	 Graphics and digitized audio-visual clips
(d)	 All of these
� [Ans. (d) All of these]

Choose and fill in the blanks

1.	 _________ has become the latest enriching 
experience in the field of information sector.
(a)	 Video			   (b)	 Graphics
(c)	 Multimedia		  (d)	 Presentation
� [Ans. (c) Multimedia]

2.	 8 colors = __________ bits.
(a)	 2	 (b)	 4	 (c)	 3	 (d)	 1
� [Ans. (c) 3]

3.	 In animation the screen object is a ________ 
image.
(a)	 Raster			   (b)	 Bitmap
(c)	 Vector			   (d)	 Static
� [Ans. (c) Vector]

4.	 _______ may be in two or three dimensional.
(a)	 Text			   (b)	 Image
(c)	 Audio			   (d)	 Animation
� [Ans. (d) Animation]

5.	 Tools for synthesizing the sound and software 
for sequencing are necessary for _______.
(a)	 RTF			   (b)	 TIFF
(c)	 AVI			   (d)	 MIDI
� [Ans. (d) MIDI]

6.	 Sampled sound is a __________ sound.
(a)	 Analog			   (b)	 Digitized
(c)	 Path			   (d)	 Dolby
� [Ans. (b) Digitized]

7.	 The quality of sound recording depend on the 
_________.
(a)	 Sampling rate	 (b)	 Digital rate
(c)	 Sampling sound	 (d)	 Digital sound
� [Ans. (a) Sampling rate]

8.	 __________ is defined as the display of 
recorded event.
(a)	 Animation		  (b)	 Video
(c)	 Graphics			  (d)	 Sampling
� [Ans. (b) Video]

9.	 Most of the computer color images and 
backgrounds are __________ image format.
(a)	 TIFF			   (b)	 GIF
(c)	 BMP			   (d)	 TGA
� [Ans. (b) GIF]

10.	 MP3 files are compressed to 1/10 the size of an 
equivalent __________ file.
(a)	 WAV			   (b)	 PNG
(c)	 RA			   (d)	 WMA 
� [Ans. (a) WAV]

11.	 The process of multimedia making begins 
with a ___________ point.
(a)	 Conceptual ignition	 (b)	 Pre-production
(c)	 Project design	 (d)	 Production Team
� [Ans. (a) Conceptual ignition]

12.	 ________ are the fields where multimedia is 
used in majority.
(a)	 Entertainment	 (b)	 Education
(c)	 E-Commerce	 (d)	 Engineering
� [Ans. (b) Education]

Very Short Answers� 2 MARKS
1.	 Define static text used in multimedia.
Ans.	Static text, the text or the words will remain 

static as a heading or in a line, or in a paragraph. 
The words are given along with the images to 
explain about the images. In static text the words 
will either give information or support an image 
or an video.

2.	 Describe the text which consists of nodes (or) 
Define Hyper text.

Ans.	A hypertext is a system which consists of nodes, 
the text and the links between the nodes, which 
defines the paths the user need to follow for the 
text access in non-sequential ways.

3.	 What is Raster or Bitmap Images?
Ans.	The common and comprehensive form of storing 

images in a computer is raster or bitmap image.

4.	 What is Bitmap?
Ans.	Bitmap is a simple matrix of the tiny dots called 

pixel that forms a raster or bitmap image.
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5.	 What does pixel consists? Explain.
Ans.	Pixel consists of two or more colors. Based on 

how much data, in bits is used to determine the 
number of colors, the color depth is determined.

6.	 What is vector images?
Ans.	Vector images is relatively small amount of data 

is required to represent the image and thereby 
only less memory is needed to store.

7.	 What is the use of compression technique to 
store the images?

Ans.	Compression techniques are used to reduce the 
file size of images that is useful for storing large 
number of images and speeding transmission for 
networked application. Various Compression 
formats used for this purpose are GIF, TIFF and 
JPEG.

8.	 What type of images created based on vector 
images?

Ans.	Drawing elements or objects such as lines, 
rectangles, circles are the images  created based 
on Vector images.

9.	 Name the two basic types of animation.
Ans.	The two basic types of animations are Path 

animation and Frame animation.

10.	 Write a note on path animation.
Ans.	Path animation involves moving an object on 

a screen that has a constant background e.g. a 
cartoon character may move across the screen 
regardless of any change in the background or 
the character.

11.	 What is sampled sound?
Ans.	Sampled sound is a Digitized sound. A sample of 

sound is taken and stored every nth fraction of a 
second as digital information in bits and bytes.

12.	 Define sampling rate.
Ans.	The quality of this recording depends on the 

sampling rate. Sampling rate is defined as how 
often the samples are taken and how many 
numbers are used to represent the value of each 
sample (bit depth, resolution and sample size).

13.	 Write the current file formats used for the 
production and delivery of multimedia data.

Ans. (i)	 Text formats
(ii)	 Image formats
(iii)	 Digital Audio and Video file formats

14.	 Write a note on RTF.
Ans.	Rich Text Format is the primary file format 

introduced in 1987 by Microsoft with the 
specification of their published products and for 
cross-platform documents interchange.

15.	 What are the text editors used to read /write 
plain text?

Ans.	Plain text files can be opened, read, and edited 
with most text editors commonly used are 
Notepad (Windows), Gedit or nano (Unix, 
Linux), TextEdit (Mac OS X).

16.	 Expand the following.
(i)	 RTF		  (ii) BMP
(iii) DIB		   (iv) GIF

Ans. (i)	 RTF	 – Rich Text Format
(ii)	 BMP	– Bitmap
(iii)	 DIB	 – Device Independent Bitmap
(iv)	 GIF	 – Graphics Interchange Format

17.	 Expand (i) JPEG	     (ii) TGA	 (iii) PNG
Ans. (i)	 JPEG	– Joint Photographic Experts Group

(ii)	 TGA	– Tagra
(iii)	 PNG	– Portable Network Graphics

18.	 Read the following statement and write the 
correct image file formats.
(i)	 Commonly used in desktop publishing 

world.
(ii)	 Quite large and uncompressed image 

format.
(iii)	Similar to BMP.
(iv)	 Most of the computer color images and 

backgrounds.
Ans. (i)	 TIFF

(ii)	 BMP
(iii)	 DIB
(iv)	 GIF

19.	 Expand	 (i) WAV	 (ii) MP3
(iii) AIFF (iv) WMA 	   (v) RA

Ans. (i)	 WAV	– Waveform Audiofile Format
(ii)	 MP3	– MPEG layer – 3 format
(iii)	 AIFF	– Audio Interchange File format
(iv)	 WMA– Windows Media Audio
(v)	 RA	 – Real Audio Format

20.	 Expand (i) AVI	 (ii) MPEG.
Ans. (i)	 AVI	   – Audio/Video Interleave

(ii)	 MPEG – Moving Picture Experts Group
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21.	 List the various fields where the multimedia 
used in majority. 

Ans. (i)	 Education
(ii)	 Entertainment
(iii)	 Business Systems
(iv)	 Medical Services
(v)	 Public Places
(vi)	 Multimedia Conferencing

22.	 List the multimedia technology application in 
libraries.

Ans. (i)	 Multimedia Kiosk
(ii)	 Webcasting and Video Conferencing 
(iii)	 User orientation Program
(iv)	 In-house production of multimedia 

resources and E-publishing 
(v)	 Digital Multimedia Libraries

23.	 What is Webcasting?
Ans.	The live telecast of real time programs through 

internet is known as Webcasting.

24.	 Define Video conferencing.
Ans.	Video conferencing is the process of conducting 

conference between more than two participants 
at different sites by using computer networks to 
transmit audio and video data.

25.	 List few digital multimedia libraries.
Ans.	Digital books, scanned images, graphics and 

digitized audio-visual clips 

26.	 Name the two types of video.
Ans.	Video can be categorized in two types as Analog 

video and Digital video.
Short Answers� 3 MARKS
1.	 Write a note on MIDI. 
Ans. (i)	 Musical Instrument Digital Identifier 

(MIDI) is a standard communication tool 
developed for computers and electronic 
instruments.

(ii)	 This tool is flexible and easy for composing 
the projects in multimedia.

(iii)	 Tools for synthesizing the sound and 
software for sequencing are necessary for 
MIDI.

2.	 What are the two types of Analog video? and 
explain it.

Ans. (i)	 In Analog video, the video data’s are stored 
in any non-computer media like video 
tape, laserdisc, film etc.

(ii)	 It is divided further in two types as 
Composite and Component Analogue 
Video. 

(iii)	 Composite Analog Video has all the video 
components like brightness, color, and 
synchronization combined into one signal. 

(iv)	 Due to the combining of the video 
components, the quality of the composite 
video resulted in color blending, low clarity 
and high generational loss.

(v)	 This recording format was used for 
customer analog video recording tape 
formats such as Betamax and VHS.

3.	 Write a note on GIF.
Ans. (i)	 GIF is a compressed image format. 

Most of the computer color images and 
backgrounds are GIF files. 

(ii)	 This file format is best suitable for graphics 
that uses only limited colors, and it is the 
most popular format used for online color 
photos.

(iii)	 13-bit Color look up table is used by the 
GIF format to identify its color values. This 
format is supported widely.

4.	 Write a note on JPEG.
Ans. (i)	 JPEG was designed to attain maximum 

image compression. 
(ii)	 It uses lossy compression technique, where 

a compression method is referred that 
loses some of the data required for the 
image reconstruction.

(iii)	 It works good with photographs, 
naturalistic artwork, and similar material 
but functions less on lettering, live 
drawings or simple cartoons.
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5.	 Read the following statement and write the 
correct image format files.
(i)	 Used lossy compression technique.
(ii)	 Supports most of the video captured 

boards.
(iii)	Acts as replacement to GIF
(iv)	 Replaces common uses of TIFF
(v)	 Comfortable for moving large image files 

between computer.
(vi)	 13 bit color look up table used in

Ans. (i)	 JPEG
(ii)	 TGA
(iii)	 PNG
(iv)	 PNG
(v)	 TIFF
(vi)	 GIF

6.	 Write a note on image files format which is 
well compressed storage of raster images. (or) 
Write a note on PNG.

Ans. (i)	 An extensible file format for the less loss, 
portable and well compressed storage of 
raster images.

(ii)	 PNG acts as replacement for GIF and also 
replaces multiple common uses of TIFF. 

(iii)	 PNG works good with online viewing 
applications like worldwide web.

(iv)	 So it is fully streameable with a best display 
option.

7.	 Write a note on MPEG.
Ans. (i)	 MPEG is a standard for generating digital 

video and audio compression under the 
International Standards Organization 
(ISO) by the group of people.

(ii)	 The group has developed MPEG-1, the 
standard on which Video CD and MP3 are 
based, MPEG-2, the standard that supports 
products as Digital Television set top boxes 
and DVD, MPEG-4, the standard for 
multimedia and mobile web.

(iii)	 MPEG- 7, the standard for search of audio 
and visual content. Research on MPEG-21 
“Multimedia Framework” has started in 
2000.

(iv)	 Simply MPEG is the standards for digital 
video and audio compression.

8.	 Write the steps in multimedia production.
Ans. (i)	 Conceptual Analysis and Planning

(ii)	 Project Design
(iii)	 Pre-production
(iv)	 Budgeting
(v)	 Multimedia Production Team
(vi)	 Hardware/Software Selection
(vii)	 Defining the content
(viii)	Preparing the Structure
(ix)	 Production 
(x)	 Testing
(xi)	 Documentation
(xii)	 Delivering the multimedia Product

9.	 List the multimedia production team 
members.

Ans. (i)	 Production Manager
(ii)	 Content specialist
(iii)	 Script writer
(iv)	 Text Editor
(v)	 Multimedia Architect
(vi)	 Computer graphic artist
(vii)	 Audio and video specialist
(viii)	Computer Programmer
(ix)	 Web Master

10.	 What is multimedia Kiosk?
Ans. (i)	 Kiosk is a free-standing furnished equipped 

multimedia computer that allow users to 
retrieve information via a touch screen. 

(ii)	 It is commonly used in airports and other 
public locations to provide directions and 
few mandatory information’s. 

(iii)	 In an library, Kiosk is usually located 
near the entrance of the library, used for 
displaying announcements, reading lists, 
comments and suggestions from library 
users and other information’s about 
operations and programs of the library.

Long Answers� 5 MARKS
1.	 Explain the following image file formats.  

(i) TIFF (ii) GIF (iii) JPEG (iv) TGA (v) PNG.
Ans. (i)	 TIFF (Tagged Image File Format) :

•	 This format is common in desktop 
publishing world (high quality output), 
and is supported by almost all software 
packages.
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•	 Recent versions of TIFF allows 
image compression, and the format 
is comfortable for moving large files 
between computers.

(ii)	 GIF (Graphics Interchange Format) :
•	 GIF is a compressed image format. 

Most of the computer color images and 
backgrounds are GIF files.

•	 This file format is best suitable for 
graphics that uses only limited colors, 
and it is the most popular format used 
for online color photos.

•	 13-bit Color look up table is used by the 
GIF format to identify its color values. 
This format is supported widely.

(iii)	 JPEG (Joint Photographic Experts 
Group) :
•	 JPEG was designed to attain maximum 

image compression.
•	 It uses lossy compression technique, 

where a compression method is 
referred that loses some of the data 
required for the image reconstruction.

•	 It works good with photographs, 
naturalistic artwork, and similar 
material but functions less on lettering, 
live drawings or simple cartoons. 

(iv)	 TGA (Tagra) :
	 It is the first popular format for high-

resolution images. TGA is supported by 
Most of the video-capture boards.

(v)	 PNG (Portable Network Graphics) :
•	 An extensible file format for the less 

loss, portable and well compressed 
storage of raster images.

•	 PNG acts as replacement for GIF and 
also replaces multiple common uses of 
TIFF. 

•	 PNG works good with online viewing 
applications like worldwide web.

•	 So it is fully streameable with a best 
display option.

2.	 Explain any five Digital Audio File Formats.
Ans.	WAV (Waveform Audio File Format) :

(i)	 It is the most popular audio file format in 
windows for storing uncompressed sound 
files.

(ii)	 In order to attain the reduced file size it can 
also be converted to other file formats like 
MP3.

MP3 (MPEG Layer-3 Format) :
(i)	 MPEG Layer-3 format is the most popular 

format for storing and downloading music. 
(ii)	 The MP3 files are roughly compressed to 

one-tenth the size of an equivalent WAV 
file.

OGG :
(i)	 A free, open source container format that 

is designed for obtaining better streaming 
and evolving at high end quality digital 
multimedia.

(ii)	 It can be compared to MP3 files in terms 
of quality.

AIFF (Audio Interchange File Format) :
	 A standard audio file format used by Apple 

which is like a WAV file for the Mac. 
WMA (Windows Media Audio) : 
	 It is a popular windows media audio 

format owned by Microsoft and designed 
with Digital Right Management (DRM) 
abilities for copyright protection. 

3.	 Explain the following steps in multimedia 
production. (i) Production (ii) Testing 
(iii) Documentation (iv) Delivering the 
multimedia product.

Ans.	Production :
(i)	 In the multimedia application, after the 

pre-production activities, the production 
phase starts.

(ii)	 This phase includes the activities like 
background music selection, sound 
recording and so on. 

(iii)	 Text is incorporated using OCR software, 
Pictures shot by digital camera, Video clips 
are shot, edited and compressed.

(iv)	 A pilot project is ready by this time.
Testing :

(i)	 The complete testing of the pilot product 
is done before the mass production to 
ensure that everything is in place, thereby 
avoiding the failure after launch.

(ii)	 If it’s an web based product, its functioning 
is tested with different browsers like 
Internet Explorer, Chrome, Mozilla and 
Netscape Navigator.
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(iii)	 If it’s an local multimedia application on a 
LAN it must be deployed in the server for 
testing purpose.

Documentation :
(i)	 User documentation is a mandatory feature 

of all multimedia projects.
(ii)	 The documentation has all the valuable 

information’s starting from the system 
requirement till the completion of testing. 

(iii)	 Contact details, e-mail address and phone 
numbers are provided for technical support 
and sending suggestions and comments.

Delivering the Multimedia Product :
(i)	 Multimedia applications are best delivered 

on CD/DVD or in the website . 
(ii)	 In reality various challenges are faced 

while delivering through internet, like 
bandwidth problems, huge number of 
plugins required to play audio and video 
and long downloading time.

(iii)	 Finally, a multimedia application is 
delivered in a more effective way by the 
integration of two mediums CD-ROM/
DVD and Internet.

4.	 Explain the applications of multimedia.
Ans.	Education :

(i)	 Multimedia plays an vital role in offering an 
excellent alternative method to traditional 
teaching by allowing the students to 
explore and learn various concepts through  
animation.

(ii)	 Students, teachers and the parents enjoy 
this multimedia mode of learning and 
multimedia learning materials.

(iii)	 Many educators accepts multimedia 
introduces new ways of thinking in the 
classroom.

(iv)	 EDUSAT (Education Satellite) is launched 
in India for serving the educational sector 
of the country for emulating virtual 
classroom in an effective manner. 

Entertainment
(i)	 The remarkable advancement in the 

entertainment industry is due to the 
Multimedia Technology mainly.

(ii)	 This technology is needed in all mode 
of entertainment like radio, TV, online 
gaming, video on demand etc. 

(iii)	 Video on demand or movies on demand is 
a service that provides movies to television 
sets on an individual basis at homes. 

(iv)	 A set-top box connected to the 
communication network converts  the 
digital information to analog signals and 
inputs it to the television set.

Business Systems : 
(i)	 Business applications for multimedia 

include presentations, training, internet 
protocols and so on. 

(ii)	 The marketing and advertising agencies 
are using animation techniques for sales 
promotion. 

(iii)	 Multimedia is used very commonly for 
building employee ID.

(iv)	 Cell phones and personal digital assistants 
with Bluetooth and Wi-Fi communication 
technology makes multimedia 
communication for business more efficiently.

Medical Services : 
(i)	 Medical services are grown drastically with 

the development of multimedia.
(ii)	 Medical Students practices surgery methods 

via simulation prior to actual surgery.
(iii)	 Tiny digital cameras are inserted in human 

body and it displays the inner scene of the 
body.

Public Places :
(i)	 Multimedia is available in many public 

places like trade shows, libraries, railway 
stations, museums, malls, airports, banks, 
hotels and exhibitions in the form of kiosks. 

(ii)	 It provides information to the customers 
and helps them. 

(iii)	 The information presented in kiosk are 
enriched with animation, video, still 
pictures, graphics, diagrams, maps, audio 
and text. 

(iv)	 Banks uses kiosks in the form of ATM 
machines.

Multimedia Conferencing :
	 Multimedia conferencing or video 

conferencing is a system that performs face-
to-face interactions among participating 
users, located far from each other, as if 
they were sitting and discussing in a single 
room.


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2.12	 Closing a Document
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2.14	 Moving Around the Document
2.15	 Scrolling the Document
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zoom tool
2.17	 Formating a Document
	 2.17.1	� Character Formatting using 

character specification dialog 
box.

	 2.17.2	� Character formatting using 
the control pallette
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Ellipses
	 2.18.3	 Drawing Polygon
	 2.18.4	� Drawing a Star using 

Polygon tool
	 2.18.5	� Filling shapes with colors and 
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2.19	 Working with pages
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	 2.19.3	 Removing Pages
2.20	 Master Pages
	 2.20.1	� Inserting Page Numbers in 

Mater Pages
	 2.20.2	 Hiding Master Items
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	 2.20.4	 Creating Master Pages
2.21	 Print a document

2.1	 Desktop Publishing
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2.3	 Opening Pagemaker
2.4	 Creating a New Document
2.5	 Entering Text in the Document
2.6	 Editing Text in the Document
	 2.6.1	 Selecting Text
	 2.6.2	 Deleting Text
	 2.6.3	 Undo Command
	 2.6.4	 Copying and Moving Text
2.7	 Text Block
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Text tool
	 2.7.2	 Moving a Text Block 
	 2.7.3	 Resizing a Text Block
	 2.7.4	� Splitting a Text Block  

into two 
	 2.7.5	 Rejoining Split Blocks
	 2.7.6	 Placing Text
2.8	 Understanding story
2.9	 Threading text blocks
	 2.9.1	� To unthread a threaded block
2.10	 Placing Text in a Frame
	 2.10.1	� Linking Frames  

containing Text
	 2.10.2	� Converting text in a Text block 

to a Frame
	 2.10.3	� Separating Text from the Frame
2.11	� Saving, Closing and Opening 

Documents
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Evaluation

PART - I

Choose the correct answer

1.	 DTP stands for ______________
(a)	 Desktop Publishing
(b)	 Desktop Publication
(c)	 Doctor To Patient
(d)	 Desktop Printer

� [Ans. (a) Desktop Publishing]

2.	 ____________ is a DTP software.
(a)	 Lotus 1-2-3		  (b)	 PageMaker
(c)	 Maya			   (d)	 Flash
� [Ans. (b) Pagemaker]

3.	 Which menu contains the New option?
(a)	 File menu		  (b)	 Edit menu
(c)	 Layout menu		 (d)	 Type menu

� [Ans. (a) File menu]

4.	 In PageMaker Window, the area outside of the 
dark border is referred to as _________.
(a)	 page			   (b)	 pasteboard
(c)	 blackboard		  (d)	 dashboard

� [Ans. (b) pasteboard]

5.	 Shortcut to close a document in PageMaker is 
_____________
(a)	 Ctrl + A 			  (b)	 Ctrl + B
(c)	 Ctrl + C 			  (d)	 Ctrl + W

� [Ans. (d) Ctrl + W]

6.	 A __________ tool is used for magnifying the 
particular portion of the area.
(a)	 Text tool 		  (b)	 Line tool
(c)	 Zoom tool 		  (d)	 Hand tool

� [Ans. (c) Zoom tool]

7.	 _________ tool is used for drawing boxes.
(a)	 Line			   (b)	 Ellipse
(c)	 Rectangle		  (d)	 Text

� [Ans. (c) Rectangle]

8.	 Place option is present in _________ menu.
(a)	 File			   (b)	 Edit
(c)	 Layout			   (d)	 Window

� [Ans. (a) File]

9.	 To select an entire document using the 
keyboard, press ___________
(a)	 Ctrl + A			   (b)	 Ctrl + B
(c)	 Ctrl + C			   (d)	 Ctrl + D

� [Ans. (a) Ctrl + A]

10.	 Character formatting consists of which of the 
following text properties?
(a)	 Bold			   (b)	 Italic
(c)	 Underline		  (d)	 All of these

� [Ans. (d) All of these]

11.	 Which tool lets you edit text?
(a)	 Text tool			  (b)	 Type tool
(c)	 Crop tool		  (d)	 Hand tool

� [Ans. (a) Text tool]

12.	 Shortcut to print a document in Pagemaker is 
___________
(a)	 Ctrl + A			   (b)	 Ctrl + P
(c)	 Ctrl + C			   (d)	 Ctrl + V

� [Ans. (b) Ctrl + P]

13.	 Adobe PageMaker is a ___________ software.
� [Ans. DTP]
14.	 ________ Bar is the topmost part of the 

PageMaker window.� [Ans. Title bar]
15.	 _________ is the process of moving up and 

down or left and right through the document 
window.� [Ans. Scrolling]

16.	 ________ tool is used to draw a circle.
� [Ans. Ellipse]
17.	 The Insert pages option is available on clicking 

the _________ menu.� [Ans. Layout]

18.	 Match the following.
Cut 	 - (i)	Ctrl + Z
Copy 	 - (ii) Ctrl + V
Paste 	 - (iii) Ctrl + X
Undo 	 - (iv) Ctrl + C

� [Ans. (iii), (iv), (ii), (i)]
19.	 Choose the odd man out.

i. Adobe PageMaker, QuarkXPress, Adobe 
InDesign, Audacity

ii. 	 File, Edit, Layout, Type, Zip
iii. 	 Pointer Tool, Line tool, Hide Tool, Hand 

Tool
iv. 	 Bold, Italic, Portrait, Underline�

[Ans. (i) - Audacity , (ii) -  Zip,  
(iii) - Hide Tool, (iv) - Portrait]

This is only for Sample 
for Full Book Order online and Available at all Leading Bookstores

orders@surabooks.com PH: 9600175757 / 8124201000 / 8124301000

www.su
ra

bo
ok

s.c
om



23

 Sura’s ➠ XII Std - Computer Applications

A
n 

In
tr

od
uc

ti
on

 t
o 

A
do

b
e 

Pa
ge

m
ak

er

20.	 Choose the correct statement.
i. (a) Text can be selected using mouse only.
   (b) �Text can be selected using mouse or the 

keyboard.
ii. (a) �DTP is an abbreviation for Desktop 

publishing.
    (b) �DTP is an abbreviation for Desktop 

publication.� [Ans. i - b, ii - a]

21.	 Choose the correct pair
(a)	 Edit and Cut		 (b)	 Edit and New
(c)	 Undo and Copy	 (d)	 Undo and Redo

� [Ans. (a) Edit and Cut]

PART - II

Short Answers

1.	 What is desktop publishing?
Ans.	Desktop publishing (abbreviated DTP) is the 

creation of page layouts for documents using 
DTP software.

2.	 Give some examples of DTP software.
Ans.	 The popular DTP software are Adobe PageMaker, 

Adobe InDesign, Quark XPress, etc.
3.	 Write the steps to open PageMaker.
Ans.	In the Windows 7 operating system, we can open 

Adobe PageMaker using the command sequence 
Start→All Programs → Adobe → Pagemaker 7.0 
→ Adobe PageMaker 7.0.

4.	 How do you create a New document in 
PageMaker?

Ans.	To create a new document,
(i)	 Choose File → New in the menu bar. 

(or) Press Ctrl + N in the keyboard. Now 
Document Setup dialog box appears.

(ii)	 Enter the appropriate settings for your new 
document in the Document Setup dialog 
box.

(iii)	 Click on OK.
5.	 What is a Pasteboard in PageMaker?
Ans. (i)	 A document page is displayed within a 

dark border.
(ii)	 The area outside of the dark border is 

referred to as the pasteboard. 
(iii)	 Anything that is placed completely in 

the pasteboard is not visible when the 
document is printed.

(iv)	 The use of pasteboard is to temporarily 
hold elements while designing document.

6.	 Write about the Menu bar of PageMaker.
Ans.	Menu bar contains the following menus File, 

Edit, Layout, Type, Element, Utilities, View, 
Window, Help. When you click on a menu 
item, a pull down menu appears. There may be  
sub-menus under certain options in the  
pull-down menus.

7.	 Differentiate Ellipse tool from Ellipse frame 
tool.

Ans.	 Ellipse 
tool

Ellipse tool Used to draw circles and ellipses.

Ellipse frame tool Used to create elliptical placeholders for 
text and graphics.

Ellipse tool Used to draw circles and ellipses.

Ellipse frame tool Used to create elliptical placeholders for 
text and graphics.

Used to draw 
circles and ellipses.

Ellipse 
frame tool

Ellipse tool Used to draw circles and ellipses.

Ellipse frame tool Used to create elliptical placeholders for 
text and graphics.Ellipse tool Used to draw circles and ellipses.

Ellipse frame tool Used to create elliptical placeholders for 
text and graphics.

Used to create 
elliptical 
placeholders for 
text and graphics.

8.	 What is text editing?
Ans.	Editing means making changes to the text. 

Editing encompasses many tasks, such as 
inserting and deleting words and phrases, 
correcting errors, and moving and copying text 
to different places in the document.

9.	 What is text block?
Ans.	A text block contains text typed, paste, or import. 

The borders of a text block cannot be seen until 
it select with the pointer tool.

10.	 What is threading text blocks?
Ans.	A Text block can be connected to other text 

block so that the text in one text block can flow 
into another text block. Text blocks that are 
connected in this way are threaded.

11.	 What is threading text?
Ans.	The process of connecting text among Text 

blocks is called threading text.
12.	 How do you insert a page in PageMaker?
Ans.	To insert pages

(i)	 Go to the page immediately before the page 
to be inserted.

(ii)	 Choose Layout →Insert Pages in the menu 
bar. The Insert Pages dialog box appears.

(iii)	 Type the number of pages want to be insert. 
(iv)	 To insert pages after the current page, 

choose 'after' from the pop-up menu.
(v)	 Click on Insert.
(vi)	 The new pages are inserted in publication.
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PART - III

Explain in Brief Answer

1.	 What is PageMaker? Explain its uses.
Ans. (i)	 Adobe PageMaker is a page layout software. 

(ii)	 It is used to design and produce documents 
that can be printed.

(iii)	 A simple business card to a large book can 
be created.

(iv)	 Page layout software includes tools that 
allows to easily position text and graphics 
on document pages.

	 For example, using PageMaker, create 
a newsletter that includes articles and 
pictures on each page. 

(v)	 Pictures and text next to each other, on top 
o f each other, or beside each other can be 
placed.

2.	 Mention three tools in PageMaker and write 
their keyboard shortcuts.

Ans.	 S.No. Tools Keyboard Short 
Cut

1. Pointer Tool F9

2. Rotating Tool Shift + F2

3. Line Tool Shift + F3

3.	 Write the use of any three tools in PageMaker 
along with symbols.

Ans. (i)	 Line Tool     – Used to create a straight line.
(ii)	 Ellipse Tool – �Used to draw an Ellipse a 

circle shape.
(iii)	 Polygon Tool – �Used to draw polygon 

shape.

4.	  How do you rejoin split blocks?
Ans.	To rejoin the two text blocks

(i)	 Place the cursor on the bottom handle of 
the second text block, click and drag the 
bottom handle up to the top.

(ii)	 Then place the cursor on the bottom handle 
of the first text block, and click and drag the 
bottom handle down if necessary.

5.	 How do you link frames containing text?
Ans.	To link Frames containing text

(i)	 Draw a second frame with the Frame tool 
of your choice.

(ii)	 Click the first frame to select it.
(iii)	 Click on the red triangle to load the text 

icon.
(iv)	 Click the second frame. PageMaker flows 

the text into the second frame.

6.	 What is the use of Master Page?
Ans. (i)	 Any text or object that you place on the 

master page will appear on the entire 
document pages to which the master is 
applied. 

(ii)	 It shortens the amount of time because don't 
have to create the same objects repeatedly 
on subsequent pages.

7.	 How to you insert page numbers in Master 
pages?

Ans. (i)	 Click on Master Pages icon.
(ii)	 Then click on Text Tool. Now the cursor 

changes to I - beam.
(iii)	 Then Click on the left Master page to put 

the page number.
(iv)	 Press Ctrl + Alt + P.
(v)	 The page number displays as ‘LM’ on the 

left master page.
(vi)	 Similarly click on the right Master page to 

put the page number.
(vii)	Press Ctrl + Alt + P.
(viii)The page number displays as ‘RM’ on the 

right master page, but will appear correctly 
on the actual pages.

PART - IV

Explain in detail

1.	 Explain the tools in PageMaker toolbox.
Ans.	Drawing :

(i)	 There are so many drawing tools in 
PageMaker.

(ii)	 Line tool, Rectangle tool, Ellipse tool and 
Polygon tool are four main drawing tools.
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Drawing Lines :
�PageMaker has two Line tools. The first one 
creates a straight line at any orientation. The 
second is a constrained Line tool that draws only 
at increments of 45 degrees.  

To draw a line :
(i)	 Select the Line tool from the toolbox. The 

cursor changes to a crosshair.
(ii)	 Click and drag on the screen to draw your 

line. As you drag, a line appears.
(iii)	 Release the mouse button and the line will 

be drawn and selected, with sizing handles 
on either end.

	�Resize the line by clicking and dragging the 
handles, if necessary.
	Drawing Rectangles or Ellipses :
(i)	 To draw a rectangle or ellipse : Click on 

the Rectangle or Ellipse tool from the 
toolbox. The cursor changes to a crosshair.

(ii)	 Click and drag anywhere on the screen. As 
you drag, a rectangle or ellipse appears.

(iii)	 Release the mouse button when the 
rectangle or ellipse is of the desired size.

	�Press the Shift key while you’re drawing to 
constrain the shape to a square or circle.
	To draw a Polygon :
(i)	 Click on the Polygon tool from the toolbox. 

The cursor changes to a crosshair.
(ii)	 Click and drag anywhere on the screen. As 

you drag, a Polygon appears.
(iii)	 Release the mouse button when the Polygon 

is of the desired size.

2.	 Write the steps to place the text in a frame.
Ans.	To place text in a Frame

(i)	 Click on one of a Frame tool from the 
Toolbox.

(ii)	 Draw a frame with one of PageMaker’s 
Frame tools (Rectangle frame tool or 
Ellipse Frame Tool or Polygon frame Tool). 
Make sure the object remains selected.

(iii)	 Click on File. The File menu will appear.
(iv)	 Click on Place. The Place dialog box will 

appear.
(v)	 Locate the document that contains the text 

you want to place, select it. 
(vi)	 Click on Open.
(vii)	Click in the frame to place the text in it. The 

text will be placed in the frame.

3.	 How can you convert text in a text block to a 
frame?

Ans.	Converting text in a text block to a frame:
After creating a text in the text block, to convert 
it to a frame. It can be done by using these steps.
(i)	 Draw the frame of your choice using one of 

the PageMaker’s Frame tool.
(ii)	 Select the text block you want to insert in 

the frame.
(iii)	 Click the frame while pressing the Shift key. 

Now both elements will be selected.
(iv)	 Choose Element → Frame → Attach 

Content on the Menu bar.
(v)	 Now the text appears in the frame.

4.	 Write the steps to draw a star using polygon 
tool?

Ans.	Drawing a star using polygon tool:
To draw a Star
(i)	 Click on the Polygon tool from the toolbox. 

The cursor changes to a crosshair.
(ii)	 Click and drag anywhere on the screen. As 

you drag, a Polygon appears.
(iii)	 Release the mouse button when the Polygon 

is of the desired size.
(iv)	 Choose Element → Polygon Settings in the 

menu bar. Now Polygon Settings dialogue 
box appears.

(v)	 Type 5 in the Number of sides text box.
(vi)	 Type 50% in Star inset textbox.
(vii)	Click OK. Now the required star appears on 

the screen.
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additional questions and answers

Choose the Correct Answer� 1 MARK 

1.	 Which of the following is not a DTP software?
(a)	 Adobe PageMaker
(b)	 Computer Aided Design
(c)	 Adobe Indesign	
(d)	  QuarkXpress
� [Ans. (b) Computer Aided Design]

2.	 Which of the following software includes tools 
that allow you to position text and graphics on 
document pages?
(a)	 Adobe PageMaker	 (b)	 Adobe Reader
(c)	 Portable Document file
(d)	 CAD� [Ans. (a) Adobe Pagemaker]

3.	 The shortcult key used to create a new 
document in Adobe PageMaker is 
(a)	 Ctrl + D			  (b)	 Ctrl + O
(c)	 Ctrl + N 			  (d)	 Alt + N
� [Ans. (c) Ctrl + N]

4.	 The default name of the new document is 
(a)	 Untitled – 1		  (b)	 document – 1
(c)	 Page – 1 			  (d)	  Untitled page – 1
� [Ans. (a) Untitled – 1]

5.	 Which of the following is used to temporarily 
hold elements while designing document in 
Adobe PageMaker? 
(a)	 Clibboard		  (b)	 Clipbook
(c)	 Pastebook		  (d)	 Pasteboard
� [Ans. (d) Pasteboard]

6.	 The default top and bottom margin is
(a)	 0.25"			   (b)	 0.75"
(c)	 0.50" 			   (d)	 1"
� [Ans. (b) 0.75"]

7.	 The default page orientation is 
(a)	 Tall			   (b)	 Wide
(c)	 Landscape		  (d)	 Letter
� [Ans. (a) Tall]

8.	 The default page dimension is
(a)	 8.5" × 10"		  (b)	 8.5" × 11"
(c)	 11" × 8.5"		  (d)	 8.5" × 11.5"
� [Ans. (b) 8.5" × 11"]

9.	 The topmost part of the window is 
(a)	 Tool bar			  (b)	 Tool box
(c)	 Menu bar 		  (d)	  Tittle bar
� [Ans. (d) Tittle bar]

10.	 Which of the following is not a control button 
in a Title bar?
(a)	 Open			   (b)	 Close
(c)	 Minimize		  (d)	 Maximize
� [Ans. (a) Open]

11.	 Which of the following is not a menu in the 
menu bar?
(a)	 Layout			   (b)	 Type
(c)	 Margin 			   (d)	 Element
� [Ans. (c) Margin]

12.	 Tool tip will appear on the 
(a)	 Menu bar		  (b)	 Tool bar
(c)	 Title bar 			  (d)	 All of these
� [Ans. (b) Tool bar]

13.	 How many tools are there in Tool box?
(a)	 9			   (b)	 11	
(c)	 10			   (d)	 14
� [Ans. (d) 14]

14.	 Which menu is used show or Hide tool box in 
PageMaker?
(a)	 Tools			   (b)	 Window
(c)	 Edit 			   (d)	 View
� [Ans. (b) Window]

15.	 The shortcut key is used select printer tool in 
the PageMaker tool box is
(a)	 F5			   (b)	 F8
(c)	 F9 			   (d)	 Shift + F9
� [Ans. (c) F9]

16.	 Which of the following tool is used to trim 
imported graphic objects?
(a)	 Pointer tool		  (b)	 Hand tool
(c)	 Cropping tool	 (d)	 None of these
� [Ans. (c) Cropping tool]
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17.	 The cursor used to select and rotate objects. 

(a)	 			   (b)	

(c)	  		  (d)	 +

� [Ans. (b)  ]

18.	 The use of the cursor is

(a)	 used to draw vertical lines
(b)	 used to type the text
(c)	 used to trim imported graphics
(d)	 used to rotate objects
� [Ans. (c) used to trim imported graphics]

19.	 How many scroll bars are there in PageMaker 
Window?
(a)	 2			   (b)	 3
(c)	 4			   (d)	 only 1
� [Ans. (a) 2]

20.	 How many ruler bars are there in PageMaker 
Window?
(a)	 4			   (b)	 3
(c)	 2 			   (d)	 only 1
� [Ans. (c) 2]

21.	 Which of the following appears along the top 
and left sides of the document window?
(a)	 Scroll bars		  (b)	 Status bar
(c)	 Ruler bars		  (d)	 Tool box
� [Ans. (c) Ruler bars]

22.	 Which menu is used to show Rulers?
(a)	 File			   (b)	 Edit
(c)	 Type 			   (d)	 View
� [Ans. (d) View]

23.	 The key is used to insert a blank line in a 
document is
(a)	 Shift key			  (b)	 Alt key
(c)	 Enter key		  (d)	 Esc key
� [Ans. (c) Enter key]

24.	 The flashing vertical bar called
(a)	 cursor			   (b)	 insertion point
(c)	 marker			   (d)	 pointer
� [Ans. (b) insertion point]

25.	 Text can be selected using
(a)	 Only mouse		  (b)	 Only keyboard
(c)	 Mouse or keyboard	 (d)	 Tools
� [Ans. (c) Mouse or keyboard]

26.	 The key used to select the text is 
(a)	 Shift			   (b)	 Alt
(c)	 Ctrl 			   (d)	 Esc
� [Ans. (a) Shift]

27.	 The command used to delete the text is 
(a)	 File → clear		  (b)	 Edit → clear
(c)	 Type → clear		 (d)	 View → clear
� [Ans. (b) Edit → clear]

28.	 Which of the following key combination to 
select text to the end of the current line?
(a)	 Ctrl + End		  (b)	 Shift + Ctrl + End
(c)	 Alt + End		  (d)	 Shift + End
� [Ans. (d) Shift + End]

29.	 Which key is used to delete the character 
towards left of the insertion point?
(a)	 Delete			   (b)	 Backspace
(c)	 Shift + Delete	 (d)	 Alt + Delete
� [Ans. (b) Backspace]

30.	 Which key is used to delete the character 
towards right of the insertion point?
(a)	 Delete			   (b)	 Backspace
(c)	 Shift + Backspace	 (d)	 Alt + Delete
� [Ans. (b) Backspace]

31.	 Under which menu clear command appears. 
(a)	 file			   (b)	 view
(c)	 edit 			   (d)	 window
� [Ans. (c) edit]

32.	 The shortcut key is used to reverse the action 
of the last command.
(a)	 Ctrl + U			  (b)	  Ctrl + N
(c)	 Ctrl + D 			  (d)	 Ctrl + Z
� [Ans. (d) Ctrl +Z]

33.	 A text block contains
(a)	 typed text		  (b)	 pasted text
(c)	 imported text	 (d)	 all of these
� [Ans. (d) all of these]
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34.	 Which of the following symbol denotes 
I-beam?

(a)	 			   (b)	

(c)	  			   (d)	
� [Ans. (a) ]

35.	 How many handles are seen while resizing the 
text block?
(a)	 4	 (b)	 3	 (c)	 2	 (d)	 1
� [Ans. (c) 2]

36.	 The command to insert text from other 
software in PageMake is
(a)	 File → Place		  (b)	 Edit → Place
(c)	 Edit → import	 (d)	 File → import
� [Ans. (a) File → Place]

37.	 Which of the following menu is used to 
generate a new page?
(a)	 Edit			   (b)	 Type
(c)	 Layout 			   (d)	 Window
� [Ans. (c) Layout]

38.	 The command to generate a new page is
(a)	 Type → Insert Pages
(b)	 Layout → Insert Pages
(c)	 Window → Insert → Page
(d)	 Layout → Insert → Pages
� [Ans. (b) Layout → Insert Pages]

39.	 All text in PageMaker resides inside containers 
called
(a)	 text blocks		  (b)	 text area
(c)	 page blocks		  (d)	 text thread
� [Ans. (a) text blocks]

40.	 A threaded text block can be identified by
(a)	 – 			   (b)	 +
(c)	 × 			   (d)	 ●
� [Ans. (b) +  ]

41.	 Which of the following tools is used to on 
thread the block?
(a)	 Text tool			  (b)	 Crop tool
(c)	 Pointer tool		  (d)	 Hand tool
� [Ans. (c) Pointer tool]

42.	 In PageMaker the imported text and graphs 
are called 
(a)	 objects			   (b)	 blocks
(c)	 functions		  (d)	 frames
� [Ans. (a) objects ]

43.	 Which of the following can be on a page or on 
the pasteboard?
(a)	 Block			   (b)	 Frame
(c)	 Text 			   (d)	 Object
� [Ans. (d) Object]

44.	 Which can be contained either in text blocks 
or text frames?
(a)	 Frame			   (b)	 Text
(c)	 Object 			   (d)	 Block
� [Ans. (b) Text]

45.	 The command that convert text in a text block 
to a frame is 
(a)	 Element → Frame → Attach Text
(b)	 Element → Attach Text → Frame
(c)	 Element → Frame → Attach Content
(d)	 Element → Attach Content → Frame

[Ans. (c) Element → Frame → Attach Content]

46.	 The shortcut key is used to save the file is
(a)	 Ctrl + S			   (b)	 Alt + S
(c)	 Shift + S 			  (d)	 Ctrl + Save
� [Ans. (a) Ctrl + S]

47.	 The dialogbox appears after pressing Ctrl + S 
is 
(a)	 Save As			   (b)	 Save
(c)	 Save Publication
(d)	 Save As Publication
� [Ans. (c) Save Publication]

48.	 The document can be closed using
(a)	 Ctrl + C			   (b)	 Ctrl + D
(c)	 Ctrl + S 			   (d)	 Ctrl + W
� [Ans. (d) Ctrl + W]

49.	 The shortcut key to zoom in is
(a)	 Ctrl + Alt + Space bar	
(b)	 Ctrl + Space bar
(c)	 Shift + Ctrl + Space bar
(d)	 Alt + Space bar� [Ans. (b) Ctrl + Space bar]
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50.	 Which of the following command is used to 
apply character formatting to text?
(a)	 Layout → Character	
(b)	 View → Character
(c)	 Format → Character	
(d)	 Type → Character
� [Ans. (d) Type → Character]

51.	 The shortcut key is used to apply character 
formatting to text is  
(a)	 Ctrl + T			   (b)	 Ctrl + X
(c)	 Ctrl + C 			  (d)	 Ctrl + F
� [Ans. (a) Ctrl + T]

52.	 To open character control palette, the 
command used is 
(a)	 Layout → Show control palette
(b)	 Window → Show control palette
(c)	 Window → Control Palette
(d)	 Window → Character palette
� [Ans. (b) Window → Show control palette]

53.	 Which of the following is used to open 
character control palette?
(a)	 Ctrl + '			   (b)	 Ctrl + ,
(c)	 Ctrl + " 			   (d)	 Ctrl + ;
� [Ans. (a) Ctrl + ']

54.	 The command to change the text color is
(a)	 Window → View Colors
(b)	 Window → Color Palette
(c)	 Window → Show Colors
(d)	 Window → Colors
� [Ans. (c) Window → Show Colors]

55.	 How many main tools are there for drawing in 
PageMaker?
(a)	 3	 (b)	 4	 (c)	 2	 (d)	 5
� [Ans. (b) 4]

56.	 Which of the following tool is not a main 
drawing tool?
(a)	 Hand Tool		  (b)	 Line Tool
(c)	 Rectangle Tool	 (d)	 Polygon Tool
� [Ans. (a) Hand Tool]

57.	 How many line tools are there in PageMaker?
(a)	 2	 (b)	 3	 (c)	 4	 (d)	 5
� [Ans. (a) 2]

58.	 Which key is used to draw square using 
rectangle tool?
(a)	 Alt			   (b)	 Ctrl
(c)	 Shift 			   (d)	 Space bar
� [Ans. (c) Shift]

59.	 Which of the following tool is used to draw a 
star?
(a)	 Line tool		
(b)	 Constrained line tool
(c)	 Polygon tool		  (d)	 Rectangle tool
� [Ans. (c) Polygon tool]

60.	 Which of the following command is used to 
set the number of sides in a star pattern in 
PageMaker?
(a)	 Type → Polygon Settings	
(b)	 Element → Polygon settings
(c)	 Layout → Polygon settings
(d)	 View → Polygon settings
� [Ans. (b) Element → Polygon settings]

61.	 Which of the following menu is used to got to 
a specific page in a document?
(a)	 Layout			   (b)	 Window
(c)	 Element			   (d)	 View 
� [Ans. (a) Layout]

62.	 Which of the following shortens the time 
while creating the same objects repeatedly on 
subsequent pages?
(a)	 Text Page		  (b)	 Master Page
(c)	 Layout Page		  (d)	 Last Page
� [Ans. (b) Master Page]

63.	 An object will appear on the entire document 
pages by using 
(a)	 Master page		  (b)	 Layout page
(c)	 Text page		  (d)	 Text blocks
� [Ans. (a) Master page]

64.	 Master page commonly contain.
(a)	 Logos			   (b)	 Page numbers
(c)	 headers and footers	 (d)	 all of these
� [Ans. (d) all of these]

65.	 The non printing layout guides are exists in
(a)	 first page		  (b)	 text page
(c)	 master page 		  (d)	 last page
� [Ans. (c) master page]
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66.	 Which of the following letters mark the master 
page icon for facing pages?
(a)	 L, R			   (b)	 A, B
(c)	 P, Q 			   (d)	 X, Y
� [Ans. (a) L, R]

67.	 A single-sided publication icon is marked by 
only 
(a)	 A	 (b)	 X	 (c)	 L	 (d)	 R
� [Ans. (d) R]

68.	 The shortcut key is used to put page numbers 
on master page is
(a)	 Ctrl + Shift + P	 (b)	 Ctrl + Alt + P
(c)	 Ctrl + Alt + N	 (d)	 Ctrl + Shift + N
� [Ans. (c) Ctrl + Alt + N]

69.	 The Display master option available under the 
menu is 
(a)	 Type			   (b)	 View
(c)	 Layout 			   (d)	 Element
� [Ans. (b) View]

70.	 The command to display master pages palette 
is 
(a)	 Windows → Show Master Pages
(b)	 Element → Show Master Pages
(c)	 Type → Show Master Pages
(d)	 Layout → Show Master Pages
� [Ans. (a) Windows → Show Master Pages]

71.	 How many copies are printed if collate option 
is not selected? 
(a)	 3	 (b)	 2	 (c)	 4	 (d)	 6
� [Ans. (c) 4]

Choose and fill in the blanks

1.	 ________ is the creation of page layouts for 
documents using DTP software.
(a)	 Desktop publishing	 (b)	 E-publishing	
(c)	 Desktop printer	 (d)	 None of these
� [Ans. (a) Desktop publishing]

2.	 Using _________, you could create a newsletter 
that includes articles and pictures on each 
page.�
(a)	 Lotus 1-2-3				  
(b)	 Adobe PageMaker	
(c)	 Excel			   (d)	 Word document�

� [Ans. (b) Adobe PageMaker]

3.	 The command to open Document Setup dialog 
box is _________.�
(a)	 Edit → View		 (b)	 File → View
(c)	 File → New		  (d)	 Edit → Save�

� [Ans. (c) File → New]
4.	 The keyboard shortcut used to scroll the page 

is _________.
(a)	 Shift + Alt + Drag left-mouse button	
(b)	 Shift + Alt + Drag right mouse button	
(c)	 Alt + Drag left mouse button
(d)	 Alt + Drag right mouse button�
[Ans. (a) Shift + Alt + Drag left-mouse button]

5.	 The tool used to trim imported graphics is 
__________.�
(a)	 Text tool				 
(b)	 Cropping tool	
(c)	 Hand tool		  (d)	 Zoom tool�

� [Ans. (b) Cropping tool]
6.	 The command to hide ruler bars is _________.

(a)	 View → Hide Rulers	
(b)	 View → Show Rulers
(c)	 Both (a) and (b)	
(d)	 None of these�

� [Ans. (a) View → Hide Rulers]

7.	 The command to show ruler bars is _______ .
(a)	 View → Hide Rulers	
(b)	 View → Show Rulers
(c)	 Both (a) and (b)	
(d)	 None of these�

� [Ans. (b) View → Show Rulers]
8.	 The ________ is used to create text blocks.�

(a)	 Crop tool		  (b)	 Pointer tool
(c)	 Hand Tool		  (d)	 Text tool�

� [Ans. (d) Text Tool]
9.	 _________ means making changes to the text 

blocks.�
(a)	 Viewing 			  (b)	 Editing	
(c)	 Cropping		  (d)	 None of these�

� [Ans. (b) Editing]
10.	 A ward can be selected using mouse by ______.

(a)	 One click with I beam	
(b)	 Double click with I beam	
(c)	 Triple click with I beam		
(d)	 None of these�

� [Ans. (b) Double click with I beam]
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11.	 A paragraph can be selected using mouse 
by_________.�
(a)	 One click with I beam	
(b)	 Double click with I beam	
(c)	 Triple click with I beam		
(d)	 None of these�

� [Ans. (c) Triple click with I beam]
12.	 Undo option is under the menu _______.

(a)	 File			   (b)	 Edit	
(c)	 View			   (d)	 Save�

� [Ans. (b) Edit]
13.	 The two handles which are seen while resizing 

the text box is called ___________.�
(a)	 Window shades	 (b)	 Window color
(c)	 Window cropping	 (d)	 None of these�

� [Ans. (a) Window Shades]
14.	 The place option is under the menu _________.

(a)	 Edit			   (b)	 View	
(c)	 Save			   (d)	 File�

� [Ans. (d) File]
15.	 A _________ is similar to a newspaper article.

(a)	 Unthreaded text	 (b)	 PageMaker story
(c)	 Text block		  (d)	 Threaded text�

� [Ans. (b) PageMaker story]
16.	 The connected text blocks are called _______.

(a)	 threaded			  (b)	 unthreaded	
(c)	 text block		  (d)	 none of these�

� [Ans. (a) threaded]
17.	 The process of connecting text among text 

blocks is called _______.�
(a)	 placing text		  (b)	 converting text
(c)	 threading text	
(d)	 unthreading text� [Ans. (c) threading text]

18.	 Text that flows through one or more threaded 
blocks are called __________.�
(a)	 objects			   (b)	 pages	
(c)	 window			   (d)	 story�

� [Ans. (d) Story]
19.	 The command that separates text from the 

frame is __________.
(a)	 Element → Frame → Delete content	
(b)	 Element → Tools → Backspace
(c)	 Element → Frame → Backspace	
(d)	 None of these�
[Ans. (a) Element → Frame → Delete Content]

20.	 The shortcut key to zoom out is _________.�
(a)	 Ctrl + Alt + View bar			 
(b)	 Ctrl + Alt + Space bar	
(c)	 Alt + Ctrl + View bar			 
(d)	 Alt + Ctrl + Backspace bar�

� [Ans. (b) Ctrl + Alt + Space bar]
21.	 The show colors option is under the menu 

________.�
(a)	 Layout			   (b)	 Element	
(c)	 View			   (d)	 Window�

� [Ans. (d) Window]
22.	 The shortcut key is used to go to a specific page 

in a document is ______.�
(a)	 Ctrl + Alt + A	 (b)	 Ctrl + Alt + X
(c)	 Ctrl + Alt + G	 (d)	 Ctrl + Alt + V�

� [Ans. (c) Ctrl + Alt + G]
23.	 The unused pages from the document can be 

removed by using the command _________.�
(a)	 Type → Remove pages		
(b)	 Element → Remove pages	
(c)	 Layout → Remove pages		
(d)	 Layout → Master pages�

� [Ans. (c) Layout → Remove Pages]
24.	 The command to hide master items in master 

page is ______.�
(a)	 Layout → Display Master			 
(b)	 View → Display Master	
(c)	 Element → Display Master	
(d)	 None of these�

� [Ans. (b) View → Display Master]
25.	 The four copies of all pages are printed if 

________ option not selected in print dialog 
box.
(a)	 Collate			   (b)	 Reverse	
(c)	 Proof			   (d)	 All�

� [Ans. (a) Collate]
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Match the Following

1.	  A Text tool (i) Shift + F2
B Polygon tool (ii) Shift + Alt + F4
C Rotating tool (iii) Shift + Alt + F1
D Rectangle frame 

tool
(iv) Shift + F6

	 A	 B	 C	 D
(a)	 iii	 iv	 i	 ii
(b)	 iii	 i	 iv	 ii
(c)	 iv	 iii	 i	 ii
(d)	 iii	 iv	 ii	 i

[Ans. (a) A – iii; B – iv; C – i; D – ii]

2.	  A Cut (i) Ctrl + P
B Copy (ii) Ctrl + Z
C Paste (iii) Ctrl + X
D Undo (iv) Ctrl + C
	 A	 B	 C	 D
(a)	 iii	 i	 iv	 ii
(b)	 iv	 iii	 i	 ii
(c)	 iii	 iv	 i	 ii
(d)	 iii	 iv	 ii	 i

[Ans. (c) A – iii; B – iv; C – i; D – ii]

Choose the incorrect pair:
1.	 (i)	 Line tool → Shift + F4

(ii)	 Ellipse tool → Shift + F5
(iii)	Cropping tool → Shift + Alt + F2
(iv)	Rectangle tool → Shift + F6
(a)	 i and ii			   (b)	 ii and iii
(c)	 i and iv			   (d)	 i only
� [Ans. (c) i and iv]

2.	 (a)	 Undo → Ctrl + Z
(b)	 Cut → Ctrl + X
(c)	 Copy → Ctrl + C
(d)	 Paste → Ctrl + P
� [Ans. (d) Paste → Ctrl + P]

3.	 (a)	 To close the document → Ctrl + W
(b)	 To open publication → Ctrl + O
(c)	 To save the file → Ctrl + S
(d)	 To Paste → Ctrl + P
� [Ans. (d) To Paste → Ctrl + P]

Choose the correct pair

1.	 (i)	 Rectangle tool → Shift + Alt + F4
(ii)	 Polygon tool → Shift + F6
(iii)Text tool → Shift + Alt + F1
(iv)	Constrained line tool → Shift + Alt + F2
(a)	 i and ii			   (b)	 ii and iii
(c)	 i and iv			   (d)	 ii and iv
� [Ans. (b) ii and iii]

2.	 (a)	 To Select the Entire document → Ctrl + A
(b)	 To Select the Entire document → Ctrl + E
(c)	 To Select the Entire document → Ctrl + D
(d)	 To Select the Entire document → Shift + A
� [Ans. (a) To Select the  

Entire document → Ctrl + A]

Choose the wrong statement

1.	 (i)	� An objects on master page will appear on 
the entire document pages.

(ii)	 Master page can not contain logos.
(iii)	Master page object can not deleted.
(iv)	A master item can not be selected on a 

document page.
(a)	 i and ii			   (b)	 ii and iii
(c)	 iii and iv			  (d)	 i, iii and iv
� [Ans. (b) ii and iii]

Very Short Answers� 2 MARKS
1.	 How will you hide / show the tool bar is 

pagemager?
Ans. (i)	 Click on Window. The Window menu will 

appear.
(ii)	 Click on Show tools. The toolbox appears 

in front of your document window. If you 
want to hide the toolbar, you can perform 
these steps to hide the toolbox.

	 �Click on Window. The Window menu will 
appear.

	 �Click on Hide tools to hide the toolbox.

2.	 Write the key board shortcut for the following 
tools.
(i)	 Text Tool		  (ii)	 Cropping tool
(iii)	Ellipse tool		  (iv)	Rectangle tool

Ans. (i)	 Text Tool	  – Shift + Alt + F1
(ii)	 Cropping Tool– Shift + Alt + F2
(iii)	 Ellipse Tool	  – Shift + F5
(iv)	 Rectangle Tool– Shift + F4
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3.	 Differentiate polygon and polygon frame tool.

Tool Tool 
box

Cursor Use

Polygon 
tool

+ Used to draw 
polygons

Polygon 
frame 
tool 

+ Used to create 
polygonal 
placeholders for 
text and graphics.

4.	 Write the tools which can be used for following 
purpose.
(i)	 Use to select and edit text
(ii)	 Used to scroll the page
(iii)	Used to draw Horizontal lines
(iv)	 Use to magnify an area of  the page

Ans. (i)	 Text Tool
(ii)	 Hand Tool
(iii)	 Constrained line Tool
(iv)	 Zoom Tool

5.	 What is the purpose of using the following 
keyboard shortcut?
(i)	 Ctrl + A		  (ii)	 Ctrl + Z

Ans. (i)	 To select the entire document
(ii)	 To reverse the last command

6.	 Differentiate Shit + End and Shift + Home.
Ans.	 Shit + End Shift + Home

To the end of the 
current line  
– Shift + End

To the beginning of 
the current line –  
Shift + Home

7.	 How will you delete a character in pagemaker?
Ans.	To delete a character, do the following :

(i)	 Position the insertion point to the left of 
the character to be deleted.

(ii)	 Press Delete key on the keyboard.
(or)

(iii)	 Position the insertion point to the right of 
the character to be deleted.

(iv)	 Press Backspace key on the keyboard.

8.	 How will you a block of text?
Ans.	To delete a block of text, do the following :

(i)	 Select the text to be deleted.
(ii)	 Press Delete or Backspace in the keyboard 

(or) Edit → Clear command.

9.	 What are the ways you can create a text block?
Ans.	Creating text blocks in two ways :

(i)	 Click or drag the text tool on the page or 
pasteboard, and then type.

(ii)	 Click a loaded text icon in an empty column 
or page.

10.	 What is called window shades?
Ans.	When a text block is selected with the Pointer 

tool, the block's boundaries become visible. Two 
handles are seen above and below the text block. 
These handles are called Windowshades.

11.	 How will resize a text block?
Ans.	When a text block is selected with the Pointer 

too, the block's boundaries become visible. Two 
handles are seen above and below the text block. 
These handles are called Windowshades. There 
is a dark square on both ends of the handle. These 
are used to change the size of the text block.

12.	 Write the steps to split a text block in to two.
Ans. (i)	 To split a text block into two:

(ii)	 Place the cursor on the bottom handle, click 
and drag upwards. When you release the 
bottom handle will contain a red triangle.

(iii)	 Click once on this and the cursor changes 
to a loaded text icon.

(iv)	 Position this where the second part of the 
text is to be, and click.

13.	 What do you understand from pagemaker 
story?

Ans.	A PageMaker story is similar to a newspaper 
article. The front page of a newspaper may 
contain several independent articles, some of 
which continue on other pages. In PageMaker, 
several stories may appear on the same 
publication page and continue elsewhere in the 
publication.

14.	 What is meant by unthreaded text?
Ans.	Unthreaded text is where a text block stands 

alone, without being connected to any other 
block. These blocks have nothing in their top 
and bottom handles.

15.	 What are called objects in pagemaker? 
Ans. (i)	 In PageMaker, text and graphics that you 

draw or import are called objects.
(ii)	 An object can be on a page or on the 

pasteboard.
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16.	 Write the steps that separate text from the 
frame.

Ans.	To separate text from a frame
(i)	 Click the frame with the Pointer tool.
(ii)	 Choose Element → Frame → Delete 

Content in the menu bar. The text will not 
appear in the frame.

17.	 How the pagemaker's scroll bars work 
differently from word processor?

Ans.	PageMaker’s scroll bars work differently than 
those in a word processor. Note that they are 
set to the center of each bar. Also, they scroll 
only the page you are currently on. Use the 
scroll bar on the right side to move up and 
down. Use the scroll bar at the bottom to move 
left and right.

18.	 What is meant by formatting a document?
Ans.	Formatting is the process of changing the 

general arrangement of text, i.e., improving the 
appearance of the text by using various fonts, 
font colors, and font styles. A font is a set of 
letters, numbers or symbols in a certain style. 
Each font looks different from other fonts.

19.	 What is meant by character formatting?
Ans.	Character formatting means displaying text in 

a certain way. Character formatting consists of 
text properties - bold, italic, underline, font type, 
font size and font colour.

20.	 How will you magnify part of a page?
Ans.	To magnify part of a page by dragging :

(i)	 Select the zoom tool.
(ii)	 Drag to draw a marquee around the area 

you want to magnify. To zoom in or out 
while using another tool : Press Ctrl + 
Spacebar to zoom in. Press Ctrl + Alt + 
Spacebar to zoom out.

21.	 How will you change text color in pagemaker?
Ans.	To colour characters

(i)	 Select the text you want to colour.
(ii)	 Choose Window → Show Colors in Menu 

bar. The Colors palette appears. Click the 
color you want to apply to the selected text. 
The characters change to the colour you 
selected in the palette.

22.	 What is main purpose of using pagemaker?
Ans.	The main purpose of PageMaker is composing 

pages. You can insert new pages into a document, 
remove existing pages, move between pages, and 
sort pages in a large document.

23.	 Write the steps to remove unused pages in a 
pagemaker document.

Ans.	To remove the unused pages form your 
document with a Remove Pages dialog box.
(i)	 Choose Layout → Remove Pages in the 

menu bar. The Remove Pages dialog box 
appears.

(ii)	 Type the page range you want to remove.
(iii)	 Click on OK button.

24.	 What does the master page contains?
Ans.	Master Pages commonly contain repeating 

logos, page numbers, headers, and footers. They 
also contain nonprinting layout guides, such as 
column guides, ruler guides, and margin guides.

25.	 How will you show the master page palette?
Ans.	To show Master Page Palette. Choose Windows 

→ Show Master Pages in the menu bar. The 
Master Pages Palette appears.

26.	 How will you hide master items in a particular 
page?

Ans.	To make the master items invisible on a 
particular page, switch to the appropriate page, 
then choose View → Display Master items

Short Answers� 3 MARKS
1.	 How will you show / Hide the rulers in 

pagemaker?
Ans.	To show the ruler

(i)	 Click on View. The View menu will appear.
(ii)	 Click on Show Rulers. Rulers appear along 

the top and left sides of the document 
window.

To hide the ruler
(i)	 Click on View. The View menu will appear.
(ii)	 Click on Hide Rulers to hide the rulers.

2.	 Differentiate moving and copying a text in 
pagemaker.

Ans. (i)	 The Copy and Paste commands of 
PageMaker can be used to copy text from 
one location in a document and paste it at 
another location.
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(ii)	 The Copy command creates a duplicate of 
the selected text, leaving the original text 
unchanged.

(iii)	 The Paste command pastes the copied text 
at the position where the insertion point is 
placed. 

(iv)	 The Cut and Paste commands can be 
used to move text from one position in a 
document to the other.

(v)	 The Cut command deletes the selected text 
from its original position. 

(vi)	 The Paste command then places this text 
at the position where the insertion point is 
placed.

3.	 Write the steps to create a text block with text 
tool.

Ans.	To create a text block with the text tool :
(i)	 Select the text tool (T) from the toolbox. 

The pointer turns into an I-beam.
(ii)	 On an empty area of the page or pasteboard, 

do one of the following : Click the I-beam 
where you want to insert text. This creates a 
text block the width of the column or page. 
By default, the insertion point jumps to the 
left side of the text block.

(iii)	 Type the text you want. Unlike with a text 
frame, you do not see the borders of a 
text block until you click the text with the 
pointer tool.

4.	 Write the steps to resize a text block using 
pointer tool.

Ans. (i)	 Click on the Pointer tool.
(ii)	 Click either the left or right corner handle 

on the bottom of the text block and drag. 
When you release the mouse button, the 
text in the text block will reflow to fit the 
new size of the text block.

(iii)	 A red triangle in the bottom windowshade 
means there is more text in the text block 
than is visible on the page. Drag the window 
shade handle down to show more text.

5.	 How will you insert text from other software 
program?

Ans.	Insert text form other software program like 
MS-Word in the PageMaker documents.
(i)	 Choose File → Place. The Place dialog box 

will appear.

(ii)	 Locate the document that contains the text 
you want to place and select it.

(iii)	 Click on Open in the Place dialog box. 
The pointer changes to the loaded text  
icon ( ).

(iv)	 Make a text block to place the text. (Or) 
Click in the page to place the text. The text 
will be placed in the page.

6.	 What is threading text and story?
Ans. (i)	 All text in PageMaker resides inside 

containers called text blocks.
(ii)	 A Text block can be connected to other text 

block so that the text in one text block can 
flow into another text block.

(iii)	 Text blocks that are connected in this way 
are threaded.

(iv)	 The process of connecting text among Text 
blocks is called threading text.

(v)	 Text that flows through one or more 
threaded blocks is called a story.

7.	 Write the methods used to unthread a threaded 
block.

Ans.	To unthread a threaded block : 
Method – 1 :
(i)	 Select the block that you wish to unthread 

with the pointer tool. Click on Edit → Cut 
in the menu bar.(the block disappear).

(iii)	 Now click on the Edit → Paste in the menu 
bar. The block will reappear in the same 
position, but it is now an unthreaded block.

Method – 2 :
(i)	 Select the block that you wish to unthread 

with the pointer tool. Then choose the Text 
tool and select all the text in the block. 

(ii)	 Then click on Edit → Cut in the menu 
bar.(the block disappear). Now click the 
insertion point within an existing threaded 
block. 

(iii)	 Then click on Edit → Paste in the menu bar. 
The text will be added in this block.

8.	 Write the steps that open an existing document.
Ans.	To open a document that has been saved and 

closed the following steps are used :
(i)	 (a) Choose File → Open in the menu bar 

(or) Click on the Open icon ( ) in the Tool 
bar (or) Press Ctrl + O in the Keyboard. A 
Open Publication dialog box as shown in 
appears on the screen.
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(ii)	 The file name is given in the File name list 
box. The name of the file to be opened can 
be chosen from the list, which is displayed.

(iii)	 Then click on the Open button. Now the 
required file is opened.

9.	 Write the steps to apply character formatting 
to text.

Ans.	The steps to apply character formatting to text 
are as follows :
(i)	 Select the text to be formatted.
(ii)	 Choose Type → Character in menu bar 

(or) Press Ctrl + T on the keyboard. The 
Character Specifications dialog box 
appears.

(iii)	 Make the appropriate changes in the dialog 
box. 

	 Click the drop-down menu arrow of the 
Font box and select the desired font.

	 Click the drop-down menu arrow of the 
Font Size box and select the font size.

	 Click the drop-down menu arrow of the 
Font Color box and select the desired 
colour.

	 Click the Bold, Italic, or Underline buttons 
to make the text bold, italic, or underlined 
respectively.

(iv)	 Click on OK.

10.	 How will you magnify a page in pagemaker?
Ans.	To magnify or reduce with the zoom tool :

(i)	 Select the zoom tool. The pointer becomes 
a magnifying glass with a plus sign in its 
center, indicating that the zoom tool will 
magnify your view of the image. (The 
magnifying glass shows a minus sign in its 
center when in reduction mode.) To toggle 
between magnification and reduction, 
press the Ctrl key.

(ii)	 Position the magnifying glass at the 
center of the area you want to magnify or 
reduce, and then click to zoom in or out. 
Continue clicking until the publication is 
at the magnification level you want. When 
the publication has reached its maximum 
magnification or reduction level, the center 
of the magnifying glass appears blank.

11.	 Write the steps to draw of rounded corner 
rectangle.

Ans.	To draw a rounded - corner rectangle :
(i)	 Double-click the Rectangle tool in the 

toolbox. The Rounded Corners dialog box 
appears.

(ii)	 Choose a corner setting from the preset 
shapes.

(iii)	 Click on OK. The cursor changes to a 
crosshair.

(iv)	 Click and drag anywhere on the screen.
(v)	 Release the mouse button when the 

rectangle is the desired size. Press the Shift 
key as you draw to constrain the shape to a 
rounded - corner square.

12.	 Write the steps that filling shapes with colors 
and patterns.

Ans.	Filling Rectangle with colour
(i)	 Draw a rectangle using Rectangle tool.
(ii)	 Select the rectangle.
(iii)	 Choose Window → Show colors in the 

menu bar. (or) Press Ctrl + J Now Colors 
palette appears.

(iv)	 Click on the required colour from the 
Colors Palette.

(v)	 The rectangle has been filled with the 
colour.

13.	 Write the steps to create a new Master Page.
Ans.	To create a new Master Page :

(i)	 Click the New Master Page icon in the 
Master Pages palette. The New Master Page 
dialog box appears.

(ii)	 Enter the name of the new master page in 
the Name field.

(iii)	 Make the appropriate changes in the 
Margins and Column Guides fields.

(iv)	 Click on OK. A new Master Page appears in 
the Master Pages palette.
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Long Answers� 5 MARKS

1.	 Explain how will you select text using mouse 
and keyboard?

Ans.	Text can be selected using the mouse or the 
keyboard.
Selecting Text using the mouse
To select text using a mouse, follow these steps: 
(i)	 Place the Insertion point to the left of the 

first character to be selected.
(ii)	 Press the left mouse button and drag the 

mouse to a position where you want to stop 
selecting.

(iii)	 Release the mouse button.
(iv)	 The selected text gets highlighted.

To Select Press
A Word Double - click with I - beam
A Paragraph Triple - click with I - beam

Selecting Text using the Keyboard
	�To select text using a keyboard, follow these 
steps :
(i)	 Place the Insertion point to the left of the 

first character you wish to select.
(ii)	 The Shift key is pressed down and the 

movement keys are used to highlight the 
required text.

(iii)	 When the Shift key is released, the text is 
selected.

2.	 Explain how will you copying and moving text 
in pagemaker?

Ans.	Moving the Text : The selected text can be easily 
cut and pasted in the required location.
To cut and paste text.
(i)	 Select the text to be moved.
(ii)	 Choose Edit → Cut in the menu bar. (or) 

Press Ctrl + X in the keyboard (or) Click 
the right mouse button and choose cut 
from the pop-up menu.

(iii)	 Insertion point is moved to the place where 
the text is to be pasted.

(iv)	 Choose Edit → Paste in the menu bar. (or) 
Press Ctrl + V in the keyboard. (or) Click 
the right mouse button and choose Paste 
from the pop-up menu.

	�The text can also be pasted in this way to another 
or another type of document.

The following keyboard shortcuts can be used 
to move text
Ctrl + X → to Cut
Ctrl + V → to Paste

	Copying the Text :
	�The selected text can be easily copied and pasted 
in the required location.
To copy and paste text.
(i)	 Select the text to be copied.
(ii)	 Choose Edit → Copy in the menu bar (or) 

Press Ctrl + C in the keyboard (or) Click 
the right mouse button and choose Copy 
from the pop-up menu.

(iii)	 Insertion point is moved to the place where 
the text is to be pasted.

(iv)	  Choose Edit → Paste in the menu bar (or) 
Press Ctrl + V in the keyboard (or) Click 
the right mouse button and choose Paste 
from the pop-up menu.

	�The text can also be pasted in this way to another 
location.
Keyboard shortcuts for copy and paste :
Ctrl + C → to Copy
Ctrl + V → to Paste

3.	 Explain manual text flow and automatic text 
flow.

Ans.	Manual text flow:
(ii)	 Position the loaded text icon at a corner of 

the area where you want to place text, hold 
down the mouse button, and drag to define 
the text block. Release the mouse button.

(ii)	 Text flows into the defined area. If there 
is more text than fits in the text block 
you defined, a red triangle appears in the 
bottom windowshade handle.

(iii)	 Click once on this and the loaded text icon 
reappears. Now generate a new text block 
and click. Repeat this process until there is 
no more text to place.

(iv)	 Similarly if you want to place the text in a 
page, position the loaded text icon at the 
top of the page and click. Text flows into the 
page. If there is more text than fits in the 
page, a red triangle appears in the bottom 
windowshade handle.
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(v)	 Click once on this and the loaded text icon 
reappears. Now generate a new page (or 
pages) by selecting Layout → Insert Pages 
in the menu bar. Place the loaded text icon 
at the top of the next page and click. Repeat 
this process until there is no more text to 
place.

Automatic text flow
(i)	 Before importing the text, first select 

Layout → Autoflow in the menu bar. Then 
you should import the text. Now the loaded 
text icon looks different - it contains a 
squiggly arrow ( ).

(ii)	 Place the loaded text icon at the top of 
the page and click. But now the text will 
automatically flow on to the succeeding 
pages, creating new ones, if necessary.

4.	 Explain the steps that saves the pagemaker 
document?

Ans.	To save a document for a first time following 
steps are used :
(i)	 (a) Choose File → Save in the menu bar. 

(or) Click on the Save icon( ) in the Tool 
bar. (or) Press Ctrl + S in the Keyboard.  
A Save Publication dialog box as shown on 
the screen.

 Saving a Document

(ii)	 The file name is given in the File name list 
box.

(iii)	 Then click on the Save button to save the 
document. The document  is now saved 
and a file name appears in the title bar.

	 Once a file is saved under a name, to save it 
again the name need not be entered again. 

The file can be saved simply by selecting 
the File → Save command or by clicking 
the Save button (or) clicking Ctrl + S in the 
keyboard.

5.	 Write the keyboard movement keys used to 
move around the pagamaker document.

Ans.	Keyboard movement Keys
Move Press

One character to the left Left Arrow
One character to the 
right

Right Arrow

One word to the left Ctrl + Left Arrow
One word to the right Ctrl + Right Arrow
Up one line Up Arrow
Down one line Down Arrow
To the end of a line End
To the beginning of a line Home
Up one paragraph Ctrl + Up Arrow
Down one paragraph Ctrl + Down 

Arrow

6.	 Explain the different methods used to move to 
a specific page.

Ans.	Going to a specific page: Pagemaker provides 
several methods for navigating the pages in your 
publication.
	�Method 1 :	
		� You can move from one page to another 

by using the Page up and Page down 
keys on your keyboard. This is probably 
the navigation methods you will use most 
often.

Method 2 : 
		� You can move from one page to another 

by using the page icons at the left bottom 
of 	the screen. Click on the page icon that 
corresponds to the page that you want to 
view. The page is displayed.

�Method 3 : 
		� Using the Go to Page dialog box. To go to a 

specific page in a document 
(i)	 Choose Layout → Go to Page in the 

menu bar (or) Press Alt + Ctrl + G in the 
keyboard. Now the Go to Page dialog box 
appears.
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Go to Page

(ii)	 In the dialogue box, type the page number 
that you want to view.

 Type page number

(iii)	 Then click on OK. The required page is 
displayed on the screen.

7.	 Explain how will you print a page maker 
document in detail?

Ans.	Print a document
(i)	 Choose File → Print in the menu bar (or) 

Press Ctrl + P in the keyboard. The Print 
Document dialog box appears.

(ii)	 Choose the settings in the Print Document 
dialog box as

•	 �Select the printer from the Printer drop-
down list box.

•	 �Choose the pages to be printed in the Pages 
group box by selecting one of the following 
available options :

All : 
		 This option prints the whole document.

	�Ranges: 
		� This option prints individual pages by the 

page number or a range of pages.
		� You can use commas to separate the page 

numbers (e.g., 5,7,19).
		� Use a hyphen to print page ranges(e.g., 

10-17; this will print all pages from 
page numbers 10 to 17). To print from a 
particular page to  the end of the document, 
enter the starting page number followed by 
a hyphen (e.g., 5 -).

		� You may also combine individual page 
numbers and a range of pages (e.g., 5, 9, 
15-26).

	�Print : 
		� You can also print only odd numbered 

or even-numbered pages. Select the Odd 
pages or Even pages option from the Print 
drop-down list box.

	 Type the number of copies you want in the 
Copies text box.

	 You can choose whether to collate the 
pages or not. Suppose you want to print 4 
copies of a 5 pages document.

(i)	 If the Collate option is not selected. 
PageMaker will first print 4 copies of page 
1, then 4 copies of page 2, and so on.

(ii)	 If the Collate option is selected, PageMaker 
will print a complete set of pages 1 to 5, 
then a second set, and so on.

(iii)	 After choosing from the options in the 
Print Document dialog box, click Print 
button to print the document. Make sure 
the printer is switched on.


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Evaluation

PART - I

Choose the correct answer

1.	 Which language is used to request information 
from a Database?
(a)	 Relational		  (b)	 Structural
(c)	 Query			   (d)	 Compiler 

� [Ans. (c) Query]

2.	 The ________ diagram gives a logical structure 
of the database graphically.
(a)	 Entity-Relationship	 (b)	 Entity
(c)	 Architectural Representation
(d)	 Database� [Ans. (b) Entity]

3.	 An entity set that does not have enough 
attributes to form primary key is known as
(a)	 Strong entity set	 (b)	 Weak entity set
(c)	 Identity set		  (d)	 Owner set

� [Ans. (b) Weak entity set]

4.	 ______ Command is used to delete a database.
(a)	 Delete database database_name
(b)	 Delete database_name
(c)	 drop database database_name
(d)	 drop database_name

� [Ans. (d) drop database_name]

5.	 Which type of below DBMS is MySQL?
(a)	 Object Oriented	 (b)	 Hierarchical
(c)	 Relational		  (d)	 Network

� [Ans. (c) Relational]

6.	 MySQL is freely available and is open source.
(a)	 True			   (b)	 False

� [Ans. (a) True]

7.	 ________ represents a “tuple” in a relational 
database?
(a)	 Table			   (b)	 Row
(c)	 Column			  (d)	 Object

� [Ans. (b) Row]

8.	 Communication is established with MySQL 
using
(a)	 SQL			   (b)	 Network calls
(c)	 Java 			   (c)	 API's

� [Ans. (a) SQL]

9.	 Which is the MySQL instance responsible for 
data processing?
(a)	 MySQL Client	 (b)	 MySQL Server
(c)	 SQL
(d)	 Server Daemon Program

� [Ans. (b) MySQL Server]

10.	 The structure representing the organizational 
view of entire database is known as __________ 
in MySQL database.
(a)	 Schema 			  (b)	 View
(c)	 Instance			  (d)	 Table

� [Ans. (d) Table]

Part - II
Short Answers

1.	 Define Data Model and list the types of data 
model used.

Ans.	A data model shows the logical structure of 
a database, including the relationships and 
constraints that determine how data can be 
stored and accessed.
Types of Data Model :
(i)	 Hierarchical database model
(ii)	 Relational model 
(iii)	 Network model
(iv)	 Entity – relationship model
(v)	 Object – oriented database model

2.	 List few disadvantages of file processing 
system.

Ans.	The file processing system has the following 
major disadvantages:
(i)	 Data redundancy and inconsistency 
(ii)	 Integrity Problems 
(iii)	 Security Problems 
(iv)	 Difficulty in a accessing data 
(v)	 Data isolation

3.	 Define Single and multi valued attributes.
Ans.	Single valued attributes:

A single valued attribute contains only one value 
for the attribute and they don't have multiple 
numbers of values.

Single Valued Attributes
Attributes Values

Age 3

Roll no 85
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Multi valued attributes:
A multi values attribute has more than one value 
for that particular attribute.

Attributes and Values
Attributes Values

Degree B.Tech, MBA
Bank_Account SBI, HDFC

4.	 List any two DDL and DML commands with 
its Syntax.

Ans.	DDL Commands :
(i)	 CREATE
	 Syntax : CREATE database databasename;
(ii)	 DROP 
	 Syntax : DROP database databasename;
DML Commands :
(i)	 INSERT
	 �Syntax :	 INSERT INTO tablename 

(column1, column2, column 3)
	 VALUES:	 (Value 1, value 2, value3);
(ii)	 UPDATE
	 �Syntax : 	 UPDATE tablename  

SET column 1 = "new value"
	 Where column2="value2";

5.	 What are the ACID properties?
Ans.	ACID Properties :

(i)	 The acronym stands for Atomicity, 
Consistency, Isolation and Durability. 

(ii)	 Atomicity follows the thumb rule “All 
or Nothing”, while updating the data in 
database for the user performing the 
update operation.

(iii)	 Consistency ensures that the changes 
in data value to be constant at any given 
instance. Isolation property is needed 
during concurrent transaction. 

(iv)	 To prevent the conflict in database update, 
the transactions are isolated from other 
user and serialized. This is also known as 
Degree of Consistency. 

(v)	 Durability is defined as the system’s ability 
to recover all committed transactions 
during the failure of storage or the system.

6.	 Which command is used to make permanent 
changes done by a transaction?

Ans.	COMMIT Command is used to make permanent 
changes done by a transaction.

7.	 What is view in SQL?
Ans.	In a database, a view is the result set of a stored 

query on the data, which the database users can 
query just as they would in a persistent database 
collection object.

8.	 Write the difference between SQL and MySQL.
Ans.	

Sl.
No. SQL MySQL

1. It is used in 
the accessing, 
updating and 
manipulation of 
data in a database.

It is an RDBMS that 
allows keeping the data 
that exists in a database 
organized.

2. SQL is a structured 
query language.

MySQL is a database 
software.

3. SQL does 
not provide 
connectors.

MySQL offers an 
integrated tool called 
'MySQL Workbench' 
to design and develop 
databases.

9.	 What is Relationship and List its types.
Ans.	There exists a relationship between two tables 

when the foreign key of one table references 
primary key of other table.
Types :
(i)	 One – to – One
(ii)	 One – to – Many
(iii)	 Many – to – Many

10.	 State few advantages of Relational databases.
Ans.	Advantages :

(i)	 Data is not repeated and therefore does not 
waste valuable resources.

(ii)	 Separate tables connected by a key fields 
are used

(iii)	 Data retrieval is quicker
(iv)	 Database can be extended with more data 

and tables.
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PART - III

Explain in Brief Answer

1.	 Explain on Evolution of DBMS.
Ans.	Evolution of DBMS:

(i)	 The concept of storing the data started 
before 40 years in various formats.

(ii)	 In earlier days they have used punched 
card  technology to store the data. Then 
files were used.

(iii)	 The file systems were known as predecessor 
of database system.

(iv)	 Various access methods in file system were 
indexed, random and sequential access. 
The file system had more limitations like 

	� Data Duplication : Same data is used by 
multiple resources for processing, thus 
created multiple copies of same data 
wasting the spaces.

	� High Maintenance : Access control and 
verifying data consistency needs high 
maintenance cost.

	� Security : Less security provided to the 
data.

(v)	 So database systems became popular to 
overcome the above limitations of file 
system.

2.	 What is relationship in databases? List its 
types.

Ans.	In ER Model, relationship exists between two 
entities. Three types of relationships are available 
and the Entity-Relationship(ER) diagram is 
based on the three types listed below.
(i)	 One-to-One relationship: One-to-one 

(1:1) relationship is said to exist in a 
relational database design, if 0 or 1 instance 
of entity A is associated with 0 or 1 instance 
of entity B, and 0 or 1 instance of entity B is 
associated with 0 or 1 instance of entity A.

(ii)	 One-to-Many relationship: One-to-
many (1:N) relationship is said to exist in 
a relational database design, for 1 instance 
of entity A there exists 0 or 1 or many 
instances of entity B, but for 1 instance 
of entity B there exists 0 or 1 instance of  
entity A.

(iii)	 Many-to-Many relationship: Consider 
two entities A and B. many-to-many (M:N) 
relationship is said to exist in a relational 
database design, for 1 instance of entity 
A there exists 0 or 1 or many instances of 
entity B, and for 1 instance of entity B there 
exists 0 or 1 or many instance of entity A.

3.	 Discuss on Cardinality in DBMS.
Ans.	It is defined as the number of items that must 

be included in a relationship (i.e) number of 
entities in one set mapped with the number of 
entities of another set via the relationship. Three 
classifications in Cardinality are one-to-one, 
one-to-many and Many-to-Many.

Vehicle
1

 

Person Drives
driver

Cardinality

If we consider the current vehicle, the driver is 
operating, then we have one-to-one relationship 
between Person and Vehicle. 

Customer Order
n

Places

Cardinality Relation 1 to n

In the above example, Customer places the 
Order is a one-to-many relationship. Here the 
customer can place multiple orders and the 
order is related to only one customer. 

Student Course
n

register

 Cardinality Relation n to n

The example of many-to-many relationship is 
Students registering the Courses. A student can 
register more than one courses and A course 
can be registered by many students. Hence it is 
many-to-many.
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4.	 List any 5 privileges available in MySQL for 
the User.

Ans.	List of privileges available in MySQL :
Privileges Action Performed (If Granted)

Select_priv User can select rows from database 
tables.

Insert_priv User can insert rows into database 
tables.

Update_priv User can update rows of database 
tables.

Delete_priv User an delete rows of database 
tables.

Create_priv User can create new tables in 
database

Alter_priv User can make changes to the 
database structure.

5.	 Write few commands used by DBA to control 
the entire database.

Ans.	DBA to Control the entire database :
(i)	 Use Database ;
(ii)	 Show Database ;
(iii)	 Show tables ;
(iv)	 Show columns from tablename ;
(v)	 Show index from tablename ;
(vi)	 Show table status like tablename\G :

PART - IV

Explain in Detail

1.	 Discuss on various database models available 
in DBMS.

Ans.	The database technology came into existence 
in terms of models with relational and object-
relational behavior. The major database models 
are listed below:
1.	 Hierarchical Database Model :
(i)	 The famous Hierarchical database model 

was IMS (Information Management 
System), IBM’s first DBMS. 

(ii)	 In this model each record has information 
in parent/ child relationship like a tree 
structure.

(iii)	 The collection of records was called as 
record types, which are equivalent to tables 
in relational model. The individual records 
are equal to rows.

Company

Personnel

= Container

= Object

Hierarchical Database Model

Users Machines Devices Applications

etingMark

2.	 Network model :
(i)	 The first developed network data model 

was IDS (Integrated Data Store) at 
Honeywell. 

(ii)	 Network model is similar to Hierarchical 
model except that in this model each 
member can have more than one owner. 

(iii)	 The many to many relationships are 
handled in a better way.

It has two parents

ABC college

Student

Department A College library

n:1

1:n

Network Model

Network Schema: Schema defines all about the 
structure of the database.
Sub Schema : Controls on views of the database 
for the user.
Language : Basic procedure for assessing the 
database. The major advantage of this model is 
the ability to handle more relationship types, easy 
data access, data integrity and independence. 
The limitation of network model is difficulty in 
design and maintenance.
3.	 Relational model : 
	 Oracle and DB2 are few commercial 
relational models in use Relational model is 
defined with two terminologies Instance and 
Schema.
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Member Member group Group

member_id:int

group_id:int

...

...

id:int id:int

firstname:string

surname:string

email:string

 
Relational Database Model

Relational Database

4.	 Object - oriented database model :
(i)	 This model incorporates the combination 

of Object Oriented Programming (OOP's) 
concepts and database technologies.

(ii)	 Practically, this model serves as the base of 
Relational model. Object oriented model 
uses small, reusable software known as 
Objects. 

(iii)	 These are stored in object oriented 
database. This model efficiently manages 
large number of different data types.

(iv)	 Moreover complex behaviors are handled 
efficiently using OOP's concepts. 

Name
Age

Salary

Works
in Department

DeptName Budget

Salesperson
M

1
1

Lives
At

Has
Orders

Has
Accounts

OrdersAccount

Address

StName

StNumber City

State

Zip

N

N

N

1

N

 Object-oriented Database Model

2.	 List the basic concepts of ER Model with 
suitable example.

Ans.	ER Modeling basic concepts: The basic concepts 
of ER model consists of 
1.	 Entity or Entity type
2.	 Attributes
3.	 Relationship
These are the general concepts which help to 
create an ER diagram and produce an ER model. 
With the help of these any database design can 
be created and viewed to know the concept in 
that database design. 
Entity or Entity type :
(i)	 An Entity can be anything a real-world object 

or animation which is easily identifiable by 
anyone even by a common man.

(ii)	 Eg: In a company’s database Employee, HR, 
Manager are considered as entities, where 
each of these entity will be having their 
own attributes. An entity is represented by 
a rectangular box.

Employee Manager

Attributes:  
An attribute is the information about that entity 
and it will describe, quantify, qualify, classify, 
and specify and entity. An attribute will always 
have a single value, that value can be a number 
or character or string.
Types of attributes :
(i)	 Key Attribute
(ii)	 Simple Attributes
(iii)	 Composite Attributes
(iv)	 Single Valued Attribute
(v)	 Multi Valued Attribute
Relationship Type: 
In ER Model, relationship exists between two 
entities. Three types of relationships are available 
and the Entity- Relationship(ER) diagram is 
based on the three types listed below. 
(i)	 One-to-One relationship: Consider 

two entities A and B. one-to-one (1:1) 
relationship is said to exist in a relational 
database design, if 0 or 1 instance of entity 
A is associated with 0 or 1 instance of 
entity B, and 0 or 1 instance of entity B is 
associated with 0 or 1 instance of entity A.

(ii)	 One-to-Many relationship: Consider 
two entities A and B. one-to-many (1:N) 
relationship is said to exist in a relational 
database design, for 1 instance of entity 
A there exists 0 or 1 or many instances of 
entity B, but for 1 instance of entity B there 
exists 0 or 1 instance of entity A.

(iii)	 Many-to-Many relationship: Consider 
two entities A and B. many-to-many (M:N) 
relationship is said to exist in a relational 
database design, for 1 instance of entity 
A there exists 0 or 1 or many instances of 
entity B, and for 1 instance of entity B there 
exists 0 or 1 or many instance of entity A.

In reality one-to-one are in less usage, where as 
one-to-many and many-to-many are commonly 
used. However in relational databases, many-
to-many are converted into one-to-many 
relationships.

This is only for Sample 
for Full Book Order online and Available at all Leading Bookstores

orders@surabooks.com PH: 9600175757 / 8124201000 / 8124301000

www.su
ra

bo
ok

s.c
om



46

 Sura’s ➠ XII Std - Computer Applications

C
ha

pt
er

3

3.	 Discuss in detail on various types of attributes 
in DBMS.

Ans.	Types of attributes :
1. 	 Key Attribute
2.	 Simple Attributes 
3.	 Composite Attributes 
4.	 Single Valued Attribute
5.	 Multi Valued Attribute
1.	� Key Attribute : Generally a key attribute 

describes a unique characteristic of an 
entity.

2.	 Simple Attribute :
(i)	 The simple attributes cannot be separated 

it will be having a single value for their 
entity. 

(ii)	 Ex: Let us consider the name as the 
attribute for the entity employee and here 
the value for that attribute is a single value.

Employee

First name

Name

Last name

Simple Attribute

3.	 Composite Attributes : 
(i)	 The composite attributes can be subdivided 

into simple attributes without change in 
the meaning of that attribute.

(ii)	 Ex: In the above diagram the employee 
is the entity with the composite attribute 
Name which are sub-divided into two 
simple attributes first and last name.

4.	 Single Valued Attributes : 
(i)	 A single valued attribute contains only one 

value for the attribute and they don’t have 
multiple numbers of values.

(ii)	 Ex: Age- It is a single value for a person 
as we cannot give n number of ages for a 
single person,therefore it is a single valued 
attribute.

Single Valued Attributes
Attribute Values

Age 3
Roll no 85

	� In the above table are the some examples 
for single valued attributes.

Person

Degree

Single Valued Attributes

5.	 Multi Valued Attributes :
(i)	 A multi valued attribute has more than one 

value for that particular attribute. 
(ii)	 Ex: Degree - A person can hold n number 

of degrees so it is a multi-valued attribute.

Attributes and Values
Attribute Values

Degree B.Tech, MBA
Bank_Account SBI, HDFC

4.	 Write a note on open source software tools 
available in MySQL Administration.

Ans.	MYSQL Administration open source software 
tools :
Types of software tools :
(i)	 Many open source tools are available in the 

market to design the database in a better 
and efficient manner.

(ii)	 PhpMyAdmin is most popular for Web 
Administration.

(iii)	 The popular Desktop Application tools are 
MySQL Workbench and HeidiSQL. 

1.	 PHPMYADMIN (Web Admin) :
(i)	 This administrative tool of MySQL is a web 

application written in PHP. 
(ii)	 They are  used predominantly in web 

hosting.
(iii)	 The main feature is providing web 

interface, importing data from CSV and 
exporting data to various formats.

(iv)	 It generates live charts for monitoring 
MySQL server activities like connections, 
processes and memory usage.

(v)	 It also helps in making the complex queries 
easier.
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2.	� MySQL Workbench  
(Desktop Application): 

(i)	 It is a database tool used by developers and 
DBA’s mainly for visualization. 

(ii)	 This tool helps in data modeling, 
development of SQL, server configuration 
and backup for MySQL in a better way.

(iii)	 Its basic release version is 5.0 and is now in 
8.0 supporting all Operating Systems. 

(iv)	 The SQL editor of this tool is very flexible 
and comfortable in dealing multiple results 
set.

3.	 HeidiSQL (Desktop Application) :
(i)	 This open source tools helps in the 

administration of better database systems. 
(ii)	 It supports GUI (Graphical User Interface) 

features for monitoring server host, server 
connection, Databases, Tables, Views, 
Triggers and Events.

5.	 Explain in detail on Sub Queries with suitable 
examples.

Ans.	Sub queries : Here the SQL query is written 
within a main Query. This is called as Nested 
Inner/ SubQuery. The sub query is executed 
first and the results of sub query are used as the 
condition for main query. The sub query must 
follow the below rules:
(i)	 Subqueries are always written within the 

parentheses.
(ii)	 Always place the Subquery on the right 

side of the comparison operator. 

(iii)	 ORDER BY clause is not used in sub query, 
since Subqueries cannot manipulate the 
results internally. 

Consider the Employee table with the fields 
EmpID, Name, Age and Salary. The sample data 
is given below: 

Select order by class Record List
EmpID Name Age Salary

101 Ram 35 15000
102 Gopal 41 30000
103 Priya 32 13000
104 Hari 37 20000

In the below Query, we use sub query in on 
SELECT statement.
SELECT * from Employee
where EmpID IN (SELECT EmpID from 
Employee WHERE Salary < 20000);
First, the inner query is executed. As a result 
EmpID 101 and 103 are retrieved. Now the 
external or outer query is executed. Internally 
the query is SELECT * from Employee where 
EmpID IN (101,103) and the output is drawn 
below in table

Select Record List
EmpID Name Age Salary

101 Ram 35 15000
103 Priya 32 13000

Similarly the subqueries are used with INSERT, 
UPDATE and DELETE.

additional questions and answers
Choose the Correct Answer� 1 MARK 

1.	 Expand DBMS
(a)	 Data Base Management Software
(b)	 Data Base Memory Software
(c)	 Data Base Management System
(d)	 Data Base Management Solution
� [Ans. (c) Data Base Management system]

2.	 Which of the following is system software for 
creating and managing databases?
(a)	 Database		  (b)	 DBMS
(c)	 SQL			   (d)	 MySQL
� [Ans. (b) DBMS]

3.	 Which of the following the DBMS provides to 
the users?
(a)	 create data		  (b)	 retrieve data
(c)	 update data		  (d)	 manage data
(e)	 all of these� [Ans. (e) all of these]

4.	 Grouping only related data together and 
storing them under one group name called
(a)	 tuple			   (b)	 table
(c)	 list			   (d)	 database 
� [Ans. (b) table]

5.	 Which of the following is not a type of dbms?
(a)	 DBMS			   (b)	 RDBMS
(c)	 ODBMS			  (d)	 EDBMS
� [Ans. (d) EDBMS]
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6.	 How many basic concepts all DBMS adheres?
(a)	 2	 (b)	 3	 (c)	 4	 (d)	 6
� [Ans. (a) 2]

7.	 In ACID properties, I stands for
(a)	 Information		  (b)	 Integration
(c)	 Isolation 		  (d)	 Instance
� [Ans. (c) Isolation]

8.	 In ACID properties, C stands for
(a)	 Concurrency		 (b)	 Consistency
(c)	 Conflict			   (d)	 Collection
� [Ans. (b) Consistency]

9.	 Which of the following is the DBMSs 
mechanism used for data sharing?
(a)	 ACID
(b)	 Concurrency control
(c)	 Locking			   (d)	 Consistency
� [Ans. (b) Concurrency control]

10.	 The famous Hierarchical database model was
(a)	 IBM			   (b)	 INS
(c)	 IMS			   (d)	 MIS
� [Ans. (c) IMS]

11.	 Which of the following is not a database 
model?
(a)	 Hierarchical		  (b)	 Relational
(c)	 Network			  (d)	 Consistency
� [Ans. (d) Consistency]

12.	 IMS expansion is
(a)	 Information Memory System
(b)	 Information Management System
(c)	 Information Model System
(d)	 Information Management Solution
� [Ans. (b) Information Management System]

13.	 IBM's first DBMS is
(a)	 IMS			   (b)	 RDBMS
(c)	 ODBMS			  (d)	 none of these
� [Ans. (a) IMS]

14.	 Which of the following database model has 
information in parent/child relationship?
(a)	 Network			  (b)	 Object
(c)	 Hierarchical		  (d)	 Relational
� [Ans. (c) Hierarchical]

15.	 The first developed network data model is 
(a)	 IMS			   (b)	 IDS
(c)	 DB2			   (d)	 Oracle
� [Ans. (b) IDS]

16.	 IDS expansion is 
(a)	 Integrated Data Store
(b)	 Integrated Data Source
(c)	 Integrated Data System
(d)	 Integrated Digital Source
� [Ans. (a) Integrated Data Store]

17.	 Which of the following model is defined with 
terminologies?
(a)	 Hierarchical		  (b)	 Relational
(c)	 Network			  (d)	 Object
� [Ans. (b) Relational]

18.	 Which of the following model is similar to 
Hierarchical model?
(a)	 Relational		  (b)	 ER
(c)	 Object oriented	 (d)	 None of these
� [Ans. (d) None of these]

19.	 Which database components not identified by 
Network model?
(a)	 Network Schema	 (b)	 Subschema
(c)	 Instance 			  (d)	 Language
� [Ans. (c) Instance]

20.	 How many terminology are there to define 
relational model?
(a)	 2	 (b)	 3	 (c)	 4	 (d)	 6
� [Ans. (a) 2]

21.	 Which of the following is a commercial 
relational model?
i.	 Oracle			   ii.	 IDS
iii.	 IMS			   iv.	 DB2
(a)	 i, ii			   (b)	 ii, iv
(c)	 i, iv			   (d)	 only iii
� [Ans. (c) i, iv]

22.	 In Relational model, which terminology 
specifies the table structure including name 
and type of each column?
(a)	 Network schema	 (b)	 Schema
(c)	 Sub Schema		  (d)	 Instance
� [Ans. (b) Schema]

23.	 Which model incorporates the OOP's concept?
(a)	 Relational		  (b)	 Network
(c)	 Object oriented 	 (d)	 ER
� [Ans. (c) Object oriented]
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24.	 Which model serves as the base of relational 
model?
(a)	 Hierarchical 		 (b)	 Network
(c)	 ER			   (d)	 Object oriented
� [Ans. (d) Object oriented]

25.	 Which model efficiently manages large 
number of different datatypes?
(a)	 Object oriented	
(b)	 Hierarchical
(c)	 Relational		
(d)	 Network and ER[Ans. (a) Object oriented]

26.	 Which one of the following is not a modern 
database systems?
(a)	 SQL			   (b)	 MySQL
(c)	 Oracle			   (d)	 Ms–Access
� [Ans. (a) SQL]

27.	 Which of the following is not a RDBMS 
Jargons?
(a)	 Key			   (b)	 List
(c)	 Tuple			   (d)	 Schema
� [Ans. (b) List]

28.	 Which of the following is a basis for SQL?
(a)	 DBMS			   (b)	 ODBMS
(c)	 Network model	 (d)	 RDBMS
� [Ans. (d) RDBMS]

29.	 Which of the following relational database 
supports different operating system platforms?
(a)	 Oracle			   (b)	 DB2
(c)	 MySQL			   (d)	 Ms–Access
� [Ans. (c) MySQL]

30.	 Which of the following is the simple 
representation of relations?
(a)	 Key			   (b)	 tuple
(c)	 Schema			   (d)	 Table
� [Ans. (d) Table]

31.	 Each column is a table is known as
(a)	 Tuple			   (b)	 Attribute
(c)	 Key			   (d)	 Schema
� [Ans. (b) Attribute]

32.	 Which one defined in a table to hold values of 
same type?
(a)	 tuple			   (b)	 row
(c)	 attribute			  (d)	 key
� [Ans. (c) attribute]

33.	 The horizontal entity in a table is known as
(a)	 column			   (b)	 tuple
(c)	 attribute			  (d)	 domain
� [Ans. (b) tuple]

34.	 A single entry in a table is called
(a)	 row			   (b)	 record
(c)	 tuple			   (d)	 all of these
� [Ans. (d) all of these]

35.	 The key that is chosen to perform the 
identification task in a table is called
(a)	 Primary key		  (b)	 Primary schema
(c)	 Primary Instance	 (d)	 Primary tuple
� [Ans. (a) Primary key]

36.	 Which of the following trust have a unique 
value for its Primary key?
(a)	 Attribute		  (b)	 Domain
(c)	 tuple			   (d)	 column
� [Ans. (c) tuple]

37.	 Which of the following key is a copy of primary 
key?
(a)	 super			   (b)	 composite
(c)	 foreign			   (d)	 all of these
� [Ans. (c) foreign]

38.	 Each super key is called a
(a)	 Composite key	 (b)	 Foreign key
(c)	 Candidate key	 (d)	 Attribute key
� [Ans. (c) Candidate key]

39.	 Which key is selected from the set of super key?
(a)	 Candidate		  (b)	 Foreign
(c)	 Primary			   (d)	 Composite
� [Ans. (a) Candidate]

40.	 A key with more than one attribute to identify 
rows originally in a table is called  
(a)	 Candidate key	 (b)	 Foreign key
(c)	 Primary key		  (d)	 Compound key
� [Ans. (d) Compound key]

41.	 A composite key is also called a
(a)	 Candidate key	 (b)	 Foreign key
(c)	 Compound key	 (d)	 Primary key
� [Ans. (c) Compound key]

42.	 Which model is generally used to know the 
concept of database design?
(a)	 Network 		  (b)	 ER
(c)	 Relational		  (d)	 Hierarchical
� [Ans. (b) ER]
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43.	 Which of the following model consists of a 
collection of entities?
(a)	 ER			   (b)	 Hierarchical
(c)	 Network			  (d)	 Relational
� [Ans. (a) ER]

44.	 ER diagram can be created with an help of 
(a)	 Entity			   (b)	 Attributes
(c)	 Relationship		  (d)	 All of these
� [Ans. (d) All of these]

45.	 The basic concepts of ER model does not 
consists
(a)	 Entity			   (b)	 Attributes
(c)	 Schema			   (d)	 Relationship
� [Ans. (c) Schema]

46.	 Which of the following can be easily identified 
in ER model?
(a)	 Schema			   (b)	 Entity
(c)	 Attribute		  (d)	 Relationship
� [Ans. (b) Entity]

47.	 Which of the following is represented by a 
rectangular box?
(a)	 Entity			   (b)	 Schema
(c)	 Relationship		  (d)	 Attribute
� [Ans. (a) Entity]

48.	 Which can be represented in only one rectangle?
(a)	 Strong entity		 (b)	 Weak entity
(c)	 Entity relationship	 (d)	 Entity instance
� [Ans. (a) Strong entity]

49.	 Which entity have primary key?
(a)	 Strong			   (b)	 Schema
(c)	 Instance			  (d)	 Weak
� [Ans. (d) Weak]

50.	 Which of the following entity is represented by 
double rectangle?
(a)	 Strong			   (b)	 Instance
(c)	 Weak			   (d)	 none of these
� [Ans. (c) Weak]

51.	 Which of the following represents the values 
of the entity?
(a)	 Schema			   (b)	 Key
(c)	 Attribute		  (d)	 Instances
� [Ans. (d) Instances]

52.	 Which of the following can describe an entity?
(a)	 Strong entity		 (b)	 Weak entity
(c)	 Attribute		  (d)	 Schema
� [Ans. (c) Attribute]

53.	 How many types of entities are there?
(a)	 3	 (b)	 4	 (c)	 2	 (d)	 5
� [Ans. (a) 3]

54.	 How many types of attributes are there?
(a)	 3	 (b)	 4	 (c)	 2	 (d)	 5
� [Ans. (d) 5]

55.	 Which attribute describes a unique 
characteristic of an entity? 
(a)	 Simple			   (b)	 Key
(c)	 Composite		  (d)	 Single valued
� [Ans. (b) Key]

56.	 Which attributes can be sub-divided into 
simple attributes without change in the 
meaning of that attribute?
(a)	 Compound		  (b)	 Single valued
(c)	 Multi valued		 (d)	 Composite
� [Ans. (d) Composite]

57.	 In which model, relationship exists between 
two entities?
(a)	 Network			  (b)	 Hierarchical
(c)	 ER			   (d)	 Relational
� [Ans. (c) ER]

58.	 How many types of relationships are available 
in ER model?
(a)	 4	 (b)	 5	 (c)	 2	 (d)	 3
� [Ans. (d) 3]

59.	 In ER model, which relationship type are in 
less usage in reality?
(a)	 one to one		  (b)	 one to many
(c)	 many to one		  (d)	 many to many
� [Ans. (a) one to one]

60.	 The number of classifications in cardinality is 
(a)	 2	 (b)	 4	 (c)	 3	 (d)	 1
� [Ans. (c) 3]

61.	 Which diagram presents data visually on how 
they are related to each other?
(a)	 Network			  (b)	 ER
(c)	 Entity			   (d)	 Schema
� [Ans. (b) ER]

62.	 Which of the following are not the form(s) of 
ER Diagram?
(a)	 Entities			   (b)	 Attributes
(c)	 Schema			   (d)	 Relationship
� [Ans. (c) Schema]
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63.	 Which symbol represents ER component 
relationship?

(a)	 			   (b)	

(c)	 		  (d)	

� [Ans. (a)  ]

64.	 MySQL is founded by
(a)	 Monty Widenius	 (b)	 Jon Postel
(c)	 Paul V Mockapetris	 (d)	 Bill gates
� [Ans. (a) Monty Widenius]

65.	 Which of the following is not a database?
(a)	 MySQL			   (b)	 Oracle
(c)	 SQL			   (d)	 Ms-Access
� [Ans. (c) SQL]

66.	 SQL current version is
(a)	 2007			   (b)	 2010
(c)	 2004			   (d)	 2003
� [Ans. (d) 2003]

67.	 Which of the following is not a database?
(a)	 DB2			   (b)	 SQL
(c)	 PostgreSQL		  (d)	 Sybase
� [Ans. (b) SQL]

68.	 Who posses the skills as database design end 
database queries?
(a)	 End user			  (b)	 developer
(c)	 DBA			   (d)	 programmer
� [Ans. (c) DBA]

69.	 Which of the following is a database?
(a)	 SQLite			   (b)	 Sybase
(c)	 DBZ			   (d)	 All of these�

� [Ans. (d) All of these]
70.	 Which databases did not meet out network 

issues efficiently?
(a)	 Heavy			   (b)	 Light
(c)	 Medium			  (d)	 Slow
� [Ans. (a) Heavy]

71.	 Which of the databases supports the web 
applications?
(a)	 Heavy			   (b)	 Medium
(c)	 Slow			   (d)	 Light
� [Ans. (d) Light]

72.	 The primary task of DBA's 
(a)	 Creation of new user
(b)	 Providing access rights
(c)	 Security and databackup
(d)	 All of these
� [Ans. (d) All of these]

73.	 The user account is activated with the access 
rights
(a)	 Insert			   (b)	 Select
(c)	 Update			   (d)	 All of these
� [Ans. (d) All of these]

74.	 All the query will terminate with
(a)	 :	 (b)	 ;	 (c)	 ,	 (d)	 ::
� [Ans. (b) ;]

75.	 A new user account can be added with values 
to the user table using
(a)	 Insert			   (b)	 Update
(c)	 Select			   (d)	 flush
� [Ans. (a) Insert]

76.	 Manual server rebooting is avoided using the 
command
(a)	 update			   (b)	 select
(c)	 flush privileges	 (d)	 alter
� [Ans. (c) flush privileges]

77.	 Which command is used for retrieving the 
inserted record? 
(a)	 Update			   (b)	 Alter
(c)	 Create			   (d)	 Select
� [Ans. (d) Select]

78.	 Which functions is there in MySQL to encrypt 
the password?
(a)	 Password () 		  (b)	 Pwd ()
(c)	 Passwd ()		  (d)	 Pass ()
� [Ans. (a) Password ()]

79.	 Which MySQL command is used to select the 
database for working?
(a)	 Select			   (b)	 Use
(c)	 Show			   (d)	 Insert
� [Ans. (b) Use]

80.	 Which command is used to list all the databases 
available?
(a)	 List			   (b)	 Use
(c)	 Show			   (d)	 Select
� [Ans. (c) Show]
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81.	 Which command used to list all the table in 
database?
(a)	 List			   (b)	 Show
(c)	 Use			   (d)	 Select
� [Ans. (b) Show]

82.	 The administrative tool of MySQL is a web 
application writtern in 
(a)	 Html			   (b)	 ASP
(c)	 Vbsript			   (d)	 PHP
� [Ans. (d) PHP]

83.	 Which of the following database tool, the 
DBA's mainly used for visualization?
(a)	 PHPMyadmin
(b)	 MySQL workbench
(c)	 HeidiSQL
(d)	 SQLEditor
� [Ans. (b) MySQL workbench]

84.	 How many major parts that forms a database?
(a)	 4	 (b)	 3	 (c)	 2	 (d)	 1
� [Ans. (b) 3 ]

85.	 Which of the following is not there to form a 
database?
(a)	 Tables			   (b)	 Queries
(c)	 Instances		  (d)	 Views
� [Ans. (c) Instances]

86.	 A set of stored queries are
(a)	 Tables			   (b)	 Instances
(c)	 Views			   (d)	 Schemas
� [Ans. (c) Views]

87.	 Which of the following is similar to excel sheet?
(a)	 Tables			   (b)	 Queries
(c)	 Views			   (d)	 None of these
� [Ans. (a) Tables]

88.	 A question with multiple conditions posted to 
the database is known as
(a)	 Tables			   (b)	 Queries
(c)	 Views			   (d)	 Schema
� [Ans. (b) Queries]

89.	 The efficiency and performance of the table 
purely depends on
(a)	 Query			   (b)	 View
(c)	 datatypes		  (d)	 data
� [Ans. (c) datatypes]

90.	 Which of the following is not a category of 
SQL command?
(a)	 DQL			   (b)	 TCL
(c)	 DCL			   (d)	 DAL
� [Ans. (d) DAL]

91.	 Which commands are used to define database 
schema?
(a)	 DDL			   (b)	 DML
(c)	 DCL			   (d)	 TCL
� [Ans. (a) DDL]

92.	 DDL expansion is 
(a)	 Definition Data Language
(b)	 Data Definition Language
(c)	 Database Definition Language
(d)	 Desktop Data Language
� [Ans. (b) Data Definition Language]

93.	 Which of the following command is belongs to 
DDL?
(a)	 Create			   (b)	 Insert
(c)	 Update			   (d)	 Delete
� [Ans. (a) Create]

94.	 Which command modifies the existing 
structure of database or table?
(a)	 Modify			   (b)	 Change
(c)	 Alter			   (d)	 Edit
� [Ans. (c) Alter]

95.	 Which DDL command used to delete all table 
records?
(a)	 DROP			   (b)	 TRUNCATE
(c)	 DELETE			  (d)	 DELETE ALL
� [Ans. (b) TRUNCATE]

96.	 DML stands for 
(a)	 Data Memory Language
(b)	 Data Management Language
(c)	 Data Manipulation Language
(d)	 Desktop Manipulation Language
� [Ans. (c) Data Manipulation Language]

97.	 Which of the following DML command deletes 
the records form the table?
(a)	 DELETE			  (b)	 DROP
(c)	 TRUNCATE
(d)	 DELETE RECORD
� [Ans. (a) DELETE]
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98.	 Which DML commands modifies existing data 
with in a table?
(a)	 MODIFY		  (b)	 RENAME
(c)	 SELECT			  (d)	 UPDATE
� [Ans. (d) UPDATE]

99.	 Which of the following is a DQL command?
(a)	 UPDATE		  (b)	 RENAME
(c)	 SELECT			  (d)	 INSERT
� [Ans. (c) SELECT]

100.	Expand DQL
(a)	 Data Query Language
(b)	 Definition Query Language
(c)	 Desktop Query Language
(d)	 Database Query Language
� [Ans. (a) Data Query Language]

101.	Which SQL used to fetch or retrieve the data 
from database?
(a)	 Fetch			   (b)	 Select
(c)	 Retrieve			   (d)	 Extract
� [Ans. (b) Select]

102.	TCL stands for
(a)	 Transfer Control Language
(b)	 Transmission Control Language
(c)	 Transaction Control Language
(d)	 Transaction Cardinality Language
� [Ans. (c) Transaction Control Language]

103.	Which of the following is not a TCL command?
(a)	 COMMIT		  (b)	 ROLL BACK
(c)	 SAVE POINT	 (d)	 ALTER
� [Ans. (d) ALTER]

104.	Which TCL command permanently save into 
database?
(a)	 SAVE			   (b)	 COMMIT
(c)	 SAVE AS		  (d)	 SAVE POINT
� [Ans. (b) COMMIT]

105.	SAVE POINT belong to
(a)	 DDL			   (b)	 DML
(c)	 DQL			   (d)	 TCL
� [Ans. (d) TCL]

106.	DCL stands for 
(a)	 Data Control Language
(b)	 Digital Control Language 
(c)	 Data Consistency Language
(d)	 Durability Control Language
� [Ans. (a) Data Control Language]

107.	Which of the following is not a logical 
operator?
(a)	 Between			  (b)	 Exists
(c)	 Unique			   (d)	 Where
� [Ans. (d) Where]

108.	Which clause of SQL command is used to 
specify the selection criteria as per the query?
(a)	 Where			   (b)	 Order
(c)	 Having			   (d)	 Join
� [Ans. (a) Where]

109.	Which operator can not be used in where 
clause?
(a)	 Arithmetic		  (b)	 Comparison
(c)	 Logical			   (d)	 Unary 
� [Ans. (d) Unary]

110.	Identical data in a table are grouped by using
(a)	 Where			   (b)	 Group by
(c)	 Order by			  (d)	 Join by
� [Ans. (b) Group by]

111.	Sub Queries are always enclosed with
(a)	 ( )			   (b)	 < >
(c)	 [ ]			   (d)	 { }
� [Ans. (a) ( )]

112.	Sub queries are used with 
(a)	 Insert			   (b)	 Update
(c)	 Delete			   (d)	 All of these
� [Ans. (d) All of these]

Choose and fill in the blanks

1.	 A ________ is a place where data can be stored, 
retrieved and managed.�
(a)	 database			  (b)	 information
(c)	 function			  (d)	 management�

� [Ans. (a) database]

2.	 _________ database model finding difficulty 
in handling many to many relationships.
(a)	 Optional			  (b)	 Hierarchical
(c)	 Relational		  (d)	 None of these�

� [Ans. (b) Hierarchical]
3.	 _________ model identified the Network 

Schema, Sub Schema and language.�
(a)	 Database		  (b)	 Relational
(c)	 Network			
(d)	 Object - oriented database�

� [Ans. (c) Network]
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4.	 The most popular relational database is 
_______.
(a)	 Database		  (b)	 DBMS
(c)	 SQL			   (d)	 MySQL�

� [Ans. (d) MySQL]
5.	 A primary key which is a combination of more 

than one attribute is called a __________.
(a)	 composite primary key		
(b)	 superkey	
(c)	 foreign key			 
(d)	 minimal superkey�

� [Ans. (a) composite primary key]
6.	 The candidate key is also known as ________.�

(a)	 composite primary key		
(b)	 minimal superkey 
(c)	 foreign key			 
(d)	 superkey� [Ans. (b) minimal super keys]

7.	 The number of entity types involved is known 
as __________.�
(a)	 Relationship instance			 
(b)	 Degree of relationship
(c)	 Cardinality			 
(d)	 None of these�

� [Ans. (b) Degree of relationship]
8.	 SQL expansion is ___________.�

(a)	 Structured Query Language	
(b)	 Stock Query Language
(c)	 Stored Query Language		
(d)	 None of these�

� [Ans. (a) Structured Query Language]
9.	 DBA frequently uses few commands to control 

the database and those commands are known 
as ____________.�
(a)	 Administration Responsibilities
(b)	 Administrative MySQL command
(c)	 MySQL Installation		
(d)	 MySQL Workbench�

� [Ans. (b) Administrative 
� MySQL command]

10.	 SQL commands are classified into ________ 
major categories.
(a)	 2			   (b)	 3
(c)	 3			   (d)	 5� [Ans. (d) 5]

11.	 The Query results are listed in ascending 
or descending order using the command 
___________.�
(a)	 where			   (b)	 having
(c)	 orderby			   (d)	 join�

� [Ans. (c) orderby]
Match the Following

1.	  A DROP (i) Restore database to 
original form

B TRUNCATE (ii) Used to delete all 
table records

C GRANT (iii) Deletes a table
D ROLL BACK (iv) Used to give 

permission to 
specific users

	 A	 B	 C	 D
(a)	 iii	 iv	 ii	 i
(b)	 ii	 iii	 iv	 i
(c)	 iii	 ii	 iv	 i
(d)	 iii	 ii	 i	 iv

[Ans.(c) A – iii; B – ii; C – iv; D – i]

Choose the incorrect pair

1.	 (i)	 Entity - Strong             – 

(ii)	 Entity - Weak	 –  

(iii)	Relationships	 – 

(iv)	Multivalued Attribute
	 for Entity		  – 

[Ans. (iii) Relationships – ]

Choose the wrong statement

1.	 (i)	� The famous Hierarchical database model 
was IMS, IBM's first DBMS.

(ii)	 Network model is finding difficulty in 
handling many to many relationships.

(iii)	Relational model is defined with instance 
and schema terminologies.

(iv)	Object oriented model server as the base of 
Hierarchical model.

(a)	 i and ii			   (b)	 ii and iv
(c)	 iii and iv			  (d)	 i, iii and iv
� [Ans. (b) ii and iv]
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Short Answers� 2 MARKS
1.	 What is DBMS?
Ans.	"A database management system (DBMS) is 

system software for creating and managing 
databases. The DBMS provides users and 
programmers with a systematic way to create, 
retrieve, update and manage data". 

2.	 How will you identify the data stored in a 
database?

Ans.	In a database, we would be grouping only related 
data together and storing them under one group 
name called table. This helps in identifying 
which data is stored where and under what 
name.

3.	 What is concurrency control and locking 
concept in DBMS?

Ans.	Concurrency control is the DBMSs mechanism 
used for data sharing. When the same data is 
shared among multiple users, proper access 
control is needed and privilege of changing the 
applications data item is controlled through 
Locking.

4.	 Write the advantages and limitations of 
Hierarchical model.

Ans.	Advantages like less redundant data, efficient 
search, data integrity and security. This model 
also has few limitations like complex to 
implement and difficulty in handling many to 
many relationships.

5.	 Write the advantages and limitations of 
Network model.

Ans.	The major advantage of this model is the ability 
to handle more relationship types, easy data 
access, data integrity and independence. The 
limitation of network model is difficulty in 
design and maintenance.

6.	 Write about the two terminologies defined in 
relational model.

Ans.	Relational model is defined with two 
terminologies Instance and Schema.
Instance : A table consisting of rows and 
columns.
Schema : Specifies the structure including name 
and type of each column.

7.	 What does the basic RDBMS concept includes?
Ans.	The basic RDBMS concept includes Database, 

Tables, Tuple, Attribute, Schema and Key which 
are discussed in RDBMS Jargons.

8.	 What is meant by table in relational database 
model?

Ans.	In relational database model, table is defined as 
the collection of data organized in terms of rows 
and columns. Table is the simple representation 
of relations. The true relations cannot have 
duplicate rows where as the table can have.

9.	 What is meant by attribute and attribute 
domain?

Ans.	The table consists of several rows and columns. 
Table can be divided into smaller parts, in terms 
of columns. Each column is known as attributes. 
The attribute is defined in a table to hold values 
of same type. This is known as Attribute Domain.

10.	 What is meant by Tuple?
Ans.	A single entry in a table is called as Row or Record 

or Tuple. Set of related data’s are represented in 
a row or tuple. The horizontal entity in a table is 
known as Record or row.

11.	 What is super key?
Ans.	An attribute or group of attributes, which is 

sufficient to distinguish every tuple in the 
relation form every other one is known as Super 
Key.

12.	 What is compound key?
Ans.	A key with more than one attribute to identify 

rows uniquely in a table is called Composite key. 
This is also known as Compound key.

13.	 What does ER model consist?
Ans.	The basic concepts of ER model consists of 

(i)	 Entity or Entity type
(ii)	 Attributes
(iii)	 Relationship

14.	 Write the different type of entity.
Ans.	Types of Entity :

(i)	 Strong Entity
(ii)	 Weak Entity
(iii)	 Entity Instance
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15.	  Write the types of attributes.
Ans.	Types of attributes :

(i)	 Key Attribute
(ii)	 Simple Attributes
(iii)	 Composite Attributes
(iv)	 Single Valued Attribute
(v)	 Multi Valued Attribute

16.	 Differentiate simple and composite attributes.
Ans.	 Simple attributes Composite attributes

The simple 
attributes cannot 
be separated it 
will be having a 
single value for 
their entity

The composite attributes 
can be sub-divided into 
simple attributes without 
change in the meaning of 
that attribute.

17.	 What is relationship instance?
Ans.	Each instance of the relationship between 

members of these entity types is called a 
relationship instance.

18.	 What is degree of a relationship?
Ans.	The number of entity types involved is known as 

Degree of relationship. ONe-Unary, Two-Binary, 
Three-Ternary.

19.	 What does the ER diagram represents?
Ans.	ER Diagram presents data visually on how they 

are related to each other. This model follows 
separate notations for representing data into 
entities, attributes and relationship between the 
entities.

20.	 Differentiate Heavy and light databases.
Ans.	Heavy databases support all the desktop 

applications whereas the web applications are 
supported by Light database. Heavy databases 
did not meet out the network issues efficiently. 
Light databases were able to handle all the issues 
raised by the network. So all the light databases 
that supports the web applications are also 
known as Web Databases.

21.	 Write the advantage of MySQL.
Ans. (i)	 MySQL is open source software that allows 

managing relational databases. 
(ii)	 It also provides the flexibility of changing 

the source code as per the needs. 
(iii)	 It runs on multiple platforms like Windows, 

Linux and is scalable, reliable and fast.

22.	 Write a note on role of Database Administrators.
Ans.	Database Administrators (DBA’s) who takes 

care of configuration, installation, performance, 
security and data backup. DBA’s posses the skills 
on database design, database queries, RDMS, 
SQL and networking. The primary task is the 
creation of new user and providing them with 
access rights.

23.	 What is the advantage of flush privileges 
command.

Ans.	mysql>FLUSH PRIVILEGES; The command 
is executed after every new account creation. 
This command is similar to rebooting the server 
so that newly created account and the access 
privilege are updated in the server. Manual 
server rebooting is avoided by this command.

24.	 What is administrative MySQL commands?
Ans.	The Database Administrator (DBA) frequently 

uses few commands to control the entire 
database. These commands are known as 
Administrative MySQL Commands.

25.	 Write the tools that is used to design the 
database.

Ans.	(i)      PhyMyadmin
(ii)	 MySQL Workbench
(iii)	 HeidiSQL

26.	 What is known as designing of databases?
Ans.	The process of creating, implementing and 

maintaining the enterprise data in a system is 
known as Designing of databases.

27.	 What are the three major parts that forms a 
database?

Ans.	The three major parts that forms a database are 
Tables, Queries and Views.

28.	 What is SQL?
Ans.	SQL- Structured Query Language is a standard 

language used for accessing and manipulating 
databases. It is declared as standard by American 
National Standards Institute (ANSI) and 
International Organization for Standardization 
(ISO) in 1986 and 1987 respectively.

29.	 What is backup?
Ans.	Backup is a program or process of copying table 

contents into a file for future reference. It’s a 
challenging task for DBA’s.
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30.	 What is primary key?
Ans.	This key of relational table identifies each record 

in the table in a unique way.

Explain in Brief Answers� 3 MARKS
1.	 Write the database components of Network 

model.
Ans.	The three database components are Network 

schema, Sub schema and Language for data 
management.
Network Schema : schema defines all about the 
structure of the database.
Sub Schema : controls on views of the database 
for the user
Language : basic procedure for assessing the 
database.

2.	 Write a short note on Object - oriented 
database model.

Ans.	Object - oriented database model :
(i)	 This model incorporates the combination 

of Object Oriented Programming (OOp's) 
concepts and database technologies.

(ii)	 Practically, this model serves as the base of 
Relational model. Object oriented model 
uses small, reusable software known as 
Objects. 

(iii)	 These are stored in object oriented 
database. This model efficiently manages 
large number of different data types. 

(iv)	 Moreover complex behaviors are handled 
efficiently using OOP's concepts.

3.	 Write the features of RDBMS.
Ans.	The features of RDBMS are 

(i)	 High Availability
(ii)	 High Performance 
(iii)	 Robust Transactions and support
(iv)	 Ease of management
(v)	 Less cost

4.	 Write a note on 'copy' of a primary key.
Ans. (i)	 A foreign key is a “copy” of a primary key 

that has been exported from one relation 
into another to represent the existence of a 
relationship between them.

(ii)	 A foreign key is a copy of the whole of its 
parent primary key i.e if the primary key is 
composite, then so is the foreign key.

(iii)	 Foreign key values do not (usually) have to 
be unique. Foreign keys can also be null. 
A composite foreign key cannot have some 
attribute(s) null and others non-null.

5.	 List the commonly used databases.
Ans.	The lists of commonly used databases

(i)	 DB2
(ii)	 MySQL
(iii)	 Oracle
(iv)	 PostgreSQL
(v)	 SQLite
(vi)	 SQLServer
(vii)	 Sybase

6.	 How will you add a new user account to the 
user table?

Ans.	A new user account is added with values to 
the user table using the following INSERT 
query in MySQL database. The Syntax for 
inserting record is INSERT INTO table name 
(Parameter1,Parameter2, Parameter3..) VALUES 
(Value1, Value2, Value3..); All the query will 
terminate with semicolon(;).
	 mysql> INSERT INTO user (host,
	 name, password, select_priv, insert_
	 priv, update_priv)
	 VALUES (‘localhost’, ‘guest’,
	 PASSWORD(‘guest123’), ‘Y’, ‘Y’, ‘Y’);

7.	 Write few administrative MySQL commands?
Ans.	A few administrative MySQL commands are

(i)	 Use database ;
(ii)	 Show database ;
(iii)	 Show tables ;
(iv)	 Show index from tablename ;
(v)	 Show columns from tablename
(vi)	 Show table status like tablename \G.

8.	 Write a note on the major parts that forms a 
database.

Ans.	The three major parts that forms a database are 
Tables, Queries and Views.
(i)	 Tables : similar to an excel sheet, containing 

multiple rows and columns. Where each 
row is a record and each column is an 
attribute. 

(ii)	 Queries : It is a question with multiple 
conditions posted to the database. The 
records in the database that satisfies the 
passed conditions are retrieved. 

(iii)	 Views : A set of stored queries.
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9.	 Write few functions performed using SQL.
Ans.	Few major functions performed using SQL are 

listed below:
(i)	 Executes queries against a database.
(ii)	 Retrieves data from database.
(iii)	 Inserts and updates records in a database
(iv)	 Delete records from database.
(v)	 Creates new databases and new tables in a 

database.

10.	 Write the five major classifications of SQL 
commands.

Ans.	Major classifications of SQL commands :
(i)	 DDL	– Data Definition Language
(ii)	 DML	– Data Manipulation Language
(iii)	 DQL	– Data Query Language
(iv)	 TCL	 – Transaction Control Language
(v)	 DCL	– Data Control Language

11.	 How will you delete record with an example.
Ans.	The existing record in a table is removed from 

the table using DELETE command. Entire 
record or specified columns in the table can be 
deleted. If we want to perform delete operation 
on specific columns, then that condition is given 
in the WHERE condition. If the condition is not 
specified, then the entire data will be deleted.
Syntax1: DELETE from tablename
WHERE columnname=”value”;
Example: mysql>DELETE from Biodata
WHERE firstname=”Mani”;

SQL Delete Record List
firstname lastname Age

Krishna S 10
Sugal S 14
Arun J 15

Syntax2 : DELETE from tablename;
Example: mysql>DELETE from Biodata ;

SQL Delete Record List
firstname lastname Age

12.	 Define (i) Record	 (ii) Query  (iii) Join.
Ans.	(i) Record : �Record is referred in a table, which 

are composed of fields.
(ii) Query : �In SQL, all commands are named 

as query. The query statement is 
executed against the databases.

(iii) Join	 : �Retrieves data from two or more 
tables, by referencing columns in 
the tables that hold identical values

Explain in Detail� 5 MARKS
1.	 Explain the following

(i)	 Foreign key		 (ii)	 Super key
(iii)	Composite key	 (iv)	Primary key

Ans.	Foreign key : 
(i)	 A foreign key is a “copy” of a primary key 

that has been exported from one relation 
into another to represent the existence of a 
relationship between them. 

(ii)	 A foreign key is a copy of the whole of its 
parent primary key i.e if the primary key is 
composite, then so is the foreign key. 

(iii)	 Foreign key values do not (usually) have to 
be unique. Foreign keys can also be null. 
A composite foreign key cannot have some 
attribute(s) null and others non-null.

Super key : 
(i)	 An attribute or group of attributes, which 

is sufficient to distinguish every tuple in 
the relation from every other one is known 
as Super Key. 

(ii)	 Each super key is called a candidate key. 
A candidate key is selected from the set of 
Super Key.

(iii)	 While selecting candidate key, redundant 
attributes should not be taken. The 
candidate key is also known as minimal 
super keys.

Composite Key :
A key with more than one attribute to identify 
rows uniquely in a table is called Composite key. 
This is also known as Compound Key.
Primary key :
(i)	 The candidate key that is chosen to perform 

the identification task is called the primary 
key and any others are Alternate keys.

(ii)	 Every tuple must have, by definition, a 
unique value for its primary key. A primary 
key which is a combination of more than 
one attribute is called a composite primary 
key.
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2.	 Explain the entity and its types with an 
example.

Ans.	An Entity can be anything a real-world object or 
animation which is easily identifiable by anyone 
even by a common man.
Eg: In a company’s database Employee, HR, 
Manager are considered as entities, where each 
of these entity will be having their own attributes. 
An entity is represented by a rectangular box.

Employee Manager

Entity
Types of Entity :
	 1.	 Strong 
	 2.	 Weak Entity
	 3.	 Entity Instance
1.	 Strong Entity :
(i)	 A Strong entity is the one which doesn’t 

depend on any other entity on the schema 
or database and a strong entity will have 
a primary key with it (i.e. a unique id 
which other entities will not have in 
their attributes). It is represented by one 
rectangle. 

(ii)	 In the above example it is a strong entity 
because it has a primary key (a unique id) 
as the roll no because for every one roll no 
varies and it will not be same.

2.	 Weak Entity :
(i)	 A weak entity is dependent on other 

entities and it doesn’t have any primary key 
like the Strong entity. It is represented by 
double rectangle.

(ii)	 Ex: Here the marks is the weak entity and 
there are no unique id or primary key for 
that entity. So they are dependent on the 
existence of the other entity.

Marks

Exam Subject Pass/Fail

Weak Entity

3.	 Entity Instance :
	� Instances are the values for the entity if 

we consider animals as the entity their 
instances will be dog, cat, cow… Etc. So an 
Entity Instance denotes the category values 
for the given entity. 

3.	 Explain ER diagram notations.
Ans.	ER diagram Notations :

ER Component
Description  
(How it is 

represented)
Notation

Entity – Strong Simple 
rectangular box

Student

Entity – Weak Double 
rectangular boxes

Relationships Rhombus symbol 
– Strong

Between 
Entities

Rhombus within 
rhombus – Weak

Attributes
Ellipse Symbol 
connected to the 
entity Student

Age

Key Attribute 
for Entity

Underline the 
attribute name 
inside Ellipse

Key Attribute

Derived 
Attributed for 
Entity

Dotted ellipse 
inside main 
ellipse

Multivalued 
Attribute for 
Entity

Double Ellipse

4.	 List and describe the SQL DDL commands.
Ans.	SQL DDL Commands List

Commands Description
CREATE Used to create database or 

tables
ALTER Modifies the existing structure 

of database or table
DROP Deletes a database or table
RENAME used to rename an existing 

object in the database
TRUNCATE Used to delete all table records

5.	 Explain the five major classifications of SQL 
commands.

Ans.	Types of SQL Commands: Different SQL 
commands are available to perform various 
functions. SQL commands are classified into 
five major categories depending on their 
functionality.
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(i)	 Data Definition Language (DDL) : The 
DDL commands are used to define database 
schema (Structure). Also to create and 
modify the structure of the database object 
in the database. CREATE, ALTER, DROP, 
RENAME and TRUNCATE commands 
belongs to this category.

(ii)	 Data Manipulation Language (DML): 
These SQL commands deals with the 
manipulation of data present in the 
database. Most of SQL commands come 
under DML. INSERT, UPDATE, and 
DELETE commands belongs to this 
category.

(iii)	 Data Query Language (DQL) : SELECT 
is the only SQL command used to fetch or 
retrieve the data from database tables that 
come under DQL.

(iv)	 Transaction Control Language (TCL): 
These SQL commands manage the 
transactions in SQL databases. It also 
helps to save the change into database 
permanently. COMMIT, ROLLBACK, 
SET TRANSACTION and SAVEPOINT 
commands belongs to this category.

(v)	 Data Control Language (DCL) : The 
SQL commands that implement security 
on database objects like table, view, stored 
procedure etc. GRANT and REVOKE 
commands belongs to this category.

6.	 Explain How will you create/Drop/Selecting 
database with an example?

Ans.	Create Database: 
Used to create new SQL Database. The Syntax 
and example to create student DB is given below.
	 Syntax: CREATE database databasename;
	� Example: �mysql>create database  

student DB;
The database created now can be viewed using 
the following Syntax,
	 mysql>Show databases;
As a result, the newly created student DB will 
be listed.
Drop Database : 
Used to remove any of the existing SQL Database. 
The Syntax and example to delete student DB is 
given below.

	 Syntax: DROP database databasename;
�	 Example: �mysql>DROP database  

student DB;
The deleted database will not be viewed,when 
we list all databases using the Syntax, Show 
databases; 
Select Database : 
Many databasesareavailable in the repository, 
from which the suitable database is selected 
using the below command.
	 Syntax: USE databasename;
	 Example: mysql>USE studentDB;
Once the database is selected, multiple 
operations are performed as per the needs of the 
application.

7.	 How will you insert and select record in the 
database table. Explain with an example.

Ans.	Insert Record : Database will have multiple 
tables. Tables are created using the create 
command with various fields added to it as per 
their need. Any table is complete only with the 
record available in it. So new row are added to 
the table using the Insert command. The Syntax 
and example for inserting new record into the 
table is given below:

Syntax 1:
INSERT INTO tablename (column1, 
column2, column3)
VALUES (value1, value2, value3);
Syntax 2:
INSERT INTO tablename VALUES 
(value1, value2, value3);

Consider we have a table named Biodata, which 
has three columns namely firstname, lastname 
and age. Now the new record is added to the 
table using either Syntax1 or Syntax2 as shown 
below.

mysql>INSERT INTO Biodata 
(firstname, lastname, age)
VALUES (Krishna, Sam, 10);

(or)
mysql>INSERT INTO Biodata 
VALUES (Krishna, Sam, 10);

Select Record: From the multiple records 
available in the table, the enquired data are 
retrieved from the table-using the SELECT 
command with some conditions specified in it. 

This is only for Sample 
for Full Book Order online and Available at all Leading Bookstores

orders@surabooks.com PH: 9600175757 / 8124201000 / 8124301000

www.su
ra

bo
ok

s.c
om



61

 Sura’s ➠ XII Std - Computer Applications

In
tr

od
uc

ti
on

 t
o 

D
at

ab
as

e 
M

an
ag

em
en

t 
S

ys
te

m

We can retrieve all the fields of a record or specify 
the necessary fields in a table. The records of 
any table are retrieved using the SELECT Syntax 
given below in Table
	 Syntax1: SELECT * from tablename;
	 Example: mysql>SELECT * from Biodata;

SQL Select Record List
Firstname Lastname Age

Krishna S 10
Sugal S 14
Arun J 15
Mani K 18

	� Syntax2: SELECT column1, column2 
from tablename;

	� Example:  mysql>SELECT firstname, age 
from Biodata;

SQL Select Record List
Firstname Age

Krishna 10
Sugal 14
Arun 15
Mani 18

8.	 Explain how will you modify and sort records 
in database table. Give an example.

Ans.	Modifying Record : SQL provides us with 
modifying and updating the existing records in 
a table using UPDATE command. The age of 
Krishna in Biodata table is changed using the 
below Syntax.
Syntax1: 	 UPDATE tablename
	 SET column1=”new value”
	 Where column2=”value2”;
Example: mysql>UPDATE Biodata SET
age=13 WHERE firstname=”Krishna”;
WHERE Clause : 
(i)	 In SQL command WHERE clause is used 

to specify the selection criteria Based on 
that data’s are retrieved or modified as per 
the query. 

(ii)	 In the WHERE conditions, operations like 
=, !=, >, >=, < , <= are used to frame the 
query statement. WHERE clause is used 
in SELECT and UPDATE query statement 
for the condition.

(iii)	 The number of records updated in a table 
depends on the WHERE condition.

Using Operators : 
(i)	 While forming the SQL query we use major 

operators like Arithmetic, Comparison 
and Logical in the WHERE clause. 

(ii)	 The purpose of each operator is listed 
below in Table

MySQL Operators
Operator Type Operator

Arithmetic 
Operator

+, –, *, /, %

Comparison 
Operator

=, !=, <, >, <>, >=, <=, 

Logical 
Operator

AND, ANY, BETWEEN, 
EXISTS, IN, LIKE, NOT, 
OR, UNIQUE

Sorting Records :
The Query results  are listed in Ascending or 
Descending order using the command ORDER 
BY. In some databases the results are sorted 
by default in Ascending order and is given in 
Syntax1. The results are displayed in descending 
order as per Syntax2. 
Syntax1: select * from tablename ORDER BY 
columnname;
Example: select * from Biodata ORDER BY 
firstname;

Select Record List
firstname lastname Age

Arun J 15
Krishna S 13
Sugal S 14


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Evaluation
PART - I

Choose the correct answer
1.	 What does PHP stand for?

(a)	 Personal Home Page
(b)	 Hypertext Preprocessor
(c)	 Pretext Hypertext Processor
(d)	 Pre-processor Home Page
� [Ans. (b) Hypertext Preprocessor]

2.	 What does PHP files have a default file 
extension?
(a)	 .html			   (b)	 .xml
(c)	 .php			   (d)	 .ph
� [Ans. (c) .php]

3.	 A PHP script should start with _______ and 
end with _______:
(a)	 <php>			   (b)	 < ? php ?>
(c)	 < ? ? >			   (d)	 < ?php ? >
� [Ans. (c) < ? ? >]

4.	 Which of the following must be installed on 
your computer so as to run PHP script?
(a)	 Adobe			   (b)	 windows
(c)	 Apache			   (d)	 IIS
� *[Ans. (c & d) Apache & IIS]

5.	 We can use ___ to comment a single line?
i) /?		 ii) //	 iii) #	 iv) /* */
(a)	 Only (ii)			
(b)	 (i), (iii) and (iv)
(c)	 (ii), (iii) and (iv)	
(d)	 Both (ii) and (iv) 
� [Ans. (c) (ii), (iii) and (iv)]

6.	 Which of the following PHP statement/
statements will store 41 in variable num?
i) int$num = 41;		  ii) intnum = 41;
iii) $num = 41;		  iv) 41 = $num;
(a)	 Both (i) and (ii)
(b)	 All of the mentioned
(c)	 Only (iii)		  (d)	 Only (i)

� [Ans. (c) Only (iii)]

7.	 What will be the output of the following PHP 
code? 
< ?php
$num = 1;
$num1 = 2;
print $num . “+”. $num1 ;
?>
(a)	 3			   (b)	 1+2
(c)	 1.+.2			   (d)	 Error

� [Ans. (b) 1+2]

8.	 Which of the following PHP statements will 
output Hello World on the screen?
(a)	 echo (“Hello World”);
(b)	 print (“Hello World”);
(c)	 printf (“Hello World”);
(d)	 sprintf (“Hello World”);� [Ans. (a,b,c)]

9.	 Which statement will output $x on the screen?
(a)	 echo “\$x”;		  (b)	 echo “$$x”;
(c)	 echo “/$x”;		  (d)	 echo “$x;

� [Ans. (a) echo "\$x";]

10.	 Which of the below symbols is a newline 
character?
(a)	 \r			   (b)	 \n
(c)	 /n			   (d)	 /r� [Ans. (b) \n]

PART - II

Short Answers

1.	 What are the common usages of PHP?
Ans. (i)	 It is very simple and lightweight open 

source server side scripting language. 
(ii)	 It can easily embed with HTML and other 

client side scripting languages like CSS 
(Cascading Style Sheets) and Java script. 

(iii)	 It also creates dynamic and interactive 
Webpages in the real time Web 
development projects.

(iv)	 It is a competitor and alternative for 
other server side scripting languages like 
Microsoft ASP (Active Server Page) and 
JSP (Java Server page).
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2.	 What is Webserver?
Ans.	A Web server is a Software that uses HTTP 

(Hypertext Transfer Protocol) to serve the files 
that form Web pages to users.

3.	 What are the types scripting language?
Ans. (i)	 PHP

(ii)	 Microsoft ASP (Active Server Page)
(iii)	 Java Server Page

4.	 Difference between Client and Server.
Ans.	 Client Server

A client machine is 
a small computer 
with a basic hardware 
configuration.

A server machine 
is a high-end 
computer with 
an advanced 
hardware 
configuration.

A client is a simple and 
less powerful machine. 

A server is 
a powerful 
expensive 
machine.

A client is used for 
simple tasks.

A server is used 
for storing huge 
data files and 
applications. 

5.	 Give few examples of Web Browser.
Ans. (i)	 UC Browser

(ii)	 Opera
(iii)	 Google chrome
(iv)	 Internet Explorer
(v)	 Firefox
(vi)	 Safari

6.	 What is URL?
Ans.	A uniform resource locator (URL) is the address 

of a resource on the internet. A URL indicates 
the location of a resource as well as the protocol 
used to access it.

7.	 Is PHP a case sensitive language?
Ans.	In PHP, variable names are case-sensitive but 

function names are not case sensitive.
8.	 How to declare variables in PHP?
Ans.	The variable in PHP begins with a dollar ($) 

symbol and the assignment activity implemented 
using “=” operator, finally the statement ends 
with semi colon “;” The semicolon indicates the 
end of statement.

9.	 Define Client Server Architecture.
Ans. (i)	 In the evolution of network architecture, 

various critical networks related problems 
are getting resolved by client server 
architecture model.

(ii)	 The client server architecture introduces 
application sharing mechanism between 
two different hardware systems over the 
network (Internet/intranet).

10.	 Define Webserver.
Ans.	Web server software that runs on server 

hardware, governs the server side scripting 
compilation into an intermediate byte-code that 
is then interpreted by the runtime engine.

PART - III

Explain in Brief Answer

1.	 Write the features of server side scripting 
language.

Ans. (i)	 Server side scripting prevents increasing of 
the load as it does not require plugins or 
browser scripting technology-overloading 
leads to problems like slow loading, high 
CPU usage and even freezing.

(ii)	 Server side scripting is necessary to run 
dynamic pages on browsers that do not 
fully support Java script.

(iii)	 Server side scripting doest not depend on 
browser processing as all the processing is 
performed on the server side.

2.	 Write is the purpose of Web server.
Ans. (i)	 A web server's main purpose is to store web 

files and broadcast them over the internet 
for you site visitor's to see.

(ii)	 In-essence, a web server is simply a 
powerful computer that stores and 
transmits data via the internet. 

(iii)	 When someone visits a web page on your 
site their browser communicates with 
your web server, sending and receiving 
information that ultimately dictates what 
appears on the visitor's computer screen. 
Thus, the main purpose of a web server is 
to store and transfer web site data upon the 
request of a visitor's browser. 
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3.	 Differentiate Server side and Client Side 
Scripting language.

Ans. (i)	 Web scripting languages are classified 
into two types, client side and server side 
scripting language. 

(ii)	 PHP is completely different from Client 
side scripting language like Java script.

(iii)	 The PHP code entirely executes on 
Webserver which is installed in the remote 
machine and it is generating HTML code 
which is sent to the user.

(iv)	 The user receives the HTML code and sees 
the Website contents via Internet browser 
in their computer or laptop.

(v)	 PHP also supports OOPs (Object Oriented 
Programing) concepts. 

(vi)	 It is applicable to implement all OOPs 
features such as class, object and 
inheritance etc.

4.	 In how many ways you can embed PHP code in 
an HTML page?

Ans.	The PHP code embed in a HTML page in only 
one way.

5.	 Write short notes on PHP operator.
Ans.	Operator is a symbol which is used to perform 

mathematical and logical operations in the 
programing languages. Different types of 
operator in PHP are:
(i)	 Arithmetic operators,
(ii)	 Assignment operators,
(iii)	 Comparison operators,
(iv)	 Increment/Decrement operators,
(v)	 Logical operators, and
(vi)	 String operators. 

PART - IV

Explain in Detail

1.	 Explain client side and server side scripting 
language.

Ans. (i)	 Web scripting languages are classified 
into two types, client side and server side 
scripting language. 

(ii)	 PHP is completely different from Client 
side scripting language like Java script.

(iii)	 The PHP code entirely executes on 
Webserver which is installed in the remote 
machine and it is generating HTML code 
which is sent to the user.

HTTP response

HTTP request

Executive PHP code

Web broswer

Web Server

PHP

Website Request and Response from 
Web server to Browser

(iv)	 The user receives the HTML code and sees 
the Website contents via Internet browser 
in their computer or laptop.

(v)	 PHP also supports OOPs (Object Oriented 
Programing) concepts. 

(vi)	 It is applicable to implement all OOPs 
features such as class, object and 
inheritance etc.

2.	 Discuss in detail about Website development 
activities.

Ans.	Web development concept describes in detail 
about Website development and hosting 
through network (Internet/Intranet). The 
process of development also includes Web 
content generation, Web page designing, 
Website security and so on.
1.	 PHP Script Work :
(i)	 Website or Web page is developed by the 

programmer using PHP script. Finally the 
entire Website codes are moved to Web 
server path in a remote server machine. 

(ii)	 From client side, the end user opens a 
browser, types the URL of the Website 
or Webpage and initiates the request to 
remote server machine over the network. 

(iii)	 After receiving the request from client 
machine the Web server tries to compile 
and interpret the PHP code which is 
available in remote machine. 

(iv)	 Next a response will be generated and 
sent back to the client machine over the 
network from Webserver.

(v)	 Finally the browser which is installed in 
the client machine receives the response 
and displays the output to user.
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2.	� PHP Syntax : 
	� Three types of PHP Syntax are available. 

They are as follows
	 1.	 Default Syntax
	 2.	 Short open Tags
	 3.	 HTML Script embed Tags
Default Syntax : The default Syntax begins with 
“<?php” and closes with “?>”.

Opening PHP tag

Ouput
one or more string

End of statement

<? ?>echophp “Hello world...” ;

String Closing PHP tag

PHP Syntax

Short open Tags : The Short open Tags begins 
with “<?” and closes with “?>”. But admin user 
has to enable Short style tags settings in php.ini 
file on the server.

Opening PHP tag

Ouput
one or more string

End of statement

?>echo “Hello world...” ;

String Closing PHP tag

 PHP Short Syntax

HTML Script embed Tags: HTML Script 
embed Tags looks just like HTML scripts tags.

HTML Syntax

The above syntax is created and saved in a file 
with extension of .php. This .php file is ready to 

execute from Webserver and generate response 
to client machine.
3.	 Embed PHP in HTML : 
(i)	 PHP script can be written in side of HTML 

code and save the file with extension of 
.php. 

(ii)	 The embedded PHP file get executed in the 
Webserver, the browser receives only the 
HTML and other client side files. 

(iii)	 None of the raw PHP code is visible in 
browser which means that PHP interpreter 
produces raw HTML files to browsers in 
the client machine.

3.	 Explain the process of Webserver installation.
Ans.	The following are the steps to install and 

configure Apache Httpd Webserver and PHP 
module in windows server machine.
(i)	 Step 1: Go to Apache foundation Website 

and download the Httpd Webserver 
Software.

	 https://httpd.apache.org/download.cgi
(ii)	 Step 2: After downloading .MSI file from 

Apache foundation Website, user launches 
the .MSI file and clicks next and next button 
to finish the installation on server machine. 
The software takes default port number 130 
or 130130. Once the user finished, the Web 
server software is installed and configured 
on server hardware machine as a service.

(iii)	 Step 3: To test the installation of Apache 
Httpd Webserver, enter the following URL 
from your Web browser which is installed 
in your client machine. 

	 https://localhost:130/ or  
	 https://localhost:130130
The output page that says “Its works”
(iv)	 Step 4: Administrator user can start, stop 

and restart the Web server service at any 
time via windows Control panel. Once the 
services stops, the client machine will not 
receive the response message from server 
machine.

(v)	 Step 5: Webserver’s configuration setting 
file “httpd.conf” is located in the conf 
directory under the apache installation 
directory. Edit this file and enable the PHP 
module to run PHP scripting language.
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4.	 Discuss in detail about PHP data types.
Ans.	PHP scripting language supports 13 primitive 

data types. Data Types plays important role 
in all programing languages to classify the 
data according to the logics. PHP supports the 
following data types.
(i)	 String		
(ii)	 Integer
(iii)	 Float
(iv)	 Boolean
(v)	 Array
(vi)	 Object
(vii)	 NULL
(viii)	Resource
String :  String is a collection of characters within 
the double or single quotes like “Computer 
Application” or ‘Computer Application’. Space 
is also considered as a character.
	 Example:

<?php
$x = “Computer Application!”;
$y = ‘Computer Application’;
echo $x;
echo “<br>”;
echo $y;
?>

Integer: Integer is a data type which contains 
non decimal numbers.
	 Example:

<?php
$x = 59135;
var_dump($x);
?>

The var_dump() system define function, returns 
structured information (type and value) about 
variables in PHP.
Float: Float is a data type which contains decimal 
numbers.

Example:
<?php
$x = 19.15;
var_dump($x);
?>

Boolean: Boolean is a data type which denotes 
the possible two states, TRUE or FALSE

Example:
<?php
$x = true;
$y = false;
echo $x;
echo $y;
?>

Array: Array is a data type which has multiple 
values in single variable.

Example:
<?php
$cars = array(“Computer”,”Laptop”,”Mobile”);
var_dump($cars);
?>

OUTPUT:
array(3) { [0]=> string(5) “Computer“ [1]=>
string(3) “Laptop“ [2]=> string(6) “Mobile“}

Var_dump: The var_dump() function is used 
to dump information about a variable. This 
function displays structured information such 
as type and value of the given variable. Arrays 
and objects are explored recursively with values 
indented to show structure.
Object: PHP object is a data type which contains 
information about data and function inside the 
class.

<?php
class School {
	 function marks() {
			   $this->sec = “A”;
		  }
	 }
// create an object
$school_obj = new School ();
// show object properties
echo $school_obj ->sec;
?>

NULL: Null is a special data type which contains 
a single value: NULL

<?php
$x = “COMPUTER APPLICATION!”;
$x = null;
var_dump($x);
?>
OUTPUT:
NULL

Resources : Resource is a specific variable, it 
has a reference to an external resource. These 
variables hold specific handlers to handle files 
and database connections in respective PHP 
program.

<?php
// Open a file for reading
$handle = fopen(“note.txt”, “r”);
var_dump($handle);
echo “<br>”;
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// Connect to MySQL database server with
default setting
$link = mysql_connect(“localhost”, “root”,
“”);
var_dump($link);
?>

5.	 Explain operators in PHP with example.
Ans.	Operator is a symbol which is used to perform 

mathematical and logical operations in the 
programing languages. Different types of 
operator in PHP are:
(i)	 Arithmetic operators,
(ii)	 Assignment operators,
(iii)	 Comparison operators,
(iv)	 Increment/Decrement operators,
(v)	 Logical operators, and
(vi)	 String operators. 
Arithmetic operators : The arithmetic operators 
in PHP perform general arithmetical operations, 
such as addition, subtraction, multiplication and 
division etc.

PHP Arithmetic operators
Symbol Operator Name Purpose

+ Addition This operator 
performs the 
process of adding 
numbers

– Subtraction This operator 
performs the 
process of 
subtracting 
numbers

* Multiplication This operator 
performs the 
process of 
multiplying 
numbers

/ Division This operator 
performs the 
process of dividing 
numbers

% Modulus This operator 
performs the 
process of finding 
remainder in 
division operation 
of two numbers

Assignment Operators: Assignment operators 
are performed with numeric values to store 
a value to a variable. The default assignment 
operator is “=”. This operator sets the left side 
operant value of expression to right side variable.

PHP Assignment operators
Assignment Similar to Description
x = y x = y This operator sets 

the left side operant 
value of expression 
to right side 
variable

x + = y x = x + y Addition

x - = y x = x – y Subtraction

x * = y x = x * y Multiplication

x / = y x = x / y Division

x % = y x = x % y Modulus

Comparison Operators: Comparison operators 
perform an action to compare two values. These 
values may contain integer or string data types 
(Number or Strings).

PHP Comparison operators
Symbol Operator 

Name
Symbol Operator Name

= = Equal > Greater than

= = = Identical < Less than

!= Not equal >= Greater than or 
equal to

<> Not equal <= Less than or 
equal to

!= = Not 
identical

Increment and Decrement Operators: 
Increment and decrement operators are used 
to perform the task of increasing or decreasing 
variable’s value. This operator is mostly used 
during iterations in the program logics.
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PHP Increment and Decrement operators
Operator Name Description

++$x Pre-increment Increments $x value by one, then returns $x

$x++ Post-increment Returns $x, then increments $x by one

--$x Pre-decrement Decrements $x by one, then returns $x

$x-- Post-decrement Returns $x, then decrements $x by one

Logical Operators: Logical Operators are used to  combine conditional statements.

PHP Logical operators
Symbol Operator Name Example Result

&& And $x && $y True if both $x and $y are true

|| Or $x || $y True if either $x or $y is true

! Not !$x True if $x is not true

xor Xor $x xor $y True if either $x or $y is true, but not both

String Operators : Two operators are used to perform string related operations such as Concatenation 
and Concatenation assignment (Appends).

PHP String operators
Operator Name Example Result
. Concatenation $text1 .$ text 2 Concatenation of $txt1 and $txt2

.= Concatenation assignment $text1 .=$ text2 Appends $txt2 to $txt1

additional questions and answers

Choose the Correct Answer� 1 MARK 

1.	 Who introduced the concept of Internet and 
world wide web?
(a)	 Bill gates			  (b)	 Tim Berners Lee
(c)	 Jame Gonsling	 ( d)	Dennis Ritchie
� [Ans. (b) Tim Berners Lee]

2.	 WWW expansion is
(a)	 World Wide Web	
(b)	 World Web Wide
(c)	 Wide World Web	
(d)	 Web World Wide
� [Ans. (a) World Wide Web]

3.	 Which is one of the most widely used and 
recognizable technologies in use on the 
internet?
(a)	 MySQL			   (b)	 SQL
(c)	 PHP			   (d)	 HTML
� [Ans. (c) PHP]

4.	 Which of the following is a fundamental part 
of any dynamic webpage?
(a)	 SQL			   (b)	 HTML
(c)	 Pagemaker		  (d)	 PHP
� [Ans. (d) PHP]

5.	 Which one of the following is the important 
server side web and general purpose scripting 
language? 
(a)	 Javascript		  (b)	 PHP
(c)	 VB script		  (d)	 SQL
� [Ans. (b) PHP]

6.	 PHP invented by
(a)	 Tim Berner's Lee	 (b)	 Dennis Ritchie
(c)	 Rasmus Lerdorf	 (d)	 Ken Thomson
� [Ans. (c) Rasmus Lerdorf]
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15.	 The current version of php is

(a)	 3.7			   (b)	 7.3
(c)	 8.7			   (d)	 7.4
� [Ans. (b) 7.3]

16.	 Which of the following is a high performance 
hardware machine it could run more than one 
application concurrently?
(a)	 Client			   (b)	 Server
(c)	 CGI			   (d)	 JSP
� [Ans. (b) Server]

17.	 Which is a hardware machine which connected 
with server in the network?
(a)	 IIS			   (b)	 Apache Tomcat
(c)	 Client			   (d)	 None of these
� [Ans. (d) None of these]

18.	 How many classifications are their in client-
server Architecture?
(a)	 2	 (b)	 4	 (c)	 5	 (d)	 3
� [Ans. (d) 3]

19.	 How many classifications are there in web 
scripting language?
(a)	 2			   (b)	 3
(c)	 4			   (d)	 many
� [Ans. (a) 2]

20.	 How many percentage of websites are running 
under the open source web servers?
(a)	 100%			   (b)	 110%
(c)	 120%			   (d)	 130%
� [Ans. (d) 130%]

21.	 Which of the following is not a open source 
web servers?
(a)	 Apache Tomcat	 (b)	 Microsoft IIS
(c)	 Nginx			   (d)	 all of these
� [Ans. (b) Microsoft IIS]

22.	 The process of web development includes
(a)	 Web content generation
(b)	 Web page designing
(c)	 Web site security	 (d)	 all of these
� [Ans. (d) all of these]

23.	 How many types of PHP Syntax are available? 
(a)	 2	 (b)	 4	 (c)	 3	 (d)	 6
� [Ans. (c) 3]

7.	 PHP invented in the year
(a)	 1991			   (b)	 1992
(c)	 1993			   (d)	 1994
� [Ans. (d) 1994]

8.	 CSS expansion is
(a)	 Cascading Style Sheets
(b)	 Cascading Side Sheets
(c)	 Consolidated Style Sheets
(d)	 Compiled Style Sheets
� [Ans. (a) Cascading Style Sheets]

9.	 Which of the following is a server side scripting 
language?
(a)	 CSS			   (b)	 Javascript
(c)	 PHP			   (d)	 Python
� [Ans. (c) PHP]

10.	 Which of the following is a client side scripting 
language?
(a)	 PHP			   (b)	 CSS
(c)	 ASP			   (d)	 JSP
� [Ans. (b) CSS]

11.	 JSP stands for
(a)	 Java Script Page	 (b)	 Java Server Page
(c)	 Java Sheet Page
(d)	 Java Server Processor
� [Ans. (b) Java Server Page]

12.	 CGI stands for
(a)	 Common Gateway Interface
(b)	 Consistency Gateway Interface
(c)	 Common Gateway Information
(d)	 Common Gateway Intelligent
� [Ans. (a) Common Gateway Interface]

13.	 In Microsoft IIS, IIS stands for
(a)	 Internet Information Server
(b)	 Information Internet Server
(c)	 Internet Information System
(d)	 Internet Information Script
� [Ans. (a) Internet Information Server]

14.	 Which of the following is not a webserver?
(i)	 Apache Tomct	 (ii)	 PHP
(iii)	Microsoft ISS
(iv)	Active Server Pages
(a)	 i and ii			   (b)	 ii and iii
(c)	 i and iii			   (d)	 ii and iv
� [Ans. (d) ii and iv]
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24.	 Which of the following is not a type of PHP 
Syntax?
(a)	 Default Syntax	 (b)	 Short open tags
(c)	 HTML script embed tags
(d)	 Script open Tags
� [Ans. (d) Script open Tags]

25.	 The short open Tags begins with
(a)	 <?....?>	 		  (b)	 <?php?>
(c)	 ?<....<?			   (d)	 <!...!>
� [Ans. (a) <?....?>]

26.	 The variable in PHP beging with 
(a)	 @	 (b)	 =	 (c)	 !	 (d)	 $
� [Ans. (d) $]

27.	 The PHP statement always ends with
(a)	 :	 (b)	 ;	 (c)	 ,	 (d)	 .
� [Ans. (b) ;]

28.	 How many datatypes supported by PHP 
scripting language?
(a)	 11	 (b)	 12	 (c)	 10	 (d)	 13
� [Ans. (d) 13]

29.	 Which of the following datatype enclosed with 
in single or double quotes?
(a)	 Resource		  (b)	 String
(c)	 Boolean			   (d)	 NULL
� [Ans. (b) String]

30.	 Non decimal numbers are called
(a)	 Float			   (b)	 NULL
(c)	 Array			   (d)	 Integer
� [Ans. (d) Integer]

31.	 Which of the following is not a datatype?
(a)	 String			   (b)	 Var-dump( )
(c)	 Array			   (d)	 Resource
� [Ans. (b) Var-dump( )]

32.	 Which of the following function returns 
structured information about variables in 
PHP?
(a)	 String ( )			  (b)	 Variable ( )
(c)	 Var-dump( )		 (d)	 dump-var( )
� [Ans. (c) Var-dump ( )]

33.	 Which datatype contains decimal numbers?
(a)	 Float			   (b)	 Integer
(c)	 NULL			   (d)	 Array
� [Ans. (a) Float]

34.	 Which datatype returns true or false?
(a)	 Boolean			   (b)	 NULL
(c)	 Resource		  (d)	 None of these
� [Ans. (a) Boolean]

35.	 Which datatype have multiple values in single 
variable?
(a)	 NULL			   (b)	 Resource
(c)	 Boolean			   (d)	 Array
� [Ans. (d) Array]

36.	 Which datatype contains information about 
data and function inside the class?
(a)	 Var-dump( )		 (b)	 String
(c)	 Object			   (d)	 NULL
� [Ans. (c) Object]

37.	 Which of the following is a special datatype?
(a)	 Var-dump( )		 (b)	 NULL
(c)	 Object			   (d)	 String
� [Ans. (b) NULL]

38.	 Which of the following variables handles files 
and database connections in respective PHP 
program?
(a)	 Var-dump( )		 (b)	 Object
(c)	 NULL			   (d)	 Resources
� [Ans. (d) Resources]

39.	 Which operator finds remainder of two 
interger numbers?
(a)	 /	 (b)	 ==	 (c)	 %	 (d)	 //
� [Ans. (c) %]

40.	 Which operator denotes identical?
(a)	 ==			   (b)	 =
(c)	 =+			   (d)	 ===
� [Ans. (d) ===]

41.	 Which of the following is not a logical 
operator?
(a)	 !			   (b)	 XOR
(c)	 ¦¦			   (d)	 .=
� [Ans. (d) .=]

42.	 Which operator used for string concatenation?
(a)	 .	 (b)	 :	 (c)	 +	 (d)	 :+
� [Ans. (a) .]

43.	 Which operator appends string1 with string2?
(a)	 .	 (b)	 .+	 (c)	 .=	 (d)	 . .
� [Ans. (c) . =]
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Choose and fill in the blanks

1.	 _________ and ________ online applications 
are performing very important role in business 
and entertainment industry.  �
(a)	 Internet, web based			 
(b)	 Web based, scripting languages
(c)	 HTML, PHP		
(d)	 None of these�

� [Ans. (a) Internet, Web based]

2.	 PHP can easily embed with ______ and _____.
(a)	 HTML, PHP		 (b)	 HTML, CSS
(c)	 ASP, PHP		  (d)	 CSS, PHP�

� [Ans. (b) HTML, CSS]

3.	 HTML stands for _________.�
(a)	 Hyper Text Marking Language		
(b)	 Hyper Text Marketing Language
(c)	 Hyper Text Markup Language		
(d)	 Hyper Tags Markup Language�

� [Ans. (c) Hyper Text Markup Language]

4.	 PHP interpreter module supported by 
_________ and ________ web servers.�
(a)	 Apache Tomcate, Microsoft IIS	
(b)	 Adobe, Windows	
(c)	 CGI, Windows	
(d)	 None of these�

�[Ans. (a) Apache Tomcate, Microsoft IIS]

5.	 __________ introduces application sharing 
mechanism between two different hardware 
systems over the network.�
(a)	 Web server Architecture		
(b)	 Client-server Architecture
(c)	 Both 'a' and 'b'	
(d)	 None of these�

� [Ans. (b) Client-server Architecture]

6.	 Client side and server side are the classification 
of _________ . �
(a)	 Web scripting languages
(b)	 PH scripting languages
(c)	 SQL scripting languages			 
(d)	 None of these�

� [Ans. (a) Web scripting languages]
7.	 _________ are the storage location, which can 

store the values for the later manipulations in 
the program.�
(a)	 Constant		  (b)	 Variable
(c)	 Operator		  (d)	 Literals�

� [Ans. (b) Variable]

Match the Following

1.	  A % (i) Assignment operator
B += (ii) Increment operator
C === (iii) Logical operator
D ++$x (iv) Arithmetic operator
E Xor (iv) Comparison operator

	 A	 B	 C	 D	 E
(a)	 iv	 i	 v	 ii	 iii
(b)	 iv	 v	 i	 ii	 iii
(c)	 iv	 i	 v	 iii	 ii
(d)	 i	 iv	 v	 ii	 iii

[Ans.(a) A – iv; B – i; C – v; D – ii, E – iii]

Choose the incorrect pair

1.	 (a)	 ==	     – Equal
(b)	 ===	 – Identical
(c)	 < >	 – Not identical
(d)	 !=	 – Not equal
� [Ans. (c) < > – Not identical]

Choose the wrong statement

1.	 (i)	 Variable name always begin with a = symbol
(ii)	 Variable name can always starts with an 

alphabet
(iii)	Variable name are case sensitive
(iv)	Variable declaration requires datatype 

keyword separately
(a)	 i, ii			   (b)	 ii, iii, iv
(c)	 ii, iv			   (d)	 iii, iv
� [Ans. (c) ii, iv]

2.	 (i)	 PHP is an open source
(ii)	 PHP is not a case sensitive
(iii)	PHP is a efficient programming language
(iv)	PHP is not a flexible programming language
(a)	 i and ii			   (b)	 ii and iv
(c)	 ii and iii			   (d)	 i and iv
� [Ans. (b) ii and iv]
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Short Answers� 2 MARKS
1.	 Write a note on PHP.
Ans.	PHP is one of the most widely used and 

recognizable technologies in use on the internet. 
Originally PHP stood for "Personal Home Page", 
though more recently it has been changed to 
stand for "PHP: Hypertext Preprocessor". PHP 
is a fundamental part of any dynamic web page.

2.	 How the PHP scripting language is executed?
Ans.	PHP scripting language can be executed via an 

interpreter which is installed in the Webservers 
or CGI (Common Gateway Interface). The most 
of the Webservers such as Apache Tomcat, 
Microsoft IIS (Internet Information server) 
supports the PHP interpreter module.

3.	 Name the web servers that supports PHP 
interpreter module.

Ans. (i)	 Apache Tomcat
(ii)	 Microsoft ISS

4.	 Write the advantage of the PHP variable 
declaration.

Ans.	The main advantage of the PHP variable 
declaration is, it does not requires to specify the 
data type keyword separately such as int, char, 
float, double or string etc.

5.	 What is HTTP?
Ans.	HTTP means HyperText Transfer Protocol. 

HTTP is the underlying protocol used by the 
World Wide Web and this protocol defines how 
messages are formatted and transmitted, and 
what actions Web servers and browsers should 
take in response to various commands.

6.	 What is server?
Ans.	A server is a computer or a device that provides 

functionality for other programs or devices, 
called “clients”. This architecture is called 
the client server model, and a single overall 
computation is distributed across multiple 
processes or devices.

Explain in Brief Answers.�3 MARKS

1.	 What is web scripting language? Write its 
advantage.

Ans. (i)	 Internet and World Wide Web 
(WWW). Concepts required a new set of 
programming languages over the network 
communication.

(ii)	 These programming languages are recently 
called as Web scripting languages.

(iii)	 The Web scripting languages has many 
policies which is easy to handle and solve 
the critical business problems around the 
world.

2.	 Write the classification of client server 
Architecture model.

Ans.	Client server architecture classified into three 
types, as follows
(i)	 Single Tier Architecture
(ii)	 Two Tier Architecture
(iii)	 N/Multi/Three tire architecture

3.	 How PHP script works?
Ans.	PHP Script works :

(i)	 Website or Web page is developed by the 
programmer using PHP script. Finally the 
entire Website codes are moved to Web 
server path in a remote server machine. 

(ii)	 From client side, the end user opens a 
browser, types the URL of the Website 
or Webpage and initiates the request to 
remote server machine over the network. 

(iii)	 After receiving the request from client 
machine the Web server tries to compile 
and interpret the PHP code which is 
available in remote machine. 

(iv)	 Next a response will be generated and 
sent back to the client machine over the 
network from Webserver.

(v)	 Finally the browser which is installed in 
the client machine receives the response 
and displays the output to user.

4.	 Write the types of PHP syntax.
Ans.	Three types of PHP Syntax are available. They 

are as follows 
(i)	 Default Syntax
(ii)	 Short open Tags
(iii)	 HTML Script embed Tags

5.	 Write the basic rules for variable declaration.
Ans.	Basic Rules for Variable Declaration :

(i)	 Variable name must always begin with a $ 
symbol.

(ii)	 Variable name can never start with a 
number.

(iii)	 Variable names are case-sensitive.
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Explain in Detail� 5 MARKS
1.	 Explain types of client server Architecture 

model.
Ans.	Client server architecture classified into three 

types, as follows
1.	 Single Tier Architecture
2.	 Two Tier Architecture
3.	 N/Multi/Three tire architecture

Single Tier Architecture :
(i)	 This architecture is used for the server, 

accessed by client.
(ii)	 The client application runs inside the 

server machine itself.
(iii)	 This acts as a single layer interaction.

Client computers

1-Tier Architecture

File server

Single Tier Architecture

Two Tier Architecture :
(i)	 This architecture is used for the server, 

accessed by client as two layer interactions. 
(ii)	 Such as Client layer in tire one and server 

layer in tire Two.

Client Tier

Database Tier

2-Tier Architecture

Database Server

 Two- Tier Architecture 

N/Multi/Three tire architecture :
(i)	 This architecture is used for the server, 

accessed by client through more than one 
layer interaction. 

(ii)	 The programmer could decide the count 
of business logic layers according to the 
software requirement that is the reason 
this model is also known as Multi Three 
Tire Architecture.

Client Tier

Business Logic
Tier

Application Server

Database Tier

3-Tier Architecture

Database
Server

Multi/�ree- Tier Architecture 

(iii)	 Most of the server side scripting languages 
are working on any one the client server 
architecture model.

(iv)	 Webserver is software which is running in 
server hardware. 

(v)	 It takes the responsibilities for compilation 
and execution of server side scripting 
languages.

2.	 Write the characteristics of PHP.
Ans.	Characteristics of PHP :

(i)	 PHP is an Open Source
(ii)	 PHP is a Case Sensitive
(iii)	 PHP is a Simplicity Program language
(iv)	 PHP is a Efficiency Program language
(v)	 PHP is a Platform Independent Program 

language
(vi)	 PHP is a Security Program language
(vii)	 PHP is a Flexibility Program language
(viii)	PHP is a Real-Time Access Monitoring 

Program language


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